Volumio and FiiO E10 OLYMPUS


I have been using succesfully the previous version of Volumio with my FiiO E10 OLYMPUS DAC (on Raspberry PI).
I have now installed the last version of Volumio (volumio-2.031-2016-11-23-pi.img).

The DAC is not recognised. In Playback options if I try to select USB:audio for Output Device it revert to “Audio jack”.
No problem instead with an Asus Sonar U3.
Any hint?

Thank you

Mario, Italy

Any hint on how to track the problem?
This dac was supported in the previous Volumio version.



Probably there’s a problem with the output selector, not the dac itself… Try to reboot, select your dac and hit save.

Let me know

Dear Michelangelo

Even after a reboot the situation does not change.
I select USB audio and it is selected
I click save…and it reverts to “audio jack”

I have two different versions of the same DAC. They do not work.
With a different DAC, it works.

Thank you


Just to report something similar here.

I am able to get the DAC working (as per michaelangelo’s suggestion) via

  • select “USB: Audio” in Playback Options -> Output Device
  • Hit save (instantly refreshes to “Audio jack”)
  • Reboot
  • Still says “Audio” (not even “Audio Jack”; that’s only visible when you expand the dropdown)
  • DAC works though

Volumio version: 2.041 on raspberry pi 3 model b

DAC: Fiio Olympus 2-E10K

[ 4.210454] usb 1-1.3: New USB device found, idVendor=1852, idProduct=7022
[ 4.218309] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 4.226545] usb 1-1.3: Product: DigiHug USB Audio
[ 4.232091] usb 1-1.3: Manufacturer: FiiO
[ 4.250753] input: FiiO DigiHug USB Audio as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.0/0003:1852:7022.0001/input/input0
[ 4.323842] hid-generic 0003:1852:7022.0001: input,hidraw0: USB HID v1.00 Device [FiiO DigiHug USB Audio] on usb-3f980000.usb-1.3/input0

Interesting… seems that the fact that your device is called Audio, tricks a bug! :wink:
thanks for reporting!

Just in case it’s of any use to demo what I see, screenshots attached. Audio here refers to “Audio Jack”, which should be standard for all Pis, right? USB audio is what I’d really want to select :slight_smile:

Default display

Dropdown selected.

If there’s any more useful logs I could grab from it all, let me know, happy to help. Or equally could file a bug report if it’d help?

I also confirm that in the end the dac works even if the selector tells you differently.

Thank you!