Volumio 3 + touch Display not working (7" Raspberry screen)

Hi folks,
First of all, all the best for 2022 , wish you success, health and time to listen to great music.

I’ve recently upgraded my Volumio to V3. however the touch display is not working, no UI is getting displayed (still get the bash).
I tried to uninstall and reinstall the plugin, also did a clean install of v3 but I still have the same issue.
from the log : error: touch_display: Connecting to the Xserver failed.
error: touch_display: Xserver unix domain socket cannot be determined.

i also saw that the date was not correct on the device (seems to be wifi related, still wip)


  • OS info

  • Version of Volumio: 3.179

  • Hostname: {hidden}

  • Kernel: 5.4.83-v7+

  • Governor: performance

  • Uptime: 0 days, 2 Hrs, 31 Minutes, 35 Seconds

  • Audio info

  • Hw audio configured: HiFiBerry DAC Plus

  • Mixer type: Hardware

  • Number of channels:

  • Supported sample rate:

  • Board info

  • Manufacturer: Raspberry Pi Foundation

  • Model: Raspberry Pi 3 Model B Plus Rev 1.3

  • Version: a020d3

  • Firmware Version: Jan 8 2021 14:33:35 - 194a85abd768c7334bbadc3f1911c10a7d18ed14

  • CPU info

  • Brand: BCM2837

  • Speed: 1.4Ghz

  • Number of cores: 4

  • Physical cores: 4

  • Average load: 3%

  • Temperature: 58°C

  • Memory info

  • Memory: 991696 Ko

  • Free: 349940 Ko

  • Used: 641756 Ko

  • Storage info

  • INTERNAL storage - Size: 26908Mo

  • Used: 28Mo

  • Available for storage: 25488Mo (95%)

What’s the version of the Touch Display plugin?

Did you wait several minutes after Volumio’s first boot so the data partition could fully expand? On a system where the data partition had not been expended there is typically not enough space for all the software the Touch Display plugin needs.

If you are sure your system is not lacking disk space, I recommend to uninstall the plugin (again).

Then enable “Plugins Test Mode” on //volumio.local/dev and re-install beta version 3.3.2 of the plugin.

This new version of the plugin aborts (and rolls back) the plugin’s installation process if downloading/installing of one of the required software packages (xorg, chromium etc.) fails. Unlike before, now the plugin would not even appear in the list of installed plugins if a software download should have failed.

So, if you do not find the plugin in the list of installed plugins after the installation process has finished, it is because an error occurred during its installation. Maybe check your internet connection (especially for DNS problems) and try to install the plugin again.

Hi gvolt,

thanks for the reply, I am using 3.3.1. the issue seems to be solved, the cause was the date of the raspberry pi not up to date, causing certificate issue while trying to download the plugin component.
i had to manually set the date (ntpd -q -g was somehow not working) with a date -s +wget. once done I uninstalled the plugin, restarted, and installed the plugin again, looking at the log I saw a huge difference as many component were downloaded this time.

in a nutshell ntp was to blame but I played a bit with the initial setup of the volumio, it might be something with network initiation failing through wifi (works better through LAN but not perfect).


Thank you for the feedback.

Yes, either download errors or too less space on the data partition are typically the causes for the error message you had. In both cases the software needed by the plugin to work doesn’t get installed (completely). Therefore version 3.3.2 of the plugin has been changed in that it will abort its installation process if an error occurs while downloading/installing the required software packages.

This happened to me too on v3, but not on v2. My ISP blocks NTP ports, which has caused issues for me before. Once I set the date/time manually, the plugin installed successfully.

I’m curious what changed from v2 to v3 with date/time?

When I was experiencing the issue initially, the Touchscreen plugin installation would say it was completed, but it only took about 15-20 seconds. Didn’t get notified of an error or anything, so I assumed it worked. I didn’t realize at the time that the installation should take much longer and nothing else clued me in on the failed install.

Since version 3.3.2beta of the plugin the plugin’s installation process aborts (and rolls back), if downloading/installing of one of the required software packages (xorg, chromium etc.) fails. Unlike before, now the plugin would not even appear in the list of installed plugins if a software download should have failed.

To get beta versions of plugins you need to enable “Plugins Test Mode” on //volumio.local/dev. Then in the plugin store click on the “Details” button for the plugin and choose “Install vX.X.X (beta)”. If the plugin is already installed, you need to uninstall it first (IIRC).

Using the latest normal touchscreen plugin and after that the latest beta, the touchscreen still doesn’t work when touching.
Using 3.513 volumio version.

What else can I try?

Are you using the original 7" Raspberry Touchscreen?

Yes I do😊

I can see things on the screen, even the mousepointer but when touching nothing happens

So the display is working, but touch not?

Yes indeed. Very strange

I saw you are using Volumio 3.513. Did it work with 3.512?

I don’t know, used the screen long time ago with Volumio 2. Then everything worked ok.

Did a clean install of 3.512, not 3.513. Typo. My bet.

Should work. Are you able to test the touch function with another OS e.g. Raspberry Pi OS to rule out a hardware defect?

P.S.: Touch Display plugin version is 3.3.7?

Tried the latest normal and latest beta.

Will try again tomorrow, time is up for today.

Thanks for your replies!