Volumio 3 RC1 - Open Beta Testing

@volumio, I would love to know about EQ integration. Additionally, would Dirac integration be possible?

1 Like

Hello
Is it planned that the Allo Dac2 will also receive support from Volumio?

1 Like

Not working with hifiberry digi+ pro. No sound and an alsa error

1 Like

Also in the latest version of Buster the configuration of the Wireles network is erased. Each restart must be activated.
This I have been reporting for a long time. It seems to me that it would be a good idea to inform if the reported problem, whatever it is, is detected and if it is in the process of being solved.
RPi3, Volumio 3.114

Get the same issue

A short one: Can we expect this “Probe the system” plugin?

@btaney @adream
if you could post the log you can find instructions here :
https://volumio.github.io/docs/User_Manual/Sending_logs_for_troubleshooting.html

and please post the link in this form so people can look at it.

@danielfelix this already a long problem it was there in the 3.074 maybe @volumio can pick this up.
( i had the same experience after boot wifi is switched off instead of on . )
this should be fixed before the release.

Ok, after some research, I think I’ve located the source of the issue, and it’s on the windws 10 PC.
What happens is this type of SSD is automatically assigned as a SCSI backup drive, and as such, it just can NOT be treated and properly ejected as any USB External drive.

I tried to change the SSD’s properties once formatted, no success yet … :frowning::frowning::frowning:

I’d be delighted if anybody has a solution, would be helpful for many people I guess ?

JMiK

1 Like

@JMiK
Did you delete and rebuild the partition first ?
If there are more than 1 partition , delete all ,

I did a full formatting, and changed the SSD’s name.
I guess there is something to modify somewhere in the SSD’s properties, and it looks like windows does not offer any choice at first.
Maybe I should ask for help in some PC forum ?
This Samsung T5 External drive is supposed to be used also as a regular USB drive ?

JMiK

1 Like

Just installed on PI4 using my Yamaha CDS-2100 'sDAC and everyting works as expected with all my music files stored on an external M2 SSD!
Congrats

2 Likes

I face the following problem:
UPNP Servers not found

Device running volumio:
DIY X86 PC with Gigabyte Mainboard GA-H81M-D2W, i7-4770K, 16GB Ram.
onboard network, video and audio ( analog out)
Volumio booting from USB Stick. Version 3.114
logfile:http://logs.volumio.org/volumiobuster/nJAMsC1.html

I got the same general network problems i also faced with different volumio 2 and other volumio 3 versions on several older intel platforms: partially network is not working: i’m able to play internetradio see internet pages etc. but UPNP media servers are not shown in the media servers list and/or not found - even not after hours.
Either they are all ( 2+ ) there or none.
But!: I can play from the last 100 list from my (not found !) media servers and NAS. But i cannot choose new albums etc.
It seems it even got more worse with volumio 3.
Sometimes ( but seldom) reboot helps, sometimes using a fixed IP helps.
Usually once it worked fine it continues to work ( at least with volumio 2)
I am using wired 1 GBit/s network only, no WLAN - Wireless is not installed and always switched off.

In conjunction with this i made some tests ( changing from fixed to dynamic IP) and was surprised that all the time i saved the settings there was an error message in red on the upper right corner , telling me that the wireless network could not be restarted although its switched off through the volumio settings.
I use several other UPNP streamers and systems ( e.g. foobar2000 for windows on the same machine , bubble UPNP, YAMAHA MusicCast ) ) and had never issues finding the UPNP server on my NAS - this happens only with volumio.
The Synology DS920+ NAS is always up due to a surveillance video system running all the time and the FRitz!Box router and UPNP server, too as it is my primary Network router and Gateway.
Volumio is able to receive the IP from that gateway when using dynamic IP but the UPNP server on the same device is not found/shown !??.

It would be fine to solve this otherwise volumio is not usable for me on my various X86 platforms.

ADDITION: This is the error that prevents it from starting

Oct 18 08:24:39 volumioh81md2w volumio[828]: Unhandled rejection Error: No sockets available, cannot start.
Oct 18 08:24:39 volumioh81md2w volumio[828]: at SsdpClient.SSDP._createSockets (/volumio/node_modules/node-ssdp/lib/index.js:186:11)
Oct 18 08:24:39 volumioh81md2w volumio[828]: at SsdpClient.SSDP._start (/volumio/node_modules/node-ssdp/lib/index.js:229:10)
Oct 18 08:24:39 volumioh81md2w volumio[828]: at /volumio/node_modules/node-ssdp/lib/client.js:60:10
Oct 18 08:24:39 volumioh81md2w volumio[828]: at Promise._execute (/volumio/node_modules/bluebird/js/release/debuggability.js:384:9)
Oct 18 08:24:39 volumioh81md2w volumio[828]: at Promise._resolveFromExecutor (/volumio/node_modules/bluebird/js/release/promise.js:518:18)
Oct 18 08:24:39 volumioh81md2w volumio[828]: at new Promise (/volumio/node_modules/bluebird/js/release/promise.js:103:10)
Oct 18 08:24:39 volumioh81md2w volumio[828]: at SsdpClient.start (/volumio/node_modules/node-ssdp/lib/client.js:54:10)
Oct 18 08:24:39 volumioh81md2w volumio[828]: at SsdpClient.search (/volumio/node_modules/node-ssdp/lib/client.js:82:17)
Oct 18 08:24:39 volumioh81md2w volumio[828]: at ControllerUPNPBrowser.onStart (/volumio/app/plugins/music_service/upnp_browser/index.js:126:12)
Oct 18 08:24:39 volumioh81md2w volumio[828]: at PluginManager.startCorePlugin (/volumio/app/pluginmanager.js:380:24)
Oct 18 08:24:39 volumioh81md2w volumio[828]: at HashMap. (/volumio/app/pluginmanager.js:478:31)
Oct 18 08:24:39 volumioh81md2w volumio[828]: at HashMap.forEach (/volumio/node_modules/hashmap/hashmap.js:171:10)
Oct 18 08:24:39 volumioh81md2w volumio[828]: at HashMap.proto. [as forEach] (/volumio/node_modules/hashmap/hashmap.js:201:7)
Oct 18 08:24:39 volumioh81md2w volumio[828]: at PluginManager.startCorePlugins (/volumio/app/pluginmanager.js:477:20)
Oct 18 08:24:39 volumioh81md2w volumio[828]: at Promise._successFn (/volumio/app/pluginmanager.js:142:29)
Oct 18 08:24:39 volumioh81md2w volumio[828]: at nextTickCallback (/volumio/node_modules/kew/kew.js:47:28)

Sorry - i am not very familiar with linux and network sockets.
Is this an development issue ?
Can i do anything to bypass this issue ?
Does this somehow depend on the quantity of network devices or streamers online in the network ? I got a quite large network with many devices in my house ( i guess 30+)
Each of my Pcs is a streamer and there app. 10 other devices able to stream that are most of the time online: TVs (4), Audio Receivers (3) , Audio streamer (3), Sat Receiver (2).

For DSP machines 1&2 users. Let’s help the Volumio-team create a new player.
We have adapted our drivers for Volumio 3.
Follow the instructions to connect your DSP to the player:

A post was merged into an existing topic: X86 Hardware issues (WiFi, DAC, Disks etc.)

When trying to install kernel headers on Raspberry Pi 4 with cmd “volumio kernelsource” I get the following error message: “this tool is only available for RPI”.
On Raspberry Pi 3 kernel headers are installed properly.

I tried to replicate your issue, but here wireless static network is stored properly. Would you mind providing more info about how to replicate the issue?
Also can you send a log after you set your network parameters which are not saved?

The wireless network with static IP is saved correctly. When restarting, most of the time it is disabled. You turn it back on and hopefully it works fine in a reboot or two and then it turns off.
Is this description useful? Shipping log?

1 Like

I tried the new Volumio buster 3RC1 and it worked fine on my Raspi4 with no issue finding the USB M2 SSD!
Unfortunately on the Raspi4100 the new version 3RC1 cannot find the NVMe Samsung SSD so i backpedaled to the previous working version…
The Raspi4100 in a remote room outside of my home worked on a different network but i tried to select the appropriate network it only found the main metwork??? So it’s impossible to find the Source NVMe SSD? Sorry i don’t know how to send a log…

how did you get this interface?

Device: raspberry Pi
Version 3.114. ’
Log: http://logs.volumio.org/volumiobuster/RxPFqnW.html
Issue: I have an USB SSD disk attached with all my music. This setup worked fine in Volumio 2.
It is a fresh install, no changes. After I scanned all music, I see all my artists, albiums, etc.
However, when I select an artist, and I get the list of albums (and songs below that), and I then select one of the albums to play the album, I get an empty screen. See the attached screenshot. This is not solved by re-scanning the music from the USB disk.
I can play individual songs.

Thanks,
Sjaak Laan.

1 Like