Volumio 3 on Pine A64(+)/ Pine A64-LTS/ SOPINE Compute Module

These images be built at regular times or on request (if there is appropriate demand for it) .

OTA Updates from Volumio 2 to Volumio 3 are NOT supported!!

As I have left the community developer team, there will be no more updates, support has ceased.

New version 3.212 is available, please use OTA to update (test mode required) or use the download link in the opening post.

Does the latest version work for anyone, please?

I’m here to help, but your post holds no information whatsoever.
Asking this way won’t solve your issue, trust me.
Why not start with explaining which Pine64 model you are referring to (so that we know which version you might have downloaded) and describing the problem you have with it so that you can stop people guessing at what “does the latest version work for anyone” means.

1 Like

Sorry, but considering the silence here, I wanted to check whether there is anyone alive here at all, before wasting my time on digging into any problems. I wasn’t sure it is not just some kind of automatic, untested build.

Ok. I have not actually done much testing. I just installed the 3.212 (tried both pine64plus and pine64base, since I did not find any explanation on the difference) and noticed it booted and connected to network, but that was about all. None of the crucial services managed to start (mpd, ssh, volumio UI, …). I couldn’t find any clear explanation in the logs. So, I just tried version 2.916 and that one “just works” out of the box (despite of noticing mostly the same kind of “errors” in the logs that I have noticed with 3.212 - so they are obviously not fatal).

So, I wanted to know whether the newer builds were actually ever tested on some Pine64. I only quickly tested on a Pine A64 2GB (so I suppose it is the “+” version - always forgetting the difference). I also have some 1GB versions, so I can do some more testing as long as the available time and SD cards allow. Maybe, I could test the previous version 3.187 first, unless you have some other suggestion. I suppose you have a better idea than me what has been changed between the releases.

(Well, and of course I did not manage to activate the original Pine LCD panel either yet, but as far as I noticed in the forum, you cannot really help with that problem. Anyway, that is not that crucial.)

You got a reply within 24 hours.

Yes! And I am happy I am not the last desperate trying to revive my old Pine64s :slight_smile: I am sorry in case my timid “doorbell ringing” made an awkward (or even rude) impression.

So, I tested the 3.187 and it worked. So I tested the 3.212 version again and… now it works! Hooray! So, either the image was written incorrectly the first time, or I am just an idiot or whatever… It’s true that the services don’t all start at the first try and there are some errors in the logs (esp. the PnP daemon takes more time). But eventually everything is running (except of the haveged.service).

So, I am sorry for making such a stir with the simple question after the initial failure.

Maybe, I could still ask about the original LCD activation: in the previous thread someone mentioned the need to load the module “gt9xxf_ts” and you reported the module is available. But I only get “Module gt9xxf_ts not found in directory /lib/modules/5.7.19”.

yes, give me a few days but please remind me.
The current image should support the stock Pine panel display, it has been configured and used for something else and that was ok.
First thing you need to do is install the touch screen plugin, it could, but may not work.
I don’t know by heart which panel driver was loaded as default (also tested a 2nd model), could be the wrong one.
Not near my dev machine currently.

Great, thanks!

Oh, it looks like one needs an account to install plugins, now!? It wasn’t necessary in Volumio 2, is it a new “feature”?

Not a “feature”, read the forum for the (good) reasons behind it.
The account is free, so no worries.

1 Like

Any tips on how to get the PINE64 POT to work? I can get sound out if I choose “onboard SPDIF” but nothing if I choose “I2S DAC”. And even with onboard SPDIF (TOSLINK and coax), I can play 16-bit flacs, but nothing above that (24-bit, for example). Running the most recent Volumio (and I’ve also tried about the last five releases, including volumio2 with the same results).


Update: it’s not the bit depth that is the problem. 24-bit flacs play fine. It’s the sample rate. Anything over 44.1 makes no sound from the TOSLINK or coax outputs. I2S plays fine over the RCA outs, but I would prefer the coax output with my current setup. But it won’t play over 44.1k from Volumio. My Dac can accept up to 192 on all inputs, but only USB is working above 44.1k from volumio at the moment.

A late reminder (or re-quest-ion): how about the support for the original Pine display?

Meanwhile I stopped support for Pine boards (see first post), I’m sorry.

Is there any chance to get the last version? Since the Link is down?

It seems all resources for all other Bords are gone? Is their any chance to get the last version?

Old versions would not work due to certificates, which expired in the meantime.
There is no more support, so no more updates.

I now run 2.916, i just would like to run the last available version. Or is there any alternative for that bord? Maybe something running on top of armbian that provides airplay and Spotify connect?

The latest V3 (unsupported) is at the top of this topic.