Volumio 3 Buster general issues

Not sure if this is a Buster specific problem, but it is here in both Arm & x86 that I have noticed that on the hotspot running on first boot with the ‘first config wizard’, the chosen wifi network password field is not visible on my Android mobile (but occasionally is, just to be awkward ). I can see it ok on a connected laptop, but even here the field is very far to the right (outlying the green border lines).

Tidal playback stops after playing one song (6 seconds before the end if this song) in a list of songs (i.e. an album)
Version: Volumio beta 3.055 (Volumiobuster-3.055-2021-03-12-x86_amd64.zip)

Today everything is working fine again with Tidal.
Seems to be a server-based problem that apparently has been solved…



now I see the “Tidal problem” again. Every time I start a sequence of songs (i.e. an album) playback of Tidal stops after he first or the second song in the list. After that playback is not possible until I wait a few minutes and start a single song or I change the Playback Potions to another output device.

Since I didn’t see such things over the last couple of months I’m now tending to the opinoin that this issue has its cause in the beta program.

May be somewhere in MPD or ALSA ?

Version: Volumiobuster-3.055-2021-03-12-x86_amd64


In a intermediate version out of december 2020 (2.857) the playback and UI (tidal, albums, webradio, etc.) is completely stable and robust.

There is definitely an issue with the beta 3.x regarding playback of tidal / albums…

Here’s a log (Volumiobuster-3.058-2021-04-10-x86_amd64.img) when this problems (playback of WEBradio and Tidal noch stable) occur:

2021-04-13: (Volumiobuster-3.055-2021-03-12-x86_amd64)
Tidal is stopping again - 6s before the end of the track playback mutes, then no further playback is possible…



20 posts were split to a new topic: Pi-hole with Volumio 3?

i just started installing Volumiobuster-3.073-2021-05-07-x86_amd64on my Volumio 2 Systems.
On an Intel X86 System ( Asus P5G41T/M_LX3 MB, Core 2 duo, 6GB) most of the time everything works fine ( except known issues) , but sometimes the Media Servers ( Synology 920 NAS) ist not shown - even when i play music from that NAS ( because the link is still stored from the last session) at the same time or from Internet Radio - so Networking is o.k. !.
I had that just once after app 10 restarts. I run Volumio Buster form SSD - the system has no USB 3 and boots very slow from USB 2 so i copied the system on a small SSD.
(Thats a very good option to do that from Volumio itself)
Waiting for some minutes did not help.

This post is a “Volumio 3 beta for x86” issue, not a general one.
Please post this again and stick to the rules outlined in the first post of the “Volumio 3 for x86” thread.
We need hardware info and logs, without it we are not able to offer support.

A post was split to a new topic: Access/Hot Point Password

The user interface had numerous display issues when running the setup wizard. Controls, especially drop-down menus would disappear when I clicked on them, then reappear, only to disappear again after attempting again to access them.

I noticed the browser attempting to connect to external web sites. It was failing, of course, because my only network interface was attached directly to the device operating as an access point. My browser had no outside access. I eventually succeeded by attaching a second WiFi controller, a USB device, I had available, to maintain the separate WiFi connections. Plainly this option is not always available.

Generally, a device controlled through a web interface should be able to serve the entire interface internally. Expecting either the device or the client to have internet access at all times when attempting to control the device presents to me as a bad design choice.

I may be misunderstanding the design based on a few small observation available to me, but I certainly stand by the recommendation to maintain a design free from internet dependencies.

I would recommend you to read the very first post of the beta test instead of complaining. In case you have difficulties with the quality of the beta, you should not have joined the beta program.

@gkkpch: Are you referring to the post that begins with the following invitation?:

Help us improve the Volumio experience … let us know what works & what doesn’t.

nope, this one

Sorry, I’m not understanding your objection. A beta program involves developers receiving feedback from testers, and you have given a reference to an outline of the particular rules of the current testing program.

I had similar problems, but couldn’t figure out what was going on. Good catch! This would explain most of the setup problems I was having.

wifi problem on 3.079 / 3.074
wireless network switch is everytime switched off after reboot.
sometimes volume goes back to 0 if it’s set on 45
rest api is unresponsive many times 3.079 is slow in use.

If something is changed in the playback settings, the volume briefly rises to 100%! (With RPI I it takes a little longer … :astonished: :skull_and_crossbones:;-))
This can be problematic and damage the amplifier and speakers …
I suggest that after pressing the save button in the playback area, the pause is always activated first. So damage should be excluded.

Hi @all,

installed the 3.803 on a separate SD for Testing (RPI 4 4GB). My Setup run well with Volumio 2. Output ist routet to an ES9038PRO Custom DAC using the rpi-dac (RPI-DAC) overlay which worked perfectly as mentioned before (DSD over PCM and the other Setup ist the same as of Volumio 2 Setup). After Hitting Play the first 3-4 seconds there is no output and then you here a sound loop of the tracks (length about 1-2sec - which is accurate no noise or so) 5-6 times and afterwards another sound loop of the next 1-2sec for 5-6 times and so on. Don’t think it is an DAC Problem rather than a cache Problem? Any Ideas about that ? This is not Source / Format dependent. NAS / Webradio / Local ist the same.

using journal following is suspicious:

Sep 19 10:44:10 volumio systemd[1]: mpd.service: State ‘stop-sigterm’ timed out. Killing.
Sep 19 10:44:10 volumio systemd[1]: mpd.service: Killing process 1303 (mpd) with signal SIGKILL.
Sep 19 10:44:10 volumio systemd[1]: mpd.service: Main process exited, code=killed, status=9/KILL
Sep 19 10:44:10 volumio systemd[1]: mpd.service: Failed with result ‘timeout’.
Sep 19 10:44:10 volumio volumio[881]: error: MPD error: Error: read ECONNRESET
Sep 19 10:44:10 volumio systemd[1]: Stopped Music Player Daemon.
Sep 19 10:44:10 volumio systemd[1]: Starting Music Player Daemon…

3.803 (you meant 3.083) is an unreleased version and therefore unsupported.

please reread this important notice to all beta testers

To avoid further confusion, please unset Test mode if you have not done so already.
That way you will avoid stumbling over insufficient testet or non-working alpha versions.

Please hold on a little more, a new beta will arrive and be announced soon.

There is a new update available: Volumio 3 Release Candidate 1.

The next stage of testing will involve a Volumio 3 Announcement with reported feedback in a new single thread for RPi, Tinkerboard, and x86 .

Thread closed … see you in the new thread. :smiley: