Volumio 3 Buster Beta for RPi

When restarting, the configuration of the Static IP of the WiFi wireless network is erased.

Rasp3
Allo Boss
Volumio 3.046

A post was merged into an existing topic: Remote Control in Buster

Please do not pollute this thread related to beta WHITout plugin. This a choice to avoid having issues not coming from Volumio itself.
Thanks

Update on the issue above.
Done some test and logging and approx 10% of my Albums won’t play if I go from Artists and play them from there , but if I use three dot menu and “Go to Artist” from main window all album works nice.
In my case there is always the same albums that don’t work (done Reboots Rescan and Update of the library)
When logging I see that the path is wrong on the Albums that don’t work

// From Artists, pick the Album
info: CoreCommandRouter::volumioAddQueueItems
info: CoreStateMachine::addQueueItems
info: CorePlayQueue::addQueueItems
info: Adding Item to queue: artists:///Evil%20Is%20Forever
info: Exploding uri artists:///Evil%20Is%20Forever in service mpd
error: Explode URI Error: null

//From Artists, pick another Album that works
nfo: CoreCommandRouter::volumioAddQueueItems
info: CoreStateMachine::addQueueItems
info: CorePlayQueue::addQueueItems
info: Adding Item to queue: artists://Astral%20Doors/Cloudbreaker
info: Exploding uri artists://Astral%20Doors/Cloudbreaker in service mpd
info: CorePlayQueue::saveQueue

// From Main window, three dot menu and Go to Artist. And pick the Album
info: Launching a new LiveLog session
info: CoreCommandRouter::volumioAddQueueItems
info: CoreStateMachine::addQueueItems
info: CorePlayQueue::addQueueItems
info: Adding Item to queue: albums://Astral%20Doors/Evil%20Is%20Forever
info: Exploding uri albums://Astral%20Doors/Evil%20Is%20Forever in service mpd
info: CorePlayQueue::saveQueue

To follow up on my earlier issues- now the volumio selection of web radios appears in my Web Radio tab. Awesome! Thank you to whoever made that change.

One thing to note, is I am seeing a message in the UI that says BBC radio will stop working on this device soon :cry: which would be a great disappointment.

Also, I’ve noticed the alarm function doesn’t appear to work.

Additional info: The internet radio from the BBC is playing intermittent messages saying this stream will be stopped soon over their broadcasts.

Edit: actually the alarm worked this morning. Will keep an eye on it.

So far i could read it will be there only for people in the UK,
that’s why it stops outside of the UK.

Hey dvo. I am in the UK. From what I could see the BBC seems to be changing the address of their streams. As seen here

@dvo/tophee, bbc channel does not seem to be a Beta issue, could you both take this to another thread for follow up?

flashed the image again and the problem with the hardware mixer is gone and everything works as it should now.

Sure. Will do.

thanks, you may want to hook up to this one

Would it be possible to include the dtd for hifi berry-amp100? This is new in the kernel release.

I am using 3.046 for a couple of days now and see frequents hangs of mpd;
mostly in the morning after an extended time of inactivity.
I hope this is not considered a crosspost from the tinker thread as this is happening on the RPI4.
Anyways here is the logfile:
http://logs.volumio.org/volumiobuster/US4yhma.html

To elaborate a bit, this is what i see and do:
When Volumio is not playing (also it says it does),
i start mpc in the terminalto see whether i get a response from mpd.
mpc times out.
I can neither stop mpd by sudo service mpd stop nor by kill PID.
A sudo kill -9 is needed to kill the process.
After a
service mpd start
All is back to normal.

in mpd service status i see.
Mar 06 08:07 : exception: Decoder plugin 'wildmidi' is unavailable: configuration file does not exist: /etc/timidity/timidity.cfg
This might or might not be related.
Also my internet connection is a bit shacky at the moment (Thank you Vodafone)
This could be related with me playing Qobuz streams before mpd hang itself.
I will be on a different network in a couple of days so we will see how that will work out.
Anything i can do to narrow this down?

new version out, see OP

1 Like

RPI4
Volumio 3.051
can’t play wma file. Seems to play but no sound
http://logs.volumio.org/volumiobuster/zhbmnPt.html

Hello
One question pls.
I have just installed latest version and boot is ok. It seems that it is faster then volumio2.
Why qobuz and tidal are already integrated but for spotify I need to install a plugin :(.

@balbuze
it is posible to have spotify login in Sources ? if yes How can i do that ? Currently I have only Qobuz and Tidal .

Thanks

Thanks for the log. This appears not to be a WMA issue, but a floating point audio issue. A fixed version should be available soon.

1 Like

Thanks!
A new log with Qobuz. It hangs when changing track (not always)…
http://logs.volumio.org/volumiobuster/rqbdiOs.html
edit : new log link

Qobuz
Volumio 3.051
RPI4
Each track start to play, 1 second, stop a fraction of second and then plays

Hi,
I just installed the latest version, then install touch display plugin, peppy meter plugin and when trying to instsll the mpd oled package it gives me some error that the disk și full. I saw that /var/log has only 20M and it is full.
On volumio 2 I did not had that issue.
Thanks