Volumio 3 Beta test: Auto updates

Got a new update, noticed that the screen became unresponsive for about 5/10 seconds. I didn’t want to update during a listening session, so maybe the only responsive part was the notification itself :wink:

Version 3.422 displays messages about an available update and works for me in most of its functions stably,
unfortunately the UPNP/AV renderer still works in a limited way (stops after one track played)

Updated to 3.423 all good (don’t use upnp, so can’t comment on rak39’s reply)

As the automatic updates itself works flawlessly and I see no error reports on that, what are we waiting for with regards to a public release? Are there any other features planned to come with official 3.4?

The other missing piece was Timezone setting, which allows Volumio to update only at night. Plus some minor fixes. 4.423 is the golden release.

We are proceeding with extra caution with this series of updates, as the OTA updater is a critical INFRA at Volumio and we want to make sure we are not overloading it

Nice! Would it be possible to set the auto-updater to a certain time manually (see post 2 of this thread)?

May I suggest in addition the feature to be able to set the time for automatic installation (let’s say 4:30 at night?)? In other words: I would like to make sure that my system does not restart during a party or a late night listening session.

Thanks for the good work!

That’s the idea. Setting is not there, but with the timezone setting, adding it will be a breeze


Update failed

System Software Integrity check failed, manually edited files were detected. System Software Update is not possible under these circumstances. Please execute a Factory Reset or Delete User Data, then retry.

I’ve got this message when checking updates. How to find out which files are edited, and how to solve it without factory reset? :crazy_face:

1 Like

restore past modified Files to original or uninstall or disable unofficial plugins.
if you don’t use unofficial plugins or modified files I don’t know.

I have use volumio version 3423 and I’m happy with it.
now I see each time when start up that there is an update available and I already
switched it off but still I get this message.

Update v3.429

Hotfix release

  • Timezone configuration fixes
  • State machine improvements and fixes
  • Auto update window configuration
  • Automatic timezone configuration in the wizard
  • Multiroom state synchronization fixes

is there a way to switch it off?

Strange you’re getting that. I presume from what you wrote that you switched the option off in System settings.

Could it be you’ve upgraded from the beta version? I didn’t run the beta, so can’t reproduce that.

I use a fresh version of 3423, and switch of the update.

But still I receive the pop up


Nobody any suggestions?

Please stop cross posting!

You can switch off the automatic updates function, but not the notification that there is a new update available.


Oke that I did not know, is there a way to blok that?

Not as of now. Also, it’s an incentive to keep user’s devices up to date, which makes our job easier at supporting it.
What is the reason you don’t want to update?

i think if it’s not broken don’t fix it principle… lot of the time updates can break working systems…

and every time a toaster with there is a new update nagging to update doesn’t work.
you can always check it if you want.

Auto update is a choice, it is not even on per default in the system settings.

What 12121937 is looking for to block is the notification about the available update(s).

oke if the auto update is off then the notification toaster about a new update should be off too.

Does that not defeat the whole purpose - you either have the auto update on so it is done in the background or you get the notifction that there is an update available for you to install (or not to install, just dismiss the notifction)