Volumio 3.631 RPi Zero 2 - No sound via USB DAC whatever the source

Hi,

I have just installed a new instance of Volumio 3.631 free on a RPi Zero 2.
When I try to output audio to an SMSL SU6 DAC I get no sound.
The SU6 has switchable inputs but mine is set to USB and the Volumio instance recognises the DAC as it is listed in the cofiguration settings.
I have previously used this DAC with a Volumio instance running on a RPi 4 without issue

aplay -l output
volumio@jfbvolumio:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: b1 [bcm2835 HDMI 1], device 0: bcm2835 HDMI 1 [bcm2835 HDMI 1]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 0: b1 [bcm2835 HDMI 1], device 1: bcm2835 HDMI 1 [bcm2835 HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 H eadphones]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 5: AUDIO [SMSL USB AUDIO], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

asound.txt (842 Bytes)

I have tried mixer type = software and = none without success.

I have tried changing the output to headphone, saving and then back to SSL USB Audio and saving to force an update in asound.config with no change.
Happy to upload further diagnostic info to resolve this

Thanks

I have replicated your set up as closley as I can:
Raspberry Pi Zero 1 WH
Volumio fresh download and install.
Power from powerbank ( see image below)
OTG usb adapter ( the black adapters are to give space for the power input)
Ran initial setup and selected Headphone output with no l2s DAC
Attached USB DAC (Xtreme Pro X1) which Volumio found and added as a playback option.
Selected and saved Xtreme Pro as Playback device. Made sure Volume was set to Maximum (although it should not make a difference)
Selected Web Radio from volumio home screen and Volumio Selection. Clicked on Radio Swiss Jazz and after a brief (10 seconds) buffering period got excelent sound.
Switched USB output to to a Musical Fidelity V90-AMP which has an integrated DAC. Volumio recognised it, selected it and saved. Chose France Musique La Jazz from Volumio Selection and, after buffering, great sound.
I wonder if the OTG usb adapter is making a difference?

Hi Andrew,

thanks for taking the time and effort to help with a solution.
It could well be an OTG USB cable issue.
I will explore further

Thanks

i had a similar issue with the latest update on a new sd card not recognizing my USB dac. tried rebooting pi to no avail. then i tried telling pi that i had an I2s dac attached and saved configuration and rebooted the pi and my dac. then i turned of the the i2s setting at which point volumio recognized that the Hegel usb dac was connected. rebooted one final time and everything worked .

I don’t know if this will help but

i don’t know if it will help but this worked for me.

Don’t ask me why this should make a difference but I reflashed the SD card and all is now working as it should. No changes in hardware or cables.
Thanks both for your input