Volumio 3.395 Fast Beta-Test

I wrote fresh image to SD card and it works fine. As wasn’t near my box during update I don’t know if there were some errors. Other reason may be SD card, I use it since 2019.

Currently we’ve landed on V3.398, which became a pretty weird expierence.

  • factory reset (from rPi4-8GB, V3.378)
  • During the first install wizard, WL network gets into a loop, keeps detecting (spinning wheel). So forced to reboot the system. After doing this (Also connected wired) the system won’t register with myvolumio, even though It’s logged into myvolumio. Loading plugins failed.
  • Performed a 2nd factory reset and started over.
  • After the first time wizard, almost every plugin failed to install
E: Release file for http://raspbian.raspberrypi.org/raspbian/dists/buster/InRelease is not valid yet (invalid for another 19h 38min 12s). Updates for this repository will not be applied.
E: Release file for http://archive.raspberrypi.org/debian/dists/buster/InRelease is not valid yet (invalid for another 21h 59min 24s). Updates for this repository will not be applied.

  • Reason time zone incorrect, after running sudo dpkg-reconfigure tzdata still 27 hours off, so nothing could be installed or updated.
Current default time zone: 'Europe/Amsterdam'
Local time is now:      Wed Dec  7 09:56:24 CET 2022.
Universal Time is now:  Wed Dec  7 08:56:24 UTC 2022.

Finally after 4 reboots and retries, the new timestamp was correct.

So after 2 hours, I can finally do some testing. Not sure what causes this. never had these troubles before.
More to come

New screen layout, still a bit unlogical, there is a huge amount of unused space to left. Not sure why not resizing/re-arranging?

just an example:

  • Menus to the corners, not random as they are tied to the player controls
  • Use left space for covers
  • use remaining for track info etc. Which will give room for artist info which is gone now.

Or add this as option for the manifest UI.
Player controls <Rep> |<< > >>| x Yes/No
Artist info Yes/No

Long playlist/pause.
Seems stable . Still running test.

thanks for informing us , I am still on 3.396…

1 Like

My devices seem to have become stable on 3.396, For the last 24 hours or so I have not had any issues with the configuration update loop.
I’ve got 2 RPi 4 4G one hardwired the other on wifi and I’m logged into my volumio premium on both devices, the devices don’t show up on the other for multiroom grouping nor available devices to switch devices in the web UI

I just setup version 3.396 on my RPi3 with the Adafruit Bonnet. I’ve configured my NAS and it discovers my MP3 files. When I try a web radio station, it plays fine. However when I attempt to play the NAS files, I can see the song progress bar moving along but there is no audio playing. Additionally, after I try playing one of the NAS files, I cannot switch to play a different source. It’s as if my files crash the player. I have found that rebooting is the only way to restore service. After rebooting, I’m able to play web radio again. I’ve tried converting my files to WAV and FLAC as well, but these don’t seem to make a difference.

EDIT: I ended up doing a factory reset because I had already tried installing FusionDSP to see if that would help, and wanted to follow the instructions to do the Test Mode for this. After the factory reset, it seems to be working fine.


2 posts were merged into an existing topic: Qobuz “Error No Result”

the 7.9 display looks similar. I wish I could shift it over or get rid of the dead space.

1 Like

I Have one device now that has started the “Configuration Update Player Successfully Updated” loop again. I updated that device to 3.398, turned off testing mode. Then I did a reboot of the device. After the reboot it was still in the loop so I proceeded with a factory reset and the configuration updated loop continued.

It was stable for a few hours yesterday on 3.396 and I was able to listen to a few podcasts on spotify and my sleep sounds playlist but sometime in the night it started into the loop.

I am still unable to sync multi-room playback when the devices are stable and signed into my volumio premium account.

here are the logs:

seems to be stable now, so I grabbed the logs again to see if it helps in figuring out what is happening.


Then after a reboot from the GUI power button the loop begins again:


A reboot also kicked off the configuration update loop on the device that had been stable on 3.396 since Friday:


Please check you DNS settings in your router.
I see a bunch of network errors in your logs.
Please update the DNS in your router to those from Google.

And test again.

It’s always DNS…

Unfortunately my provider has DNS locked on my router and I haven’t had a chance to set up my pfsense in the new place yet. However turning on DNS settings in the networking panel on the devices seems to have worked perfect.

Also seems to have fixed the multiroom playback as well.


Good to hear you’re up and running again.
We have seen multiple occasions, when some connections are being blocked Volumio get into this loop. However this should have been solved with V3.396 @volumio .
The Volumio team is working to get a solution on the -3007 error.
Browse raised the following error Error: getaddrinfo -3007

after a while I have problem with playing. This time a have issue while playing Spotify, but sometimes it happens with Tidal or YouTube cast. Logs attached:
Not occurred before update. To reproduce this error you can switch between sources: playing locally(NAS), Tidal, Youtube Cast, Spotify.

I think something went wrong with flashing your ID.
There are to many errors (138). mainly on audio, kernel panics etc.

Please reflash your SD with Raspberry pi imager.
Don’t install plugins like LMS, YouTube Cast Receiver, YouTube Music, Music Services Shield.
First you need a clean stable install, then move forward.

Link to latest release please!

Within the Volumio menus go to System and click Check Updates.

Sorry - Newbie on this forum - as I posted from the Fast Beta-Test topic I meant a link to the latest beta of Volumio 3. Already a happy Premium user of Volumio 2. Would like to set up a separate CM4 test bench for Volumio 3.


As newby take the final release version, not a beta release.