Volumio 3.251 on X86 problem

Hello everyone!

I’m trying to install Volumio 3.251 on an old x86 PC 'cause my raspberry pi1b+ is too slow. I’ve tryied before on a VM (VirtualBox) and it worked; i installed it on a virtual disk from a flashed usb drive (i’ve used Etcher) running the automatic procedure from System Menu.
So i tried to do the same on the PC without success…i have always the same error on boot:

findfs: unable to resolve UUID:xxxxxx

It seems to be unable to find the three partition created.
What can i do?

Thanks a lot

This is a 100% flash issue.
Use another tool, against different opinions in this forum, do not use Balena Etcher. At least for x86, all similar error reports I have seen were from users using the Balena tool.
Use something like Rufus or Win32DiskImager.
Or if you’re on Lnux or Mac, use ‘dd’, this always works.

Ok, thanks for your answer…
now i’m trying to flash the usb key with rufus, i’ll write back as soon as the whole process will be ended.

1 Like

unfortunately it doesn’t work, same error. I flashed with rufus…
do you have any suggestion?

thanks again

No, but I repeat it is an incorrectly flashed image. Nothing I can help with.

1 Like

I’ll try win32diskimager, thanks again

if your target is to install volumio on hdd/ssd of the old pc, why don’t you simply flash volumio directly on hdd/ssd? obviously you have to phisically detach hdd/ssd from old pc, flash on it from another pc with the hdd/ssd connected via usb (cable, docking station) and finally attach again hdd/ssd in the old pc.
balena etcher allows it.
in this way i succeded in flash volumio on hdd and boot from it :wink:

Thanks for your answer,
I thought about this solution but i don’t have a SATA to USB adapter and i’m using an iMac :smiley:
i will find one and try this way

iMac? so not a PC… I hope for you that you don’t have problems with Apple boot :wink:

oh no sorry
the target pc is an old pc, i’m working on iMac where i will flash the volumio hard drive…i meant that i don’t have any external sata to use to flash and neither a SATA interface.

I’ll keep you updated.

ah. so it’s OK :wink:

i’ve tried but it doesn’t work, same error.
i flashed the new x64 volumio image (3.301 9/6/2022) from my PC with a SATA->USB adapter but no look…i tried with rufus 3.18
I will try with win32diskimager

Any other help?

Can you check whether you really have the 3 partitions on that usb stick?
And tell me more about your pc, what is it? Brand, model?

i can confirm there are 3 partitions on the HDD; i’ve mounted on a ubuntu VM to check. The PC is quite old, it is an intel dual core with 1GB of ram; integrated vga but i think it is not a problem.

I think the kernel for some reason can’t recognize the partition uuids in the syslinux.cfg or it scans before it attach the sata driver (perhaps it is a silly idea).
Then i cant use keyboard to use shell.

The PC is an HP Compaq dx2200 MT
Pentium 4 3GHz, 1GB DDR2

I don’t know if it is possible to solve this issue…but it is possible to install Volumio framework/application layer on a generic distro (ubuntu perhaps); there are any standard kernel modification or alsa subsystem?

No, Volumio is a standalone system with its own dedicated OS based on selected Debian Buster packages and Volumio additions. It cannot be installed.
In case you get the “findfs” issue with UUID it can have two causes:

  • something went wrong with flashing the image (most cases)
  • the kernel can be booted but it is not able to locate the partitions because of lacking hardware support

The latter may be the case with your old Compaq PC, if so then there is no hope. I stopped hardware support for x86, with the occasional exception for trivial issues with newer devices. Old devices I won’t touch, sorry.

thanks for your support @gkkpch ! very kind :wink:
now i have a most recent Pc of a friend, i will swap hard drive in order to try my volumio hdd.

Ok solved,
the problem is the PC, too old. In the recent PC the hard disk works like a charm.
Thanks for your support, i will find a “younger” PC for my jukebox server :smiley:

The problems with balena etcher are really frustrating, especially for new beginners!
I tried WIN32Disklmager and it works perfect, right from the beginning. Use it for Raspberry OS
Systems and Volumio. No more problems with Micro SD Cards or usb-sticks (on windows PC).