Volumio 2 not booting

Hi all.
Iam trying to install volumio 2 .
After burning volumio 2 image I am getting
Chipset not compatible please update software.
The pi is pi4 2g.
Now I can boot fine with any version of volumio on pi 4 8g and pi 4 4g.

I then installed pi desktop and tried to update eeprom, it told me it was up to date.
Reason iam using volumio 2 is my adi 2 dac fs and mdac plus are not compatible with versions 4, ie unable to use high bitrates.

Version 3 works fine on All my pi.
So why won’t the pi 2 g except volumio vs 2?

Volumio V2 is no longer supported.
Seems you rPi4-2G is rev:1.5 and requires a Kernel update.
This revision is/will not (be) available for Volumio V2.

Thank you for your info.
Could I ask how do I setup path on mini DLNA on volumio?
I tried everything , coming back with Drive not found ect…

Example if I attach a usb drive named music, which contains separate folders of albums, what would the path be?

Sources => + Add New Drive,
Here you should see your USB thingy.
The path is /media

Another thing I found out with volumio 3.
Upnp seems broken.
Mconnect and similar software won’t find any pi. With vs 3
2 works great. Another reason I wanted to stay with volumio 2.
Any chance that it can be fixed?

@terrys999 Similar issue discussed here?

There is a beta OS release which might help.