Volumio 2 installation on RP3

Its been aprox 2 years since I installed a Volumio 2 on a Raspberry Pi. I remembered I tried Volumio 3 and didnt liked it so I went back to Volumio 2, version 2.882 and worked fine, infact its been wokring nonstop for about 2 years now. I’m trying to flash this same file to use with a new RP3 that I bought recently and its not working, i flashed it with Balena, Raspberry Pi Imager and nothing. Then just to troubleshooting I downloaded the latest VOLUMIO 3, flashed it and worked like a charm. Is there a restriction now to use VOL2 on a RP3 or what can I be doing wrong? I will like to keep using Volumio Version 2. PD. Also try volumio-2.917 and still not working.


What dont you like about Volumio 3. If its the new manifest interface then you can change back to the classic interface reasonably easy.
Back to Volumio 2… saying it doest work is not too helpful. What doesnt work, is it not booting, can you not connect, how are you trying to connect etc etc.

due to trouble shooting an issue, I have recently tried versions all the way back to 2.457 on an RPI 3B and work fine.