Volumio 2.411 on AppleTV 1st generation

I builded the Volumio image for AppleTV 1st generation.
The system works fine from USB pendrive but it is designed to be installed on internal hard drive because AppleTV 1st has only one USB port.

Extract image from zip archive, then burn the img file to USB pendrive (minimum size 8Gb)
Plug on AppleTV USB port
When led stop to blink the system is ready
Access from web browser at volumio.local
Installation on internal hard drive is possible from Setting /System menu
Ready image can be downloaded here.


sure you can use the internal hard drive to store your music.
For easy update I suggest do not store music on Volumio device.

Otherwise if you want use internal hard drive as Volumio device and music storage you can follow this instructions:

OPTION 1 (not tested and deprecated)

If you do not launched the resize script, connect with ssh, execute

sudo bash resize.sh


sudo mount /dev/sda3 /mnt/INTERNAL
sudo mkdir /mnt/INTERNAL/music
sudo chmod 777 /mnt/INTERNAL/music/
sudo nano /etc/fstab.tmpl

add a new line at the end of the file

/dev/sda3	/mnt/INTERNAL	auto	defaults,noatime	0	2


Now you can copy your music to network share, volumio.local, internal storage, music folder.

Beacuase I am not sure if it is a good idea to keep music on volumio_data partition, I suggest to create a new partition to store music files.

OPTION 2 (not tested but recommended)

Install Volumio on internal hard drive, reboot Volumio usb pendrive, connect with ssh, execute

sudo sgdisk -e /dev/sda
sudo fsck /dev/sda3
sudo sgdisk -n 5:0:0 -c 5:"primary" -t 5:8300 /dev/sda
sudo mkfs -t ext4 /dev/sda5
sudo e2label /dev/sda5 music

after reboot you may find the new partition mounted under /mnt/USB/music or /media/music, execute

sudo chmod 777 /media/music

and you can copy your files on network share, volumio.local, USB, music


I did install on internal HD but I’m playing music from NAS or Spotify, for the moment.
I did do the resize, but for what I understood you say it’s better to run from USB right?
Will run from USB avoid HD from spinning?

thanks again for what you’ve done


1 Like

My preference is Volumio on internal hard drive and music on usb drive or nas.
Second option is Volumio on usb pen drive and music on internal hard drive.

Hi, do you if the USB build will work on a 2nd gen Apple TV? I’ll give it a go when I get hold of a usb female female coupler but just wondered in advance?


No. Different architecture.


I will investigate.

Give me some day.


1 Like

To enable optical audio output, connect with ssh to volumio.local then type


in the new screen

move with right arrow key to S/PDIF (2° column) and press m to activate

then move to S/PDIF 16 (4° column) and press m to activate

press q to exit

Now optical audio is working with fixed volume. If you want control volume over optical audio, choice software type mixer in Volumio playback setting.


Hi all,

My first post…

I purchased a “faulty” Apple TV 1, replaced the hard drive and uploaded as per this post. Worked first time and a great solution. Many thanks to the Developer for your efforts. I was planning on building a Raspberry Pi, but being an Apple TV 1 fan, I thought this was a neater set-up.

My notes follow:

  1. I have several different NAS options from a Windows environment and I couldn’t get any of them to mount until I found mount flags: ro,sec=ntlmv2. With this setting everything mounted without any problems;
  2. I use a TOSLINK based DAC set-up which worked extremely well;
  3. The iPhone app is better for driving Volumio. Using the URL option is really slow in comparison; and
  4. Apple TV still runs warm (as usual) - see next steps.

Next steps:

Replace the HDD with a PATA SSD to lessen power consumption and heat; and
Replace the NAS set-up with a USB based 960GB SSD as my music source.

Thanks again for the porting to Apple TV 1.


Hi all,

having issues installing to the internal hdd on my atv, the installation hangs at 49%. any ideas?

Thanks in advance


try a manual installation:

  • boot from usb drive
  • connect with ssh to volumio.local
  • copy usb to hard drive
sudo dd if=/dev/sdb of=/dev/sda bs=512
  • power off
  • remove usb drive
  • power on


1 Like

Hi again, I’m back with an update to my previous post. I installed a PATA SSD to find no improvement at all. Still runs warm/hot and still slow. Will try an mSATa next. I also tried to connect my SSD via USB and seem to have fallen short on power. I’m going to build a power injector next to sort this out.

These are all experiments as I am well aware that I’m dealing with an old platform… but it is fun.



Hi aastonvilla (Volumio & ATV1 Guru!),

Reading another forum re power settings for Raspberry PIs someone suggested “max_usb_current=1”. Could this potentially correct my issue where my ATV1 won’t recognise (power) my Sandisk 960GB SSD?



ATV usb port has few power but I use usb external case with 500gb 2,5" sata hdd and works fine.
Volumio is installed on internal 40gb pata hdd.

A powered usb hub or powered hdd case can resolve the problem.


Thanks asastonvilla. From what I can determine a 2.5 inch HDD is in the order of 400-600mA while the SSD is 700mA. I reckon I’m just a bit too high. I’ll test with a USB hub and if it works ok, I’ll build a USB power injector to isolate the 5V supply lines. Thanks again.


I think you need a powered usb hub.


I’m back! A power USB hub didn’t work - wouldn’t mount. I have a Sandisk SSD Plus 960GB that requires 700mA. The powered hub has a 1Amp supply. I’m using a NAS instead.



Maybe it si not compatibile with Linux. ATV is booting from internal HDD?

When you attach the hub, connect with ssh and type

sudo lsusb

What is the output?


Hi asastonvilla,

Won’t be for a week or so, but I’ll check and let you know.

My set-up runs off a PATA SSD. I’ve tried a WD Blue HDD and that works ok. Also, I’ve connected the SanDisk SSD Plus to an Iomega IConnect (USB to ethernet) and the SDD also works fine. I’m keen to try a direct connection as the SSD via an IConnect sounds better than a NAS connection, so I’m hoping a direct-to-USB will be better again.




Installed and working!!!

(ATV1 - 32gb pata HDSSD (evilBay) - simple NAS (Odroid C1 + openmediavault)