Volumio 2.368 and KODI Plugin: No IPTV Simple Client?

I did a test install on my RPI3 with fresh latest-greatest Volumio 2.368 plus KODI plugin.
Everything installed fine and monitor and sound worked great.
But when i tried to find and install the “IPTV Simple Client” KODI plugin there was no plugin to be found.
There is no PVR section in the adon menue.

In the end i installed it by “apt-get install …”
The plugin showed in the gui of KODI, i could give the params to my IPTV playlist but when i tried to activate the plugin
it failed with an error message that “share modules could not be loaded”.

So my question is: Is the IPTV plugin a no-go for KODI on Volumio or is there a trick i didn’t catch?

T.i.a. Frank

Hi Frank,

You need to manually install the client you want to use.
This page might help.


sudo apt-get install kodi-pvr-iptvsimple

Ah, i see.
I will try this soon.
I guess what i forgot was to add the KODI repo to the Volumio sources.list.
So the install did not work on necessary config files or dependencies.

Thank you, Saiyato!

I will report back.

As promised i report back:

After installing a (probably) missing package and turning off the Volumio startup sound the kodi-iptvsimple Client works as expected.

Long text
I started with a fresh install of Volumio on my Raspberry PI3. Sound output in my case is a usb soundcard.
This combination was setup and running out the box.
Next to this i installed the KODI Krypton plugin from the inbuilt plugin library.
The plugin installed without problems.
I could access the web interface of KODI and have my settings.
First problem there: NO SOUNDCARD inside audio output settings.
After some reading and experimentation i found out that i only had to switch off Volumios startup sound and reboot to have my
usb soundcard to setup in KODI.
Next to install was the kodi-pvr-iptvsimple addon. So i enabled ssh on the Volumio dev section and went into a ssh shell.
After a sudo update i could install the addon flawlessly and reboot just to find it in the addon section of KODI.
Next was to transfer the KODI.m3u playlist for the German free TV channels which i had readily available from the KODI forum.
I used this playlist already for playing free tv with vlc media player before which works quite fine.
So made a file transfer of the playlist to the /home/volumio directory. I do this with the secure ftp on my ubuntu system that i use in
a virtual machine because i found many things much easier to do on a RasPI machine if using Linux operating system.
Next was to setup the plugin which i did by point the playlist section to the /home/volumio/kodi.m3u.
Next was to enable the plugin. But FAIL. Message says something about a shared lib cannot be loaded, Check the logs.
I did not know where to check the logs. But inside the Volumio i found Kodi crashlogs telling nothing.
Also, the standard logs inside /var/log/message did not help.
So i decided, just to check if iptv basically runs, to install the addon kodi-pvr-demo. I read the the simple iptv client was based on that and to me
it just turned out logical to check.
After install, like mentioned above and reboot i suddenly noticed tv programs to be loaded by the iptv simple plugin als well as the empty
demo videos from the newly installed plugin.
So i did a deeper dive into what is installed by the demo addon and found that the library named
was the only dependency that was missing in my system to have kodi-pvr-demo to be installed.
So i did an apt-get remove to see what will happen if i did an uninstall of the demo addon. Reboot and nothing special happened.
The iptv still working! And the mentioned lib still installed. Did not do a purge, though.

So these are my findings. I am not an expert. Neither of Volumio nor Kodi inside mechanism.
Maybe someone can make use of my information and get some more precise info.

Besides this i am very happy to have my entertainment world unified in one system.

Greetings and warm thanks to all Volumio Kodi RasPI dev teams and persons out there!

That’s weird behaviour indeed, I did the following:

  • Install Kodi plugin
  • Install pvr simpleclient
  • Restart Pi
  • Start Kodi plugin
  • Enable add-on
  • Load m3u
  • Restart add-on (said it needed that)
  • Watch TV

Works perfectly so far (3 minutes of playback, but I’ll leave it playing for the next few hours).

Hi Saiyato

Kodi plugin works on x86 volumio release?

No, I need a ppa for that