volumio 2.185: airplay disconnecting frequently


since I updateted to the last volumio version 2.185 I got several problems in having a stable airplay streaming.

While playing audio with my mac connected to volumio via airplay the connection breaks and afterwords the volumio airplay disappear from the network. The only way to connect it again with airplay is to reboot volumio.
This happens mostly when I manually change songs in iTunes or I change the streaming source of on my mac (itunes, web video, vlc, ecc…) .

I am using volumio with a raspberry pi 3 on a wireless network.


Can you send logs when that happens please?
volumio.github.io/docs/User_Man … oting.html

Please paste the log link in this thread. Thanks


here is the log: logs.volumio.org/volumio/UWUo8PT.html

First I see that you installed pulseaudio and bluetooth, and this might be conflicting. Second, did you seek trough the UI?

yes, I was using the previous version of volumio and I added pulseaudio and bluetooth, but the problem started occurring after the upgrade.

Before even when volumio got disconnected it was possible to reconnect to it. Now the only way is rebooting volumio.
Probably the Airplay server (or whatever enable airplay on volumio) crashed.

I doubt this could be a conflict with bluetooth and pulseaudio, but if you think so, I can try to make a fresh installation.

I don’t understand what you mean by “seek trough the UI”, could you explain better?
After the "crash"I can access the UI via web normally and play whatever is on the harddrive. Just volumio doesn’t appear anymore as airplay device.


If you could try with with a fresh install that would be super useful…

Now I see, I struggled quite a lot to add the bluetooth functionalities, so I would like to have a backup first :wink:

What I can tell you by now is that what’s going on is that “shairport-sync” crashes and I have to restart it.
So, if I restart it from the command line I don’t have to reboot the volumio and everything works again.
Was the shairport version changed in the last volumio release?

Yes it changed, along with few tweaks. If you want you can wait for the new release, to see if those problems are solved…

Hi! I’m on vanilla volumio latest and I get this error too. So after some time the airplay connection breaks and can’t be reestablished.

After the last update the airplay server seems to be very buggy.
I can connect via my MacBook to the volumio Airplay but no sound is playing.

I switch to Rune, Moodeaudio and Max2Play and everything is fine.

Can someone help me please? I still want to use Volumio :smiley:

I would like to know the shareport-sync reset command so I dont have to reboot anymore (as a workaround)

We’re working hard to solve the issue, but it’s not easy to understand what goes wrong.

If connecting via SSH, do

sudo systemctl restart airplay

Something that would help us if you could send the logs when it crashes. Thanks

Same issue is still evident in 2.201. As a workaround, if you want to restart Airplay without using an SSH command, going into Settings>Network and then clicking on a ‘Save’ button without changing any settings seems to work. It reports that wireless has been restarted and, soon after that, Airplay comes back up again (but it will go down again after a while if not in use).

I too am having the same problem with Airplay, my post here
In my situation, when this occurs I lose the ability to get to volumio.local but can get to volumio_ip

Thanks for posting ways to restart the airplay service so I don’t always have to abruptly unplug power and then power back on :frowning:

I found that I don’t need to change any settings, just clicking the save button seems to reset something that make AIrplay work again.

To help us debug this, please send us log IMMEDIATELY after airplay crashes. Thanks

volumio.github.io/docs/User_Man … oting.html

just fyi: I had submitted a log in my other post. I will submit more logs in this thread as crashes happen.

Speaking of, just booted my DAC, confirmed I could see the Volumio airplay service on my MAC, then suddenly it was gone…so here is a log;

Here is another crash log

Was playing Spotify over Airplay on my MAC from this morning to this afternoon, turned Spotify off for about an hour and just now tried to start playing on Volumio again, nothing.