Volumio 2.175 update from 2.141 internal music, webradio


im using raspberry pi zero w with

  • justboom dac zero
  • justboom amp zero

booth were running very smooth with 2.141.

Upgrading to 2.175 more or less wiped out my whole project.

In the dac and the amp i can’t access the radio as before:
“service”: “webradio”,
“name”: “fm4”,
“uri”: “http://mp3stream1.apasf.apa.at/listen.pls

on the amp update and rescan can’t find any files located on the internal storage and were played with the previous version without any problem.

thanks for your time and help

volumio@volumiodac:~$ ifconfig
lo Link encap:Local Loopback
inet addr: Mask:
RX packets:999 errors:0 dropped:0 overruns:0 frame:0
TX packets:999 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:136714 (133.5 KiB) TX bytes:136714 (133.5 KiB)

wlan0 Link encap:Ethernet HWaddr b8:27:eb:b6:da:97
inet addr: Bcast: Mask:
RX packets:984 errors:0 dropped:316 overruns:0 frame:0
TX packets:562 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:151402 (147.8 KiB) TX bytes:117864 (115.1 KiB)

volumio@volumiodac:~$ sudo iwconfig
wlan0 IEEE 802.11bgn ESSID:“dahoam5”
Mode:Managed Frequency:2.462 GHz Access Point: 30:D3:2D:6F:BA:E5
Bit Rate=72.2 Mb/s Tx-Power=31 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=63/70 Signal level=-47 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:2 Invalid misc:0 Missed beacon:0

lo no wireless extensions.

volumio@volumiodac:~$ cat /etc/resolv.conf

Generated by dhcpcd from wlan0


OpenDNS nameservers


volumio@volumiodac:/data/favourites$ sudo ping mp3stream1.apasf.apa.at
[sudo] password for volumio:
PING mp3stream1.apasf.sf.apa.at ( 56(84) bytes of data.
64 bytes from mp3stream1.apasf.apa.at ( icmp_seq=1 ttl=119 time=16.1 ms
64 bytes from mp3stream1.apasf.apa.at ( icmp_seq=2 ttl=119 time=21.3 ms
64 bytes from mp3stream1.apasf.apa.at ( icmp_seq=3 ttl=119 time=24.6 ms
64 bytes from mp3stream1.apasf.apa.at ( icmp_seq=4 ttl=119 time=33.2 ms

I tried a clean install with 2.175 and the same situation again.

  • Webradio can’t play the stream

any ideas? Need to go back to 2.141 :frowning:

Ok I did some more testing. At the moment i think it is only a Webradio stream thing.

Tried JustBoom Player latest Version too same issue.

Booth Images and Players working fine till a webradio is selected … afterwards the internal music folder is shown a empty in the webinterface.

2017-05-26T05:47:54.785Z - info: CoreCommandRouter::volumioPushQueue
2017-05-26T05:47:54.790Z - info: [1495777674786] interfaceApi::pushQueue
2017-05-26T05:47:54.795Z - info: [1495777674791] InterfaceWebUI::pushQueue
2017-05-26T05:47:54.808Z - info: [1495777674803] CoreStateMachine::updateTrackBlock
2017-05-26T05:47:54.812Z - info: [1495777674808] CorePlayQueue::getTrackBlock
2017-05-26T05:47:54.818Z - info: CoreCommandRouter::volumioPlay
2017-05-26T05:47:54.824Z - info: [1495777674822] CoreStateMachine::play index 3
2017-05-26T05:47:54.826Z - info: [1495777674824] CoreStateMachine::setConsumeUpdateService undefined
2017-05-26T05:47:54.829Z - info: [1495777674827] CoreStateMachine::stop
2017-05-26T05:47:54.831Z - info: [1495777674829] CoreStateMachine::setConsumeUpdateService undefined
2017-05-26T05:47:54.845Z - info: [1495777674832] CoreStateMachine::play index undefined
2017-05-26T05:47:54.847Z - info: [1495777674846] CoreStateMachine::setConsumeUpdateService undefined
2017-05-26T05:47:54.850Z - info: [1495777674848] CorePlayQueue::getTrack 3
2017-05-26T05:47:54.852Z - info: [1495777674851] CoreStateMachine::startPlaybackTimer
2017-05-26T05:47:54.865Z - info: [1495777674853] CorePlayQueue::getTrack 3
2017-05-26T05:47:54.867Z - info: [1495777674866] ControllerWebradio::clearAddPlayTrack
2017-05-26T05:47:54.869Z - info: [1495777674868] ControllerMpd::sendMpdCommand stop
2017-05-26T05:47:54.890Z - info: [1495777674886] sending command…

Sorry, can you clarify what your issues are please. You can’t play any radio streams, or just one specific stream? You have music files on your sd card (‘internal storage,’ Samba share) that Volumio can’t find?

There are mp3 files on the sd card. ‘internal storage’.

When I start any added m3u/pls radio stream, i can’t play. After trying to start the radio - volumio can’t find the files. So everything is fine till I want to start any Radio Stream.

What happens when you try to play a radio stream? Have you checked /var/log/volumio.log for errors?

Check if the stream plays ok from cli:

mpc add http://mp3stream1.apasf.apa.at/listen.pls mpc play

Thanks a lot for your time! After trying the url from the webgui the mpc/mpd is more or less down (no response from mpc status --> error timeout).
This is maybe the thing why i can’t see the mp3 files after startet the stream.


May 27 09:40 : zeroconf: No global port, disabling zeroconf May 27 09:40 : client: [0] opened from local May 27 09:40 : client: [0] closed May 27 09:40 : client: [1] opened from local May 27 09:40 : client: [1] closed May 27 09:40 : client: [2] opened from local May 27 09:40 : client: [2] closed May 27 09:40 : exception: Failed to decode http://mp3stream1.apasf.apa.at/listen.pls May 27 09:40 : player: played "http://mp3stream1.apasf.apa.at/listen.pls"

2nd stream url:

May 27 09:43 : client: [10] opened from local
May 27 09:43 : player: played "http://fm4.amd.co.at/m3us/listen-high.m3u"
May 27 09:43 : client: [10] closed
May 27 09:43 : client: [11] opened from local
May 27 09:43 : client: [11] closed
May 27 09:43 : client: [12] opened from local
May 27 09:43 : client: [12] closed


2017-05-27T09:36:14.414Z - info: CoreCommandRouter::volumioAddQueueItems 2017-05-27T09:36:14.419Z - info: [1495877774414] CoreStateMachine::addQueueItems 2017-05-27T09:36:14.424Z - info: [1495877774419] CorePlayQueue::addQueueItems 2017-05-27T09:36:14.428Z - info: uri=http://mp3stream1.apasf.apa.at/listen.pls, title=FM4, service=webradio 2017-05-27T09:36:14.433Z - info: First index is 10 2017-05-27T09:36:14.438Z - info: ADDING THIS ITEM TO QUEUE: {"uri":"http://mp3stream1.apasf.apa.at/listen.pls" ,"title":"FM4","service":"webradio"} 2017-05-27T09:36:14.445Z - info: [1495877774441] CorePlayQueue::saveQueue 2017-05-27T09:36:14.453Z - info: Adding item to queue: {"uri":"http://mp3stream1.apasf.apa.at/listen.pls","tit le":"FM4","service":"webradio","name":"FM4","albumart":"/albumart","samplerate":"","bitdepth":0,"channels":0} 2017-05-27T09:36:14.457Z - info: CoreCommandRouter::volumioPushQueue 2017-05-27T09:36:14.463Z - info: [1495877774459] interfaceApi::pushQueue 2017-05-27T09:36:14.468Z - info: [1495877774464] InterfaceWebUI::pushQueue 2017-05-27T09:36:14.483Z - info: [1495877774479] CoreStateMachine::updateTrackBlock 2017-05-27T09:36:14.488Z - info: [1495877774484] CorePlayQueue::getTrackBlock 2017-05-27T09:36:14.494Z - info: CoreCommandRouter::volumioPlay 2017-05-27T09:36:14.499Z - info: [1495877774497] CoreStateMachine::play index 10 2017-05-27T09:36:14.501Z - info: [1495877774500] CoreStateMachine::setConsumeUpdateService undefined 2017-05-27T09:36:14.504Z - info: [1495877774502] CoreStateMachine::stop 2017-05-27T09:36:14.506Z - info: [1495877774505] CoreStateMachine::setConsumeUpdateService undefined 2017-05-27T09:36:14.523Z - info: [1495877774508] CoreStateMachine::play index undefined 2017-05-27T09:36:14.525Z - info: [1495877774524] CoreStateMachine::setConsumeUpdateService undefined 2017-05-27T09:36:14.528Z - info: [1495877774526] CorePlayQueue::getTrack 10 2017-05-27T09:36:14.535Z - info: [1495877774529] CoreStateMachine::startPlaybackTimer 2017-05-27T09:36:14.538Z - info: [1495877774536] CorePlayQueue::getTrack 10 2017-05-27T09:36:14.548Z - info: [1495877774539] ControllerWebradio::clearAddPlayTrack 2017-05-27T09:36:14.550Z - info: [1495877774548] ControllerMpd::sendMpdCommand stop 2017-05-27T09:36:14.555Z - info: [1495877774553] sending command...

Did you try playing the stream from the command line rather than the Volumio UI?

the first reply from the mpd.log is after trying mpd add and mpd play.

the second and third is from the volumio.log after trying the gui.

Thanks a lot chsims1 !!

finally i found a workaround for the pls:

using the ipadress and port 80:
works fine now.

So at least I only find out how to load a playlist with radio streams via lirc :slight_smile:

Glad you’re sorted: mpd is a great piece of software but it has some real idiosyncracies. It works fine on a RPi3, but the RPi0 had to be different :slight_smile: