Volumio 2.001 - cannot mount Network Drive

I am running Volumio 2.001 on a pi0 with wifi dongle. It is impossible to mount my NAS (Fritzbox+Harddrive). Basically I cannot mount anything (even though the devices get detected after scanning for network drives).
I can set everything manually, but I never receive any confirmation from the UI (nor the NAS get Displayed in the overview). I am going back to v1.55, though I will miss the features of v2.

PS. Sometimes I did not get any confirmation nor Overview, but the NAS is mounted and I can find it in the Library… Though it is gone after a reboot…


I just tried out adding the fritz-nas folder to the volumio network shares and it seemed to work.

If I enter the credentials right away, the share was added successfully. But when entered the credentials in the prompt that comes up if volumio detects a protection, the share info was apparently not updated… For my tests I used the auto-discovered fritz-nas entry and just added the credentials to it.

However, when I remove the share, the items are not removed from the DB, not even after Rescan/update.


Hmm strange things. I am currently trying a workaround (not sure if it will work out yet). I added a dedicated user on my fritzbox just giving access to the Music Folder on the NAS. Then I added the auto-discovered fritz-nas entry without adding anything but username and password… it seems Library is stored even after reboot/unplugged power…

The problems could also relate to the fact, that I “outcommented” the auto ethernet statements (which prevents the pi0 from starting without usb2ethernet device attached).

UPDATE: still the Library has not finished scanning…

@Jochen might I ask for the patg/settings you added for mounting the Fritz-Drive?

In v1.55 I use the
with an empty Remote Directory and the Mount-Flag: sec=ntlmv2

In v2, copying this settings does not work for me

I’ve tried everything, still the scan starts really fast but gets slower and slower until it finally stops, without continuing…Hence I could not integrate my whole NAS. The only workaround would be to split the NAS into 6-7 parts and mount each folder seperately.
Going back to 1.55 now :confused:


I’ve just tried twice to run the latest Volumio 2.001 on my Raspberry Pi2 B.
First with an image copied with Win32DiskImager, second with Etcher both running on a Windows 7 64bits.

I confirm Volumio can’t mount my NAS. It sometimes can’t even detect the NAS automatically on “My Music” webpage.

I tried to understand the why. It appears Samba can’t run due to the fact there is no /var/log/samba directory. Thus it can’t write its log file at /var/log/samba/log.samba. I created the missing directory as root, so samba started and ran well. But after a restart, I had the issue again as the folder disappeared.

I finally run the previous version 0.976 with no issue.
Edit: Then the update to 2.001 via the WebUI works well.


That sounds like an approach, are thos old versions available for download? Did you mont the NAS before or after update?

Hi shaDNfro,

You can have some previous images on the link below

I mount the NAS before the WebUI update to version 2.001.

For info, the bug seems described and analyzed here: