Volumio 1.5 for Raspberry PI Feedback Thread

After a Clean-Install of Volumio 1.5 the name of the renderer is “volumio”. If I try to Change the Name in the system-settings-page (it should be named “MediaCLT-Bad”) it shows a Massage saying: “Job failed. Backgroundworker is busy”.
If I restart the player, the Hostname is “MediaCLT-Bad” and the name of the renderer is “MediaCLT-Bad”.
Then I turned of Airplay and the DLNA Library Server and changed the IP-Adress from DHCP to static. Now the name of the renderer is “null: Upmpdcli”.

Restart didn’t fix the problem. After a re-flash the same error occured.

It also made no difference, if I changed the IP to static first and then renamed the Client.

Thanks for your posting. I executed the following in order to downgrade to 3.12.26 and it’s working great now.

sudo rpi-update e38850519c56b835dbd1c81e04d9307e154c36ed

That is an awesome distribution!
Thanks a lot Michelangelo and all the other people who’ve put their love, time and skill into that project.
Volumio has been a real boost for my audiophile life and it’s getting better and better … just downloaded the new version and felt like a child on christmas eve :mrgreen:

There’s just one small issue I figured out so far and that was already mentioned by “DrawsACircle” - despite having chosen “software” as mixertype, spotify volume level stays the same, no matter what I do with the knob.

One more thing - not sure though wether this is the right thread to post it - tell me if it’s not!
Since there’s a spotify folder in the browse section now - is there a way to integrate it into mPad? For now I can only see the USB and the Webradio folder as before. The Webradio folder is “empty”. Can I make the additional content visible?

Thanks and have a great evening!

Adding radio station.

When i add a radio station, in my case the 3fm on icecast.omroep.nl/3fm-bb-mp3 It doenst work.

There is a .pls file created with the name i gave it and only the url i entered. This doenst seem to be enough for a .pls file, when i rename the file to .m3u it works.

I believe the script behind it needs to be altered to make working .pls files or just .m3u instead of .pls

An example .pls

Title1=(#1 - 307/512) Absolutely Smooth Jazz - SKY.FM - the world's smoothest jazz 24 hours a day

Oh and how would volumio be updated if apt-get update / upgrade breaks by design?

Thx and goodluck

Could one of you clever people tell me how to do this in words that are simple. I tried this

but it didn’t work. Said I needed to install something else first, which did not work. :neutral_face:

Guys, many thanks for the feedbacks. This will allow to spot the bugs I’ve missed and prepare an update.

The update will basically launch a script, so no package update involved.

Please keep up on posting what’s wrong, it’s really useful in that phase.

Hi Jotak!

I understand your motivation!

Your work and the result to achieve the functionality of this facility are great!

Maybe my expression on that issue feels a little rocky. But- as I said- it’s a matter of individual needs.
My main ambition is sound quality- and that’s a very sensitive thing with digital audio.

Don’t see my comment as a hard critic in general. I am completely satisfied with the possibility to turn it off. :wink:

Besides: I play wav files only (for sound quality reasons). That fact for itself excludes proper functionality of
the library option (no tagging).

It’s good to see, that volumio is a chamaeleon, that gives tools in each users hands that allow personal modification.

Greetingz, Robert

First real issue spotted: the i2s drivers seems a bit messed up. To help fixing it please report:

1- Is your i2s DAC working?
2- Are you on Raspberry PI B or B+?
3- Report which i2s DAC you use
4- Report which bitrates and bitdepths (16/24 ecc) works and which doesn’t

Confident we’ll have everything up and running in less than 2 days

Not sure what’s going on, but I set up a new thread to take a look!

Hi Musicopath! The Spotify folder is actually controlled by Spop instead of MPD, so unfortunately any MPD clients will not be able to see it… :confused:


First of all, “congratulazioni” for the hard work and new features!

I used to use MpDroid as interface and I used to organize webradios in subfolders in the webradio folder and select them from the app.

From the web interface I don’t see the subfolders. Is there a way to see them?

Now I am having problem to check if also in this version I can see via MpDroid since this app doesn’t connect anymore to Volumio (see my other post, seems to be a common issue).


  1. working
  2. B+
  3. hifiberry dac+
  4. 16/44.1 work, 24/96 locks it

so, current latest kernel doesn’t support 24bit and previous kernels doesn’t support Dac+… that right?

Hi, Michelangelo!

I’m running volumio on Rpi B with Hifiberry Digi- works without problems.
In general I didn’t find a real bug till now.

Everything fast and smooth

Great work!

Another interesting behaviour; adding a wifi dongle results in the eth0 i/f going DHCP from static. It was at, plugged in a wifi dongle and configured the Network page appropriately, then rebooted. After that, the eth0 static address was still set on the Network page but the Pi was actually at


1.5 looks amazing. thanks for the huge work !!!

  • Does the repositories address (in /etc/apt/sources.list) has been fixed (in order to install python and other stuff on the top on the volumio install)

  • I Will install the 1.5 version tonight using a Raspi B+ and an iqaudio dac+ … does any others volumio users have already tested this “combination” ?


I included latest version of python into Volumio, if you would need something else you should be able to do it, but don’t upgrade everything.
IQaudio Pi-dac works, you can find more informations here:


Many thanks - love the quality of playback. Using PI model B. DLINK 320L NAS & and Hifiberry.

After flashing, I had difficulty with 1.5 setting the NAS from the GUI . I needed to revert back to ssh and creating dir and access rights. Did not need to do this in 1.4 or 1.41.

Used the following to give permissions

mkdir /mnt/NAS mkdir /mnt/NAS/NAS chmod -R 7777 /mnt/NAS/NAS
Don’t seem to be able to add the BBC radio stations from:


I pasted the copied URL into the the dialogue and they added to menu but don’t play?

Good new have successfully tweeted what I’m listening too…

Many Thanks Team

Some issues:

  • mpd not listening to port 6600 -> solution posted in the help forum

  • I use a nas with samba. The share is configured with guest readonly. Volumio 1.4 did work without putting a username and a password in - 1.5 won’t!
    I think this is due to automatically putting the user “guest” in if you try to keep it empty

  • Some strange phenomenom with mp3-tags. Under 1.5 I have several songs displayed with the tag “unknown” - under 1.4 everything is completely fine.
    No idea what the reason is. At the moment the only reason I can sort out are the Unix access-rights on the NAS. The used mpd-client is cantata.

Hi guys and thank you Michelangelo!
Very nice work with this new release!
But I have the same problem of other guy:
With 16/44.1 everything’s ok.
With 24/96 speed is triplicated.
With 24/192 no sound and volumio reboots.
I have rasp bi + with iquaudio dac +.

I’ve installed Volumio 1.5 yesterday, thanks for the great work in this new release !

Here is what I’ve noticed so far :

  • The library tab is always empty, it never displays the content of my collection (artists, genre, album, tracks, etc. are empty). This might be due to the size of my collection, which is about 20000 tracks.
  • the browse tab and the playlist tab are sometime really slow to reply. After waiting a while (approx. 2 min) it usually get backs to normal. This seems to happens sometime randomly but always happens when restarting mpd. Yet mpd is up and running fine must faster, it answers requests from external mpd client only 5 sec after restart. That’s not something new though, I have the same issue with 1.4.
  • usb dac hot plug does not work, when plugging the dac the dev has wrong permission (no audio group). That’s something I’m currently working on.

Let me know if you need more info and keep up the good work :slight_smile: