volumio 1.5 + emotiva stealth dc-1 issues

I just gave the new version of volumio a spin and it works great via usb out to my emotiva stealth DC-1. switch to tracks higher than 16/44.1, however, and everything starts clicking and sounds horrible. suggestions?

interesting point of clarification:

this seems to only happen when playing music via the web interface or controlling mpd directly.

if I fire up jriver and use it as a dlna control point with volumio as a dlna renderer everything switches around just fine (i can see the sample rates changing on the emotiva display).

mpod/mpad controls mpd fine, but the clicks persist.

the symptoms suggest that I need to enable the “dirty” CMedia fix, but the toggle won’t toggle!

it uses the C-Media CM6631A chip

it looks like this issue was fixed by ALSA back in 2013 with patch v.5 and Volumio is using k3.12.26+ ?

permalink.gmane.org/gmane.linux. … vel/106773


why are cmedia issues consistenly ignored on this forum? if it’s not onboard i2s it doesn’t matter?


If you get some time to try the latest version of ALSA, let us know your findings. If it works, sounds like a candidate for inclusion in a future Volumio image release!

i have no idea how to apply the patch, which is from 2013. i guess i’m wondering why it hasn’t been included by now…




Looks like from this post that the Cmedia fix sends two pause commands between tracks with different bit depth or sample rate. Not sure why you’re having trouble toggling the Cmedia fix on. Try manually sending two pauses while playing the affected track, and see if at least that works.

telnet localhost 6600 pause pause close

Did you try to use the C-media fix? Go to system -> c-media fix enable. Let me know

From “Volumio 1.5 for Raspberry PI Feedback Thread”

I don’t know what typo, but the toggle doesn’t toggle in 1.5.

@thaddeussmith; please don’t bump twice a day, and it is possible to edit a post

Ok I’ll see what the problem is with C-media Toggle

“wether” should be “whether”. cmedia support should be a priority since it has obviously been an ongoing issue for the life of this project. ALSA appears to have fixed it, why not apply the patch?

I have this same issue. I connect DC-1 to Raspberry Pi2 running latest volumio. I only hear static. The c-media toggle is greyed out. I tried telnet by sending 2 pauses but that did not help either.

Any help?

I am also suffering from the same problem using the Emotiva XDA-2 Gen2 DAC via USB and the greyed out CMedia fix toggle. I have found if I hard code the sample rate at 16/44.1 everything plays fine. Pretty bogus the CMedia toggle is broken and a years old patch hasn’t been applied.


I also have exactly the same problem. Crackles and pops with 24/96K files. Horrible pink noise with 24/88K files. All fine with 16/44K files.

I also have the problem that the CMedia fix toggle in Volumio doesn’t work so I can’t apply the patch.

Raspberry PI Model 2
Volumio 1.55
Emotiva Stealth DC-1. Async USB 2.0 connection from RPI.
Files on Synology NAS accessed via DLNA over Ethernet
Bubble UPnP controller on Android.

I’ve tried playing with the DAC settings (change to USB 1.1 mode or turn off Async mode) and it doesn’t change anything.

The best thing right now would be to fix the bug in the Volumio GUI so we can try the CMedia fix, or send instructions about how to do it manually.


Well I tried the CMedia fix manually. I found it on another thread.

login to the RPi via ssh, and then

telnet localhost 6600

That didn’t work.

I tried the fiq_fsm fix too. Also on another thread you can find how to modify /boot/cmdline.txt to enable fiq_fsm. As far as I understand, it is a re-written USB driver that uses higher priority interrupts.

That didn’t work either.

Then I tried installing Rune and Moode (alternatives to Volumio).

I also tried updating the Linux firmware and drivers to latest versions.

So I guess I just can’t play HiRes music files from RPi using the Emotiva DAC. As far as I can see from the various discussions, this is a general problem with the USB drivers on the RPi. Maybe a future release of the kernel will fix it.

Options left:

  1. bypass the RPi. I can play HiRes files if I connect the MacBook Air to the DAC. Not very convenient but guaranteed to work.
  2. buy an interface card for the RPi and try a S/PDIF connection to the DAC
  3. buy a different hardware device for Volumio.

At the moment, option 1 is all I have.