Volumio 1.5 Auto-Mount

I have a strange configuration and a strange problem. Hoping someone can point me in the right direction.

I have managed to install Volumio 1.5 on a Next Thing Corp CHIP computer (I don’t have the linux skills to port v2 to the CHIP). I essentially followed the instructions here: http://typingoutloud.org/raspberry-pi-installing-volumio-pibang/.

Most things work well, but attaching to network share is not working. I’ve tried too many times to count to use the web interface to define the NAS mount and it just refuses to work. So my next step was to manually configure the mount through the cli. It works, but it won’t automatically mount the share at reboot. Actually it works prior to installing Volumio and after installing Volumio for a couple of reboots, but at some point it stops working. I’ve tried adding a command to the crontab, but that doesn’t seem to work either.

Two questions:

  1. Anyone know what’s going on?
  2. Anyone know where the mount config file is located in var/www?


Could you mount it at boot in fstab?

I’ve put it in fstab, but at some point after I install Volumio, fstab appears to be disabled.