Volumio 1.4 won't boot on my beaglebone black

First, apologies if this has been asked and answered, but my BBB won’t boot from the sd card. When I switch on the BBB with a card in the slot, the power light and first three user lights come on and stay on. Not surprisingly I can’t see the BBB on my LAN. I can see it and ssh into it when it boots up “normally”, ie with an empty sd slot.

I followed the instructions on the volumio website, with two different sd cards, formatting them as FAT with disk utility on my mac, then completing the sequence of commands to copy the volumio image onto it. I tried 2 cards to eliminate the possibility that the first 16GB card was too big. The second was 2GB. I’m using a 5W power supply, by the way, so power shouldn’t be an issue.

I’m not sure what else to try, as the last time I nerded about with fstabs and stuff like that was in the early 90s… Happy to take instruction from properly clever people though.

Please help, cos I’m insanely curious to hear this thing work!

Thanks in advance,


To boot Volumio (as other OSes) from SD Card on BBB you should press the “usr” button (next to SD card if I remember right) just when you power it up. Keep that button pressed and Volumio should boot.

Quoting from
shrkey.com/setting-up-beaglebone … rosd-card/

Oops – forgot to say, I tried that. Held it down for a short time (a few seconds) and a long time (at least a minute). Same result…

First, huge thanks to everyone who got in touch to help. I finally solved this by upgrading the bone to the latest version of the flashed OS. Happily it does not require using the “usr” button to boot from the SD.

So new BBB users – do yourselves a favour and don’t be lazy about following the instructions on the beaglebone.org Getting Started page…