Volume settings don't work properly

Volumio Information

Volumio Version: 2.779
Hardware: Raspberry Pi4 B 4GB
DAC: AudioQuest Dragonfly Black 1.5

Greetings from Germany,

I’m having a few problems with the volume settings.
If I set things like default volume for start up to 10 or the volume steps per click to 1, it get’s ignored.
The settings are still there but without effect.

Through the volume Bar, I can change the volume only in steps of 5. But that’s too much for my setup.

The volume plus and minus buttons in the Browser don’t work properly. Minus works maybe for 2 clicks.

I hope you can help me.

Kind regards,

okay, now i can identify the problem a bit closer.

I have problems setting volume with the HW Mixer using my Audioquest Dragonfly Black 1.5.
If I use the round volume control element on volumio (Dekstop), I can set the volume in steps of 1, as configured.

But the slider on the buttom of the page is only working in steps of 5.

The volume up and down buttons below the round volume control element (on desktop) and above/ below the volume slider (on mobile) often only work in positive direction, but in variing steps of 1, 2 or 3.
Volume down works sometimes and if it works, then only to a certain volume level (36 or 40) and then it is stuck there in downward direction.

It’s the same behaviour when using a rotary encoder or an IR remote.

If I configure it to software mixer, then everything works fine, but that’s no option because i want to use hardware volume control.

Could some one please help me?

Kind regards Marcel

Hi Marcel, since we use logarithmic volume control sometimes there are rounding errors which prevent steps of 1 to work properly
You can try to use linear instead of logarithmic

Hi, i tried linear aswell.
Makes no difference in control, when using HW Mixer.

My main problem is not, that the steps are not accuratly at 1.
That’s not a big deal for me.

But it’s really bad, if i want to lower the volume via rotary encoder or via soft buttons on the panel and it gets stuck at 36 or similar.

Could the Volumio Support please, please help me?
Or tell me what the problem could be, so I can get a bit further to a solution.

Thank you very much.

Regards, Marcel

@ Volumio
I’m still struggeling with HW volume control on Audioquest Dragonfly Black V1.5 and Dragonfly Red V1.0
Both have HW-Volume control build in.

The round volume control does work. I can increase and decrease the volume with that elemnt… BUT the soft buttons, rotary encoder or ir remote don’t work properly.
I can’t lower the volume through these things.

Please help me.


I have had a similiar problem. I got my setup with a rotary encoder working this way:
#1: Fresh initial setup with i2s dac, important: no reboot right after.
#2: Then I set startup volume to 25%, volume steps to 2 (1 never worked for me), disable startup sound.
#3: reboot
#4: installing other plugins: simple eq, activate, reboot, rotary encoder, activate, reboot.

After that my system is functional in the desired manner. My trick is after this never to touch any output options, mixer or volume settings. If I do - things get screwed up somehow.

Maybe this helps you too,
regards, Phil

Hi Phil,

Thank you.
I will try that and give feedback.
I hope it works with usb DACs aswell.

Kind regards

I forgot to mention, I soldered two 67nF non polarized capacitors, each to the clk and dt pins of the encoder for debouncing. Without these I couldn’t achieve precise volume steps and had sometimes an automatic, ghostly increase of volume.


Hi Phil,

I tried it your way, but it didn’t work.
But thank you very much :slight_smile:
It was worth a try.

After a new setup of the sd card with the newest Volumio image, the volume is still stuck on the way down at 36.

What I don’t get is that the round volume control element is working, but the other control elements have problems with lowering the volume.

Sorry that it didn’t work out.

To clarify things, when I click on my desktop browser the volume up/down-buttons below the rounded control, the volume changes in steps which I have set in the config, except inaccuracy due to roundings “volumio” mentioned in an above post. Same happens when I turn the rotary encoder, or use the mousewheel over the round volume control.

When I use the horizontal slider bar on the bottom of the screen, volume steps are of 5, not 2 as I have configured, also the mousewheel is not active here, this looks like a bug to me.

The behaviour you described, that the volume change is stuck at some point or not reacting at all sometimes, I never experienced by just clicking buttons in my browser or using the horizontal slider, it only happened when using the rotary encoder without capacitors.

When you connect to volumio via ssh, you can trigger on the command line the exact same functions the gui uses:

volumio@volumio:~$ volumio volume plus
{“time”:1596382848814,“response”:“volume Success”}
volumio@volumio:~$ volumio volume minus
{“time”:1596382854743,“response”:“volume Success”}
volumio@volumio:~$ volumio volume 35
{“time”:1596382879989,“response”:“volume Success”}

Have you checked this? Is the volume stuck too this way?
Additionally, if you enable the live log (http://volumio.local/dev), do u see errors when doing volume changes?


hi Phil,

I tried both.
The result is the same. The volume is stuck at 36.
Her is the love log. No errors.
First one from soft button, second one from ssh.



If you manually set the volume via ssh to steps below of 36

volumio@volumio:~$ volumio volume 35
volumio@volumio:~$ volumio volume 31

and then

volumio@volumio:~$ volumio volume minus

Does it decrease correctly?

Yes, if I go to 35 I can decrease till 0.

I have found another point at 86 where it does the same.
When I set it to 85, i can decrease until 36 an there it gets stuck again.

That’s really weird…

hm, I wonder if it could be an issue with rounding/not rounding a value passed to the hw-mixer, which can’t handle it, because of the format maybe, too many digits, whatever.

Yes, maybe.
I saw that the round volume control Element is setting the volume directly to a value.
That’s why it’s always working.

I hope the volumio Support can help to fix that.

Maybe it is possible to change the commands from the Buttons to Set volume to the act volume +/- 1.

@volumio is there any chance to get some help?

On the Dragonfly DACs the HW Volume control is not working correctly when using “decrease” buttons, rotary encoder or remote.

Currently I’m using the linear volume curve with steps of 4.

With this config, the volume is not stuck at 36 or 86.
But the steps are not “4” every time… it varies from 3 to 5.

Thank you.
Kind regards Marcel.

It’s an alsa rounding error.

This happens because if you set volume to 35, alsa reads it back to 35. Because it concerts the value from a scale of 255 to 100… There are a small numbers of dac affected by this issue, unfortunately one is yours.

Bad news : I have no idea how to circumvent this behaviour to solve your issue
Can you try by setting volume to linear instead of logarithmic?

it is already set to linear.