volume 100% fixed on Pi + Soundblaster Live usb

Hi there,
Found Volumio yesterday, installed it on my Pi and tried a few usb sound devices. Very good! I like it, willl make a permanent audio player with a lcd-screen + rotary button control…

It has a problem though: the volume control is fixed to 100% when using a new Soundblaster Live USB.

when I change the volume in the web control, it jumps back to 100%. When I enter a value by keyboard, volume does not change and the (control dial jumps back to 100 on the next mouse clock. Audio output from the webradio is very hard, probably on the edge of clipping.
Volumio version is beta 1.4

I tried 2 other USB devices (after a reboot of the Pi):

  • a cheap Conceptronic usb1.1 sound device : volume control on the web page works fine. (And had unbearable distorition on webradio, but not on audio files stored on the sd card).
  • a much better EMU 0202 96kHz 24 bit usb sound i/o device, which also had the volume fixed to 100% (it’s twice the size of the Pi and needs a powered usb hub)

I started alsamixer in a terminal and that controls the volume of the SB-Live nicely.
My audio devices :

$cat /proc/asound/cards 0 [U0x41e0x30d3 ]: USB-Audio - USB Device 0x41e:0x30d3 USB Device 0x41e:0x30d3 at usb-bcm2708_usb-1.3, full speed 1 [ALSA ]: BRCM bcm2835 ALSbcm2835 ALSA - bcm2835 ALSA bcm2835 ALSA
and the first 2 mixer controls of the SB-Live (the ovther 5 are for the input):

$cat /proc/asound/U0x41e0x30d3/usbmixer USB Mixer: usb_id=0x041e30d3, ctrlif=0, ctlerr=0 Card: USB Device 0x41e:0x30d3 at usb-bcm2708_usb-1.3, full speed Unit: 9 Control: name="Speaker Playback Volume", index=0 Info: id=9, control=2, cmask=0x3, channels=2, type="S16" Volume: min=-7264, max=-16, dBmin=-2837, dBmax=-6 Unit: 9 Control: name="Speaker Playback Switch", index=0 Info: id=9, control=1, cmask=0x0, channels=1, type="INV_BOOLEAN" Volume: min=0, max=1, dBmin=0, dBmax=0

I would appreciate some help on how to restore normal volume control in the web gui. Are there any Volumio config settings that I could check?

Change the mixer type from Hardware to Software (over the WebUI, maybe you must restart your PI)