Version 3.396 on RPi4 network services not available at first boot

Yesterday I was trying version 3.396 on a brand new SDCard (RPi 4) and (tried twice on different sdcards), after burning it with balenaEtcher, it resized the filesystem and showed me the login prompt.

It showed me the IP obtained from my router (Fritzbox 7490, wired network) but for just a second the IP at the login prompt was something like a 192.168.211.x ip .
Looking on the router leases, the IP was actually released, but it didn’t respond neither accessing with a browser or to a ping command.

The webUI didn’t respond at the IP address,
I could see the WiFi hotspot on my phone, but, after putting the wpa key (volumio2) it didn’t get any from dhcp so the hotspot coudn’t connect (was stuck at ‘obtaining ip’ on Android)

So i could’t reach the first wizard neither from wired or wireless network.

Downloading the previous version (3.378) and upgrade after installation solved my problems, so now I’m at the latest version anyway.

I repeat the test 3 times in total (2 on the same memory and 1 on a completely different sdcard but same rasp4), and it keeps presenting same issues.

Is this just something happened to me?

Many thanks!

Others have reported problems with Etcher in the past. I always use RPI Imager.