Ver 2.282 problems

First, love the new getting started interface - should make it a lot easier for the first time users.

Next, the problems:

  1. Tried to update from the last official version. Locked up at 30% and would not continue. Lost use of the UI and finally had to do a hard shutdown (pull the plug). Tried to start back up but never could establish UI connection. Not a big problem as it seems Volumio updates are hit or miss, Re-flashed with new version and got things running. This is where I was surprised with the new getting started interface which seemed to work fine - nice job.

  2. Installed the GPIO plugin but cannot enter the “Settings” menu. Tried multiple un-installs and re-installs to no avail. When I click on the settings button it tries to do something but ends up going to a blank page. I use this plugin extensively in my setup and if I can’t get it set up and working properly, I’ll need to revert to the previous version. - Any suggestions?

Everything worked great with the previous versions.

Raspberry Pi B+, Ver 2; Hifiberry DAC+

I am looking at the issue with the GPIO buttons plugin, not easy.
I will deploy a fix for the system page, please be patient for the GPIO buttons one.

Thanks, Michelangelo. You and your team really do a great job with this project.

You’re welcome!
Fixed in 2.285, enjoy

Thank you! Downloading as we speak!


Until version 2.224 (intermediate), my disk was easily and correctly mounted. In later versions, Volumio does not mount the disk (it’s a hard drive on my computer [Windows 10], exclusively with music files).
I have tried versions 2.245, 2.246, 2.282 e 2.285 without success.

When I try to add the disk, I get the following message:
"Error in adding network drive
(11): Resource temporarily unavailable
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

RPi3-model B + Allo Boss

Am I doing something wrong?

Thank you.

P.S .: Sorry for my English.

We added the “soft” option to mount, maybe this is the issue… But I don’t know how to verify my assumption… Can you try to mount the disk manually?

Hello, Michelangelo. Thanks for the answer.

I’m a layman in programming and I have no idea how to mount the disk manually. Can you help me do it?

I do not want to change software. I have the OSMC (Kodi), which works perfectly, but I use my equipment exclusively for music and I really like Volumio; even bought the browser version for Android, too.

One more time, thank you.