v2.295 no LAN connection for me either

Hmmm. I assume I’m just doing something dumb, but since updating to v.2.295, my Pi can’t seem to access the network via LAN. The hotspot works. Accessing through the network works when the Pi is connected through wifi, but it seems to only connect through wifi. Accessing the NAS through wifi seems fine. Plays music. Plays webradio.

When I shut down wireless in Volumio, it doesn’t connect as wired. It also doesn’t fire up the hotspot so I’m locked out. As far as I know, my only option is to reflash. Which means I also don’t have a log file to access. I haven’t swapped ethernet cables around yet to see if it’s a bad cable. Any thing else I should try?

If I plug the sd card into another machine, can I pull the log file out of it? I’ve not ever poked around in there.

Thanks for any suggestions.


Whoops. Forgot to include. Pi3B. Kali. Piano.

And I don’t know if it’s relevant at all, but I have two Volumio Pis on the same network accessing the same NAS (usb drive plugged into router). The Kali/Piano has always been hardwired. The USB DAC has always been wifi. When scanning after the update and subsequent reinstall, I noticed they did not find the same number of files. They showed the same number of artists, but the one still working showed one additional album and about 150 extra songs.

In the past, I’ve had issues with the two machines disagreeing after a scan, but that seemed to have stopped for a while until now. Or maybe I just stopped paying attention after they matched once.

I tested yesterday Nfs connection and it works with 2.295 - but very slowly compared to the usb 2.0 port harddisk. I didn’t test Cif Lan connection.

Well, I thought I fixed it. Moved ethernet to another plug in switch. Raspberry found network and signed in. Then I switched to a fixed ip. Still worked. But was also connected to the wifi. Turned off wireless. Lost wired network. Have no hotspot again. No wired. No wifi. Reboot. Still nothing. Will reflash this afternoon.

Any suggestions?

Now 2.296 with no wired connection. Tomorrow I think I’ll swap it out with the other Pi that is wireless only. Maybe there’s a problem with the board?

It seems like I must be doing something wrong. I no longer have a static IP for the one that’s being goofy. Well, maybe I do. It keeps booting to the same IP, but it’s not the one the router is supposed to be forcing it to.

Hmmm. I wish I understood this stuff more.


same here. tried to install v2.296 fresh image.
cant connect to volumio at all. ip does show up in router.

thought my sdcard was defect. bought a new one , but still the same issue

where can i download older versions? cant find it on the website or github

i changed my usb charger with a 2amp version . everything works now :mrgreen: :laughing:

I’ve fixed many people’s Pis by replacing their power supplies, but this Pi is powered via the power supply on the Kali, so I doubt that’s the problem. But we will see when I start swapping things out.

I also doubt the SD card since it all works via hotspot and via wifi. Easy to try though.

Wired connection never shows up on the router at all.

Thanks for the suggestions.


Well, it seems it was all me. Replaced the network cable and everything is working fine except the hotspot. It stays on after the wired connection is established. I thought it was only supposed to come on when other connections were unavailable.