V 2.806 and static wired IP

To quote Queen, “I’m going slightly mad!”
Three times I have written an image of version 2.806 on my PI’s SD card, booted and found its IP, gone through the setup and then into ‘Network’ to change the IP to static and the number I want to use.
And three times it has gone missing???
This is not the first time I have gone through this procedure, so I thought I knew what I was doing !

I use the “static ip”-function over my fritzbox-router-OS. That works. Don’t know your type of router, but check it in your router-config. Think, you know what I mean. More than one times I read here about problems with updates when “static ip” in volumio is used. Maybe your problem is a similar one and is homemade by volumio…

I have never had this problem with other releases of Volumio with the same router setup.
In the end I accepted the Automatic assigned IP and have altered my NAS settings accordingly.
I have also reserved the IP and PIs MAC address in the Router in the hope it doesn’t change.
All a bit of a faff !

If your still up for it - can you check what your interface file looks like before and after setting up the static IP?

cat /etc/network/interfaces

Looking for possibly the simplest solution, but is there a possibility you are hitting the wrong button to complete the config?

I notice that when you change the settings to a static IP a warning pops up with two buttons.
One is entirely white, as if to highlight it, but is blank.
The other is normal and says “Continue.”

If you click the white button, the warning goes away and you might think the changes were applied. But you need to click “continue” to apply.

I got fooled by this the first time myself. It is different in appearance from previous versions.

If you’re sure you clicked on continue, then never mind, but it tripped me up at first.

The white button is light grey, with an unreadable text ‘cancel’ on it…

Good to know, but I couldn’t read it on my monitor.

your screenshot in fake color


Yes. I believe you. I assumed that anyway after it fooled me once. Just offering it up as something AudioPete might want to double-check.

Thanks all. I might revisit setting a static IP when I have the spare time, for now I just wanted to get things working.

The problem with your suggestion for me was that the PI disappeared off the network when I made the change to a static IP, so an ‘after’ check would be impossible.

I am pretty sure I clicked ‘Continue’, but I will certainly do so if I try it again. Volumio went through a what looked like a reboot process when I made the changes and I think a small popup displaying a progress bar, and of course I lost the UI as my browser was using the old IP.

I had a similar problem and it was user error. When you turn off auto ip it populates the ip address as, subnet mask and gateway dialog as . I mistakenly misread this and only changed the last number of the ip address, without noticing my network was 192.168.0.