v 2.245 does not boot with enable_uart=1

If I put the line


in /boot/config.txt my RPi 3 does not start anymore. This seems to be this issue (see also referenced issues therein):

Any ideas as to how to get this working? Or do I need to wait for the next update?

Why do you need it?
Anyway, it seems an issue of 4.9.36 kernel, wait for the next kernel update (no ETA)

I need it because I have built a power on indicator LED attached to the TxD pin:
howchoo.com/g/ytzjyzy4m2e/build … -indicator

Oh, that’s nice, it has been fixed in 2.246. Thanks!

Here is an update for future reference.

Settting enable_uart=1 normally also sets core_freq=250, which could have a slight impact on performance. To prevent this, one can switch of bluetooth instead (Volumio doesn’t use this anyway) like so:
This also enables a UART on the TxD pin.

raspberrypi.org/documentati … on/uart.md
Normally on the RPi 3, ttyAMA0 (PL011 UART) is connected to BT, and ttyS0 (mini UART) is disabled, and hence the Linux serial console is disabled as well. To enable the TxD pin for a status LED, a UART has to be assigned to it. dtoverlay=pi3-disable-bt disables BT and reassigns ttyAMA0 to GPIO, whereas enable_uart=1 assigns ttyS0 to GPIO, but the latter also has the effect of core_freq=250 (necessary because the baud rate of the mini UART is linked to the core_freq).