USB library vanishes & web-radio won't open

I have a web-radio and USB library issue with v2.201 on a Pi2. The issue occurs after leaving Volumio idle for an hour or so. After which I find that my USB music library is now blank and it’s not possible to open a web-radio stream.

Attempting to open a web-radio stream conjures a notification suggesting that the stream is playing, but nothing happens: no sound; no playback summary; no change to the centre-top controls.

The only remedy is to restart Volumio. After the restart my USB music library reappears and the web-radio streams will open again. If I stop playback then an hour or two later the same problem returns.

Can you give us a few more details please? Is your USB library a hdd or a USB stick for example? In what way is the USB music library blank? Does refreshing the browser make any difference?

The USB library is a stick.

The ‘blank’ library is completely empty: no artist or album names, titles or images. Nothing at all.

Refreshing the browser doesn’t help. The only solution is to restart.

I should add that the issues seem to appear after I have switched between two or more web-radio streams. Streams which I have added by hand.

I think I’ve stumbled upon the problem. Or at least a consistent and repeatable pattern that suggests an issue.

The web-radio playback and library issue appears if I switch between a number of web-radio stations. Especially without first stopping the current stream. And the quicker I switch between stations the more likely it is to hit the wall.

In the numerous tests I’ve found that I need to switch between at least 4-5 stations to bring everything to a halt. After which I can’t open another web-radio stream, nor can I see anything in the artist and album libraries. The only option is to restart.

I’ve tried to reproduce this as you suggest, but unfortunately I cannot confirm it, using a RPi3. I’ll try a RPi2 & RPi0 when I have more time.

Something quite odd has happened.

I tried to open a radio stream. A red notification told me the stream had failed. This was immediately followed by a green report telling me it was playing. It wasn’t so I checked the artists section of my USB library to confirm a system error. Just as before the artists and albums had vanished from the library.

However, about 15 seconds later a new green notification told me that the stream was playing. Shortly after Volumio started to stream the channel through my speakers. I then returned to the USB library where I was surprised to find the artists and albums had reappeared.

Dear all,
Volumio2 is an absolutely great thing. There is one problem still there with the latest release on Rasp3 which is the web radio issue. It is happening quite often that when you start a web radio it does not start playing and no other web radio will play anymore. USB drive is gone and Rasp3 will not restart. You really have to do a hard reset. It looks like it does not happen with all radio stations. Here are some stations where I often have the problem:
It also occurred with other radio stations. I read somewhere that you can do ssh to restart mpd. I did not try it by myself but I have to say that this is not really practical for my family. So fixing the issue would be great. If you let me know what to do once the problem occurred, I can try to get logs.
Your help would be highly appreciated.
(config: Raspberry Pi3, HifiBerry Digi+, latest software release, clean install)