USB-drives on RPi not mounted (automatically)


The last few weeks I’ve enjoyed listening to the music on my network via Volumio on my Pi, but I just tried to listen music from a usb-drive, but somehow the USB is not mounted. It has power as I can tell that from the blinking orange light on the drive.

HOwever, wehn using the browse command, NAS and Webradio are displayed, but no USB. I tried FAT, FAT32 and NTFS, no difference.

I always thought that usb’s are automounted…or do I need to perform an extra task to accomplish this.

Using version Beta 1.3, having a HifiBerry Digi attached.

Thanks for your help!

Addition: just discovered dat /mnt/usb does display the contents of the USB-drive that is plugged in. But can’t access via the web UI or MPAD

Addition #2: just installed runeaudio and the USB-drive was found and mounted automatically (didn’t even unplug the drive), so it has to be something wihtin Volumio which is “blocking” the drive… (but as runeaudio is not supporting the hifiberry digi yet, I want to keep using Volumio)

I have the same problem. Recently installed Volumio on RPi, and it mounts a NAS drive perfectly every time. I copied some music files to an SD card plugged into a USB stick (to see if it solves intermittent pauses in playback playing over the network), plugged into the RPI but it doesn’t show up in the library. Have tried refreshing the library, and rebooting, but still doesn’t show up. As per the OP, the mount is displayed in /mnt/usb, so the OS is auto-mounting it correctly, I guess, but Volumio isn’t processing it for some reason.

At one point (after a forced library update), USB did appear on the library list in the browse window, but clicking on it showed just an empty list - it wasn’t seeing the music on the drive. Most times, however, it doesn’t even show USB in the list (just NAS and WEBRADIO)

If it makes any difference, I’m running through the native audio out (I know… HiFiBerry on order…), with the RPI connected to the network via ethernet cable (via Powerline), the NAS is connected via wiFi, and there are no other peripherals plugged in.

UPDATE: Well, after playing with this for a little while and getting nowhere, I just left the USB stick plugged in, selected some music from my NAS drive to play and went off to do other things. Coming back to it maybe a couple of hours later, I used the Volumio GUI to browse to top level and USB had appeared. Drilling down, all my music on the USB stick had appeared too. And it played!

So maybe the answer is patience? Maybe there’s a background task that kicks in not very often to mount the USB properly? But then I’m not sure why a database refresh or reboot didn’t mount it properly. Will see how I get on and whether the USB stick remains in the list…

I had that too, took a few hours before it was recognised. And that is not very handy if a friend come by with some music he wants to hear on my system… “please come back tomorrow, but leave your USB plugged in” :wink:

if you want the database update to fly, at a small cost…change the plugin ffmpeg to no for enabled and restart mpd.

Since I only have/use FLAC, I dont need that plugin. But that was what was hanging me up…you can even see it if you tail the mpd.log