Usb drive disappeared

I am new to Volumio, I am using it since 5 days and it looks and (was) working great. I bought new RPI 4 with 1GB RAM and HiFiBerry Digi card. I connected 2.5" external USB HDD to it, installed Volumio 2.599 and 5 days ago it worked flawlessly. Until today. In the morning I started RPI and entered volumio.local on my smartphone and I couldn’t find my music on USB HDD Drive. There was nothing in the [Browse] > [Music Library] subpage… So I started to study things. First, as I consider my self intermediate experienced Linux user, I logged in with SSH. I found my drive intact, mounted on /media/Touro (its Hitachi). I could browser its folders and view files… Nothing bad happen to data. So I started to click options in Settings > My Music. There are only two buttons Update and Rescan which display the Ajax Loader and in the middle of the process Volumio plays sound similar to one which one can here on train stations… and nothing happens, no drive with music in Browse subpage. Then I fought I will try to change mounting options using SSH. I tried to umount and mount HDD but it didn’t help either. I searched (googled) for phrases like “volumio usb drive” just to find out some posts on this forum without any depth help. The problem I got seems to be shared by others. Because I want to use USB Drive as a music source, I am stuck without solution. What is the way I should debug this problem? Where I can start to look for the solution. It is strange that drive worked fine for few days and rapidly just stopped to show up in web interface. Please help,

Best regards


have you checked the power supply?
Does the USB HDD work flawlessly on another computer?


Hi Pirx,
Thank you for your reply,

You are right, the power supply can be the culprit, it’s common micro USB charger with 3 Amps current. It seems it works ok, the Raspberry Pi SBC is stable for the whole day. And when the USB Drive is connected I can perform copying (while connected via SSH) which I believe is more power consuming than just occasional reads when playing FLAC or MP3.

I have four external USB Hard Drives, all are 2.5", three are Hitachi’s Touro and one is WD’s My Passport. All work flawlessly with Dell Inspiron laptop, and Mi Box Android TV.

I wasted whole day yesterday to figure out the problem, and decided to change the software. I installed Moode Audio and I will see what it will bring in the coming week.

The Raspberry Pi 4 is so new, most of the well estabilished software players is not converted yet to the latest architecture (eg I tried to boot PiCorePlayer but it just hangs on boot). I am sure that time will bring more diversity to such software releases.
Thanks again for the reply.

After 5 days of using MoodeAudio on daily basis I can say the issue with my USB hard drive disappearing was definitely related to Volumio. That never happen while using Moode. Sorry but I still don’t know why that problem occurred. I don’t know when I will have a chance to try again Volumio, but for sure I will be tracking changlogs of it and Moode and other headless players to jump on the best solution. Now I am looking into DFF files, why they don’t play using my setup. But I’m sure its not this forum to post about it.


Same issue happens to me, unfortunately, so this is replicable I guess.

Raspberry Pi 4 (4GB version in my case), external HDD powered through Pi.
All files are accessible via SSH and SMB, but Volumio UI doesn’t see the drive after a couple reboots from initial setup.
As an added ‘bonus’ webradio wouldn’t play either since then, pointing to some internal Volumio issue. Only Spotify connect works (and perhaps other added renderers, but I haven’t tested UPnP or AirPlay).

Rebuilding library only does produce the ‘startup sound’ as OP mentioned.

At first I thought is was because of my tinkering - adding extra packages etc., but this happens on clean Volumio image as well.

I also moved to Moode audio for the time being - with an upshot of:

  • no issues with SMB mounts being write-protected with my exFAT drive
  • being based off Buster, giving me more freedom for added functionality on top.

That being said I like Volumio’s UI and functionality (esp. with plugins and webradio discovery) a bit better, and would be very happy if my issues with it were resolved, so I’ll definitely be checking out future updates, especially if it moves to Buster.

This is IMHO the explanation:

  • Volumio uses a more performance oriented CPU governor, that raises a little the power consumption.
  • This leaves less room for powering external devices like hard drives.
  • In any case, powering an external hard drive is suggested with a powered USB hub, because the power drain might in the long term corrupt the SD card.

I plan on testing with a powered hub soon (I need one to support the multiple HDDs I want to use for NAS/Backup anyway). It might just as well be the remedy - however, as OP mentioned as well, the drive and files are easily accessible from other access points (SMB share, SSH, even a Plex server running.


I have to admit I am facing the same problem since the update in 2.619, last Saturday, but my HDD is externally powered.
HDD is connected to a powered USB hub, and the hub is connected to my RPi2. The RPi is correctly turned on/off through a piswitch from nanomesher.

I don’t remember what was the previous software revision I had, but I didn’t update it since months (probably the 2.587), as it was working perfectly well.

At first power up since a few hours, the album list is empty, and my USB drive is not seen. At this moment, in the musical library, I can see all possible sources (NAS, USB, and internal) Clicking on USB drive to an empty folder.
I need to shutdown (in this case, the HDD stay powered), and turn it on again for Volumio to start to rebuild the music library.

Any help would be appreciated

I search a bit how to troubleshoot my problem , and here is an extract of dmesg after a first boot

[ 6.060817] hid-generic 0003:0835:8502.0002: hiddev97,hidraw1: USB HID v1.11 Device [Action Star USB HID] on usb-3f980000.usb- [ 8.561449] initramfs: Checking for USB updates [ 8.714207] initramfs: No USB device detected (when incorrect, try adding 'bootdelay=5' to your boot cmdline) [ 9.021825] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck. [ 9.137031] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck. [ 9.688155] EXT4-fs (mmcblk0p3): recovery complete [ 9.693923] EXT4-fs (mmcblk0p3): mounted filesystem with ordered data mode. Opts: (null) [ 9.705123] initramfs: With Option: [ 9.891350] initramfs: VOLUMIO_VERSION="2.619"

And here is the extract of dmesg after a simple reboot from Volumio UI. After the reboot, my HDD is correctly seen.

[ 6.030805] hid-generic 0003:0835:8502.0002: hiddev97,hidraw1: USB HID v1.11 Device [Action Star USB HID] on usb-3f980000.usb- [ 6.332741] usb 1- new high-speed USB device number 8 using dwc_otg [ 6.463836] usb 1- New USB device found, idVendor=0480, idProduct=a006, bcdDevice= 0.01 [ 6.463852] usb 1- New USB device strings: Mfr=1, Product=2, SerialNumber=3 [ 6.463866] usb 1- Product: External USB 3.0 [ 6.463877] usb 1- Manufacturer: Toshiba [ 6.463888] usb 1- SerialNumber: 2012100861525 [ 6.464737] usb-storage 1- USB Mass Storage device detected [ 6.465399] scsi host0: usb-storage 1- [ 8.598174] initramfs: Checking for USB updates [ 8.755594] initramfs: No USB device detected (when incorrect, try adding 'bootdelay=5' to your boot cmdline) [ 9.475587] EXT4-fs (mmcblk0p3): recovery complete [ 9.479727] EXT4-fs (mmcblk0p3): mounted filesystem with ordered data mode. Opts: (null) [ 9.488627] initramfs: With Option: [ 9.651830] initramfs: VOLUMIO_VERSION="2.619"

Does it mean that the shuttingdown with nanomesher piswitch doesn’t happen correctly, and the the HDD has not the time to be properly unmounted ?

At first boot, you did get mmcblk0p1 (Boot partition 1 of SD cart) with dirty bit.
I experienced this a lot of times, this should not affect the USB Disk part.

Since update to 2.6xx, i having the same issue about USB mounting
It can mount sometimes but its seems to take a very long time or maybe it fails while cpu usage is low .

I will not digg that f#ckin@-not-tested-new-sh&t-version : I downgraded my Volumio back to version 2.575 and it runs well on a poor Raspberry PI 1B

I think I put the finger on something :
My HDD, as well as the USB hub are always powered, which drive the HDD to go into sleep mode when the RPi is turned off.

If I unplug and replug the main power, it has for effect to wake up the HDD before i turn the RPi on.
When i proceed like that, the HDD is correctly detected during the boot of Volumio.

I think it would be interesting to downgrade to 2.575 to see if the problem is coming from the newest version of Volumio, but I will not have time to do that before at least two weeks…

Yep the Pi boot process should wake up the hdd.


I’m still stuck with this problem of powered USB HDD not detected during first boot.
Everytime I start the volumio player, I had to perform a restart from Volumio UI for the HDD to be detected. I can live with that, but it’s a bit annoying…

I was not able to downgrade to a 2.5xx version as old volumio version are no more available.

I’m wondering if adding program_usb_timeout=1 in /boot/config.txt could help ?

Anyone can help ?

Hello. I am a new member.
I use version 2.917 and still have same problem as you guys.
Here is advice all Volumio users.
Volumio is a Debian Linux based distribution, therefore, OS is a kind of Debian Linux and operation interface using WEB application is installed to the OS.
I would advise that users log-in with SSH command and try Linux/Debian commands.
Before logging in, enable SSH with Browser (go to http://volumio ip address/DEV).
For Windows user, start-up command window (i.e. CMD.exe) and type
ssh volumio@volumio ip address
user name and password is volumio as default.
Once your log in is successful, then type following command:
$ mount
If you find your USB drive, it is not the OS problem but Volumio WEB GUI application problem.
USB drive may be found as following example:
/dev/sda1 on /media/diskname type fuseblk (rw,nosuid,nodev,noatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks)
After type is file system information and it shows format type (i.e. NTFS, vfat, etc.)

If you do not find your USB drive in the $ mount output, then check power and connection of physical drive(s).
If you find your USB drive in the $ mount output, then try following:

(1) Shutdown Volumio.
(2) Power off Raspberry Pi.
(3) Remove USB drive(s).
(4) Start-up Raspberry Pi / Volumio.
(5) Leave for a while (around 10 minutes).
(6) Log in thru SSH as described above.
(7) Type “$ mount” and hit enter and see that your USB drive is not shown.
(8) Connect one of USB drives.
(9) Type “$ mount” and hit enter and verify that your USB drive is now mounted (it is automatically mounted).
(10) Start-up your browser and connect to your Volumio.
(11) Volumio will automatically begin updating your music collection.

I hope it will help.