Usb DAC stopped working

First off I am really enjoying Volumio on my Pi. Great work

I have a Model B rev1 and I have I have been using a super economical 2704 based DAC ($6 on ebay) for many months with no problems.

Recently I upgraded to a HIfimediy sabre 9023 usb DAC. It was GREAT at first. Nice improvement in sound quality and I really like using hardware mixing to control the volume.

Suddenly today, there is no sound coming out. I have checked and my amp and cables are fine. I tried a fresh install of Volumio and many reboots. No luck. Volumio plays the songs and the timer runs, but no sound is produced from the DAC.

I tried headphones plugged into the DAC and no sound either.

The Pi onboard audio works. If I switch to the 2704 DAC everything is fine. The 9023 Sabre works fine if I plug it into my iMac. I tried a generic powered usb hub on the pi to no improvement.

I am sad and mystified. I have googled that sometimes the USB ports on the pi can short, so it is unplugged and resting now.

So any ideas about what might be going on or what to try next to get my hifimediy usb DAC working with Volumio again?

Any thoughts are greatly appreciated.