USB Behringer UCA202 DAC problem

Hi I have installed Volumio 2 (volumio-2.001-2016-10-15-pi.img) on a RPi 2b
The Audio is an USB Behringer UCA202.

However when I try to select the USB Audio with Output Device=CODEC–>I2S DAC=on–>Generic-I2s-DAC
And restart the RPi, a Hifiberry DAC is selected! (Software Mixer Type and no sound)
Again I selected Output Device=CODEC–>I2S DAC=on–>Generic-I2s-DAC
And restart the RPi, now Output Device=CODEC and DAC Model= Generic I2S DAC is selected,
Mixer Type=Hardware
Mixer Control Name=Digital (Note: I also have PCM as field option but cannot select it nor save it)
But I have Audio…
Hifiberry DAC is also still in output device list.

Now the problem came with installing the VOLSPOTCONNECT plugin from balbuze.
in the " file the --mixer was set to Digital (which is the shown option in the Mixer Control Name field)
But I figured out that it should be --mixer PCM to run spotyfy connect web (The option PCM is also shown in the Mixer Control Name field, but cannot be selected nor saved as i mentioned before)

So it looks like the Spotify Connect Plugin gets problems because the USB Audio device is not installed correctly.
Can somebody figure out how to install the USB Audio Device correctly?



You’re not selecting USB, but I2S (they are 2 different thing).
Disable I2S, reboot.
Then choose your USB soundcard from Output device (you’ll see HDMI, Jack and another one, which is USB)

Aha…so you don’t have to select a I2S profile when you have an External USB Audio device?
Tried CODEC and with I2S=off and it worked…also the VOLSPOTCONNECT plugin!

Thanx man!