I am running the Volumio version 2.411 on ALLO Sparky (USBridge)

I have setup my DLink-315 NAS as a media server.

In Volumio, I can see the ‘Media Serves’ option listed under the ‘Browse’ setting.
Here I am able to see all my windows DLNA shares, but the NAS as DLNA does not appear at all.

However I am able to see the NAS when I add it as a network driver.

Is there a solution to load the DLNA on the NAS under ‘media servers’ in Volumio.

I have just tried adding a media server to my Synology NAS, and it works fine … all picked up nicely in Volumio. So, I guess you’re going to have to have a look at the settings on your NAS … I’m no expert here, but I did notice one option for limiting the devices which were allowed to access the server. Presumably you will have a similar setting for your D-Link. Sorry not to be of more help, but at least you do know now that it works with Volumio “out of the box.”

Thanks for the heads up. Let me check on the NAS.
But the NAS as DLNA appears in all my windows machines and only not in Volumio.


Which NAS model\Server are you using?

I am using DLink DNS-315 running DLink ShareCenter software

Tried everything, but the NAS media server does not show-up.
But is is visible under all windows machines.

Can you please send us logs?
volumio.github.io/docs/User_Man … oting.html