UPnP support in Volumio 2

Hi, I believe I have read that Volumio 2 supports UPnP (as a renderer), however I can’t find the option in the interface? Am I missing something? Thanks.

Just use any upnp sender app and you will see Volumio as a player… As for upnp browsing on Volumio, we’re working on that…

Thank you i also need (loves) UPNP browsing on volumio. On Version 1. 4 it works very well. So im waiting with an update on version 2

Any news on Upnp browsing in Volumio 2?

Hhm. There is a menu point called upnp when browsing music.
But for some reason it is empty, although I have a DLNA - media server on my home network.
What am I doing wrong?

Same here. I upgraded to 2.141 two days ago but Upnp is empty when browsing music even though the Synology NAS is hosting a media server. Is there a description somewhere what exactly the conditions of this function are?
I think a proper support for DLNA media servers is a true enhancement for Volumio, also compared to “competitive” projects. Using CIFS shares does the job but doesn’t look that elegant to me. Since version 2.129 it also prevents my NAS from going to standby even when Volumio is not playing since Volumio is frequently establishing a TCP connection on 445 and closing it right again. Also I see some security concerns in it. The password is visible on the GUI, even after it has been configured, which also means that the password is transmitted unencrypted between Volumio and the client since HTTPS is not used besides the fact that the GUI is not protected from unauthorized access anyway which makes the use of passwords for shares pointless.

I hope there will be further news about this subject! :smiley:

Yes, there are upnp issues and hopefully solved soon for some platforms.
But none of you girls/ guys are mentioning on which platform you are running. Please add that information in a support call, as it it vital,
“PI = not Odroid = not Pine = not Cubic =not Sparky =not” etc. issue

My bad, sorry!

The platform I’m using is:
Raspberry Pi 3B
HifiBerry DAC+ Pro
Volumio 2.141

The remote media server is:
Synology DS213j
DSM 6.1-15047 Update 2

ah, that one should have been ok, the armv7 platforms had an issue.
So perhaps someone else with this configuration has an idea?

Upnp discovery runs over UDP port 1900 (SSDP) and there are two types of messages a device can send to the multicast address, NOTIFY and M-SEARCH. I did some packet capturing and observed the following:

Scenario 1

  • After booting up sends multiple NOTIFY messages to multicast:

No. Time Source Destination Protocol Length Info
1 0.000000 SSDP 476 NOTIFY * HTTP/1.1
2 0.000060 SSDP 485 NOTIFY * HTTP/1.1
23 0.104215 SSDP 522 NOTIFY * HTTP/1.1
24 0.104391 SSDP 516 NOTIFY * HTTP/1.1

  • During later up time no further NOTIFY messages were captured.
  • Browsing “Upnp” at “Browse” tab of Volumio GUI doesn’t take any effect on SSDP communication.


  • Frequently sends multiple NOTIFY messages frequently with pauses of 15 minutes.


  • Volumio doesn’t detect NAS at “Upnp” option.

I then shortened the interval of the NOTIFY messages at the NAS to 10 seconds, the result though remained the same.

As a comparison I captured the SSDP communication between my smartphone and the NAS when the smartphone’s music player tries to find media servers:

Scenario 2

  • When opening the music player the smartphone ( sends M-SEARCH messages to multicast:

No. Time Source Destination Protocol Length Info
1 0.000000 SSDP 229 M-SEARCH * HTTP/1.1
2 0.084982 SSDP 229 M-SEARCH * HTTP/1.1
3 0.356858 SSDP 229 M-SEARCH * HTTP/1.1
4 1.255967 SSDP 196 M-SEARCH * HTTP/1.1


  • After receiving the above M-SEARCH messages the NAS ( sends a reply:

No. Time Source Destination Protocol Length Info
5 1.256200 SSDP 385 HTTP/1.1 200 OK


  • Discovery complete, NAS media server was detected.

How is the Upnp discovery set up in Volumio? Even if this might not be the actual problem’s reason my current conlusion is that Volumio only relies on SSDP NOTIFY messages of the corresponding media servers. Wouldn’t it be more convenient and less depending on the media server’s sending interval if Volumio would send M-SEARCH messages for “active” detection when the user browses “Upnp” at the Volumio GUI?

I now restaged the RPI freshly with 2.141 and the Upnp option now is not visible anymore. :confused:


Same problem here :
My System =
Raspberry Pi 3B
HifiBerry DAC+
Volumio 2.141
Synology DS415+
DSM 6.1-15047 Update 2

Also Using BubbleUPNP to stream Tidal Hifi


Hey there,

with 1.5 I was able to get Tidal via BubbleUPnP to my Odroid C0.
I followed this instructions

hifizine.com/2016/06/how-to- … pberry-pi/

Now with the latest Volumio version, if I follow the steps it’s not possible to set up media server or renderer in BubbleUPnP Server

Man and I hoped to shorten the waiting for the Tidal plug in…


Just to make sure I am asking again.

Should it be possible to use BUBBLEUPNP with Volumio 2.129 on Odroid C0?

Like I said I can’t set up the BubbleUPnP Server, there is nothing to select.

I suspect I fu**ed up my Router settings… once again

So if anyone knows if the described setup should work, please let me know.



I am running Volumio 2.246 on a Pi3. In the same Network, there is a Synology NAS with a DLNA Server. While mounting the file system on the NAS works fine, I do not see any Kind of “Option” to browse the DLNA Server. From the recent Posts I could not get a clear answer on the following:

Is DLNA browsing actually implemented?
Where in the UI can I select and browse my DLNA Server?
Currently I am not able to see my DLNA Server anywhere, just the mounted Samba share.

Any help appreciated.

Currently Volumio seems to only be a renderer. To enable server functions, install minidlna:
(for which apparently a plugin is coming).

But see here:
where it is said that some day DLNA browsing will be supported, but who knows when.


Thanks for the reply. What confuses me is that earlier in this Thread Zhapox tells us about a Upnp option in the Browse tab (I have not seen that option yet) that disappeared in a later version of Volumio. I want Volumio as a renderer/player, not as a dlna Server.

It is still not clear to me whether browsing and playing from a dlna server is an implemented feature (with certain issues) or is still to be implemented.

Some reply from the development team would be appreciated.