UPnP, Control Point and Queue Issues

Long time user… recently moved from version 2.x to the latest release (Raspberry Pi 4B) after a lot of “if it ain’t broke don’t fix it” hedging.

Brief summary of my use case: use Volumio almost exclusively as a UPnP renderer; Asset UPnP back end. Control point is Linn Kazoo on Android. All worked well enough until the update.

Now, with the latest iteration installed, Linn Kazoo can send music to the queue or delete the queue completely but the queue itself cannot be seen in the app (and thus individual entries cannot be manipulated since they are, for all intents and purposes, invisible). This echoes the behavior of the Volumio app itself which no longer seems to see the playing queue normally in this situation.

Tried a clean install of the latest Volumio: no change in behavior. Wrote a new card using Volumio 2.9x, everything worked again which strongly suggests the problem is caused by version 3.x (although the Volumio interface itself will not see the playing queue unless the UPnP server is accessed directly rather than via the control point).

Kind of at my wit’s end on this one, but it almost seems like it could be a permissions issue… anyone have any ideas?