I’ve searched for this topic but found nothing that helped, so posting a new topic.

On any of the Windows computers on our network, we can see Volumio listed as a Media Device. But whenever anyone double-clicks that, they get a blank webpage.

[(local](http://(local) ip):49152/upmpd/presentation.html

Is this normal?
What should be appearing?
Is there a fix?

Thanks in advance for any help.

In case it helps:
System version = 2.118
Release date = Mar 7, 2017

I can see from this post at Axiom that the page is meant to be a UPnP front-end to MPD.

It must be being enabled somewhere in Volumio, as part of MPD, but where?

Still no idea why it is blank though. Any clues?

If you double click on it, it should bring you directly to Volumio’s UI


It doesn’t.

The code source page is :

    <meta http-equiv="refresh" content="1;URL=http://[object Object]/">

[object Object] is not interpreted.


Well, yes, I guess it should, but as llevet has already said, the HTML looks wrong.

Not a solution, but an observation … it works for me, so it is not a general failure in Volumio. I tried on both Windows 7 & 10, and so it looks to have it’s origin in your specific Windows setup.

Err, how can that be true? The HTML is first created on the Raspberry Pi running Volumio, isn’t it?

If someone would kindly tell me what to look for in the Volumio config, and how to access it, I would happily do that.


Perhaps I need to phrase the question differently.
Let’s try it this way:

Why does Volumio publish this page?

Yes, what you’re looking for is here:
github.com/volumio/Volumio2/blo … p/index.js