Upgraded today - Volumio totally broken

Decided to upgrade Volumio through GUI today. The upgrade seems completely broken.
The Pi does not get an ip-address.
Hate when I have to reflash and set up from scratch! :imp:
Version 2.599 on Pi3

Reflashed 2.599 and it seems to work. Beware of upgrading OTA with this version at least if you have an pi3!

Same happened to me.

Same here

sometimes it gets to the point of acquiring IP address and then freezes
sometimes it does boot but becomes unresponsive
so no debug possible

will see if it’s better after a reflash
and I had my pydPiper finally running the way I wanted it :frowning:

Mine loads, but won’t play. 3 different Pis - I think two 3B+ and one 3B. 3 different DACs. At first it played from networked HDD, but did not play most webradios but did play Radio Swiss Jazz. Now, after several reboots, it won’t play radio or anything else. It says it’s beginning to play, but the play button doesn’t change to pause and no sound. Things are added to the queue though.

Well, mine seems to be working now. Not sure what’s different. Let it sit over night. Several more reboots. I did an unplug-reboot on one of the Pis. Now everything seems to be ok.

That’s too bad and a bit strange. Mine has worked perfectly after the reflash. Streaming music from a cifs drive and webradio works well.

Sent from my iPhone using Tapatalk

I also have a problem with the upgrade. The home-webpage is just white. Or empty.

After the upgrade the machine rebooted. It has the usual ip-address (I use a static ip-address) on the ethernet-interface. The wlan-interface is disabled (as intented). I can ssh to the pi, so I can look around and debug if you want. (I know a little Unix, I’m a c-programmer, I know networking very well, I used to be a sysadmin (more than 2 decades ago)). Just tell me what to look at.

I can connect (telnet) to port 80, so there is something running. It just gives me a white page. In the titlebar of the browser-window, I see “Volumio - Audiophile Music Player”. So the webserver is giving me some data. Happens both with Firefox as well as Palemoon (a Firefox derivative) as well as MS’s Internet Explorer.

When I use wget to see what happens, I get this.
I’m not a html/web expert, so maybe someone else can look at this:

$ wget

<!doctype html><html ng-app="volumio"><head><meta charset="utf-8"><title>Volumio - Audiophile Music Player</title><meta name="description" content=""><base href="/"><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no"><link rel="shortcut icon" type="image/png" ng-href="{{favicon}}"><link rel="manifest" ng-href="{{variantAssetsUrl}}/manifest.json"><link rel="apple-touch-icon" sizes="57x57" ng-href="{{touchIconsUrl}}/apple-touch-icon-57x57.png"><link rel="apple-touch-icon" sizes="60x60" ng-href="{{touchIconsUrl}}/apple-touch-icon-60x60.png"><link rel="apple-touch-icon" sizes="72x72" ng-href="{{touchIconsUrl}}/apple-touch-icon-72x72.png"><link rel="apple-touch-icon" sizes="76x76" ng-href="{{touchIconsUrl}}/apple-touch-icon-76x76.png"><link rel="apple-touch-icon" sizes="114x114" ng-href="{{touchIconsUrl}}/apple-touch-icon-114x114.png"><link rel="apple-touch-icon" sizes="120x120" ng-href="{{touchIconsUrl}}/apple-touch-icon-120x120.png"><link rel="apple-touch-icon" sizes="144x144" ng-href="{{touchIconsUrl}}/apple-touch-icon-144x144.png"><link rel="apple-touch-icon" sizes="152x152" ng-href="{{touchIconsUrl}}/apple-touch-icon-152x152.png"><link rel="apple-touch-icon" sizes="180x180" ng-href="{{touchIconsUrl}}/apple-touch-icon-180x180.png"><link rel="icon" type="image/png" ng-href="{{touchIconsUrl}}/android-chrome-192x192.png" sizes="192x192"><link rel="mask-icon" ng-href="{{touchIconsUrl}}/safari-pinned-tab.svg" color="#5bbad5"><link rel="apple-touch-startup-image" ng-href="{{touchIconsUrl}}/apple-touch-icon-180x180.png"><meta name="msapplication-TileColor" content="#4bbe87"><meta name="msapplication-navbutton-color" content="black"><meta name="msapplication-TileImage" content="{{touchIconsUrl}}/mstile-144x144.png"><meta name="msapplication-config" content="{{touchIconsUrl}}/browserconfig.xml"><meta name="apple-mobile-web-app-title" content="Volumio"><meta name="theme-color" content="black"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="apple-mobile-web-app-status-bar-style" content="black"><link rel="stylesheet" href="styles/vendor-aa5c8b9861.css"><link rel="stylesheet" href="styles/app-df4e8101b1.css"></head><body><!--[if lt IE 10]>
 <p class="browsehappy">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> to improve your experience.</p>
 <![endif]--><div ui-view="layout"></div><div id="cssExposer"></div><script src="scripts/vendor-089433e0c9.js"></script><script src="scripts/app-84d1bf3661.js"></script><script>
    window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
    ga('create', 'UA-92970181-1', 'auto');
    ga('send', 'pageview');
    ga('set', 'anonymizeIp', true);
    </script><script async="" src="https://www.google-analytics.com/analytics.js"></script></body></html>

Anything else I can do to troubleshoot ?

The weird thing is: I got another pi with volumio (in my bedroom). I had that upgraded to 2.599 weeks ago (I actually can’t remember when). No problems. Today I tried to upgrade the pi in my livingroom, and the upgrade failed. The differences: the failed pi uses ethernet, and has pihole installed. The successfully upgraded pi uses wlan, and does not have pihole installed. For the rest the systems are the same (dmesg says: Machine model: Raspberry Pi 3 Model B Plus Rev 1.3).

Do you want to see the /var/log/volumio.log ?
Here it is anyway:

2019-08-19T22:35:47.663Z - info: -------------------------------------------
2019-08-19T22:35:47.666Z - info: -----            Volumio2              ----
2019-08-19T22:35:47.666Z - info: -------------------------------------------
2019-08-19T22:35:47.667Z - info: -----          System startup          ----
2019-08-19T22:35:47.667Z - info: -------------------------------------------
2019-08-19T22:35:47.759Z - info: MYVOLUMIO Environment detected
2019-08-19T22:35:47.893Z - info: Plugin folders cleanup
2019-08-19T22:35:47.894Z - info: Scanning into folder /volumio/app/plugins/
2019-08-19T22:35:47.894Z - info: Scanning category audio_interface
2019-08-19T22:35:47.895Z - info: Scanning category miscellanea
2019-08-19T22:35:47.896Z - info: Scanning category music_service
2019-08-19T22:35:47.897Z - info: Scanning category plugins.json
2019-08-19T22:35:47.897Z - info: Scanning category system_controller
2019-08-19T22:35:47.898Z - info: Scanning category user_interface
2019-08-19T22:35:47.899Z - info: Scanning into folder /data/plugins/
2019-08-19T22:35:47.900Z - info: Plugin folders cleanup completed
2019-08-19T22:35:47.901Z - info: -------------------------------------------
2019-08-19T22:35:47.902Z - info: -----      Core plugins startup        ----
2019-08-19T22:35:47.902Z - info: -------------------------------------------
2019-08-19T22:35:47.903Z - info: Loading plugins from folder /volumio/app/plugins/
2019-08-19T22:35:47.906Z - info: Adding plugin upnp to MyMusic Plugins
2019-08-19T22:35:47.908Z - info: Adding plugin airplay_emulation to MyMusic Plugins
2019-08-19T22:35:47.909Z - info: Adding plugin upnp_browser to MyMusic Plugins
2019-08-19T22:35:47.912Z - info: Loading plugins from folder /data/plugins/
2019-08-19T22:35:47.914Z - info: Loading plugin "system"...
2019-08-19T22:35:47.940Z - info: Loading plugin "appearance"...
2019-08-19T22:35:49.231Z - info: Loading plugin "network"...
2019-08-19T22:35:49.691Z - info: Loading plugin "services"...
2019-08-19T22:35:49.696Z - info: Loading plugin "alsa_controller"...
2019-08-19T22:35:49.807Z - info: Loading plugin "wizard"...
2019-08-19T22:35:49.822Z - info: Loading plugin "volumio_command_line_client"...
2019-08-19T22:35:49.829Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam
2019-08-19T22:35:49.830Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam
2019-08-19T22:35:49.831Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam
2019-08-19T22:35:49.831Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam
2019-08-19T22:35:49.860Z - info: Loading plugin "upnp"...
2019-08-19T22:35:49.867Z - info: [1566254149867] Starting Upmpd Daemon
2019-08-19T22:35:49.869Z - info: CoreCommandRouter::executeOnPlugin: system , registerCallback
2019-08-19T22:35:49.871Z - info: Loading plugin "my_music"...
2019-08-19T22:35:49.881Z - info: Loading plugin "mpd"...
2019-08-19T22:35:50.358Z - info: Loading plugin "upnp_browser"...
2019-08-19T22:35:51.446Z - info: Loading plugin "networkfs"...
2019-08-19T22:35:51.669Z - info: CoreCommandRouter::executeOnPlugin: system , registerCallback
2019-08-19T22:35:51.670Z - info: Loading plugin "alarm-clock"...
2019-08-19T22:35:51.910Z - info: Loading plugin "airplay_emulation"...
2019-08-19T22:35:51.944Z - info: Starting Shairport Sync
2019-08-19T22:35:51.946Z - info: Loading plugin "last_100"...
2019-08-19T22:35:51.954Z - info: Loading plugin "webradio"...
2019-08-19T22:35:52.085Z - info: Loading plugin "i2s_dacs"...
2019-08-19T22:35:52.098Z - info: I2S DAC not set, start Auto-detection
2019-08-19T22:35:52.114Z - info: Loading plugin "volumiodiscovery"...
2019-08-19T22:35:52.180Z - info: Applying required configuration parameters for plugin volumiodiscovery
2019-08-19T22:35:52.210Z - info: CoreCommandRouter::executeOnPlugin: system , registerCallback
2019-08-19T22:35:52.211Z - info: Loading plugin "outputs"...
2019-08-19T22:35:52.219Z - info: Loading plugin "albumart"...
2019-08-19T22:35:52.242Z - info: Plugin example_plugin is not enabled
2019-08-19T22:35:52.243Z - info: Loading plugin "inputs"...
2019-08-19T22:35:52.253Z - info: Loading plugin "updater_comm"...
2019-08-19T22:35:52.465Z - info: Plugin mpdemulation is not enabled
2019-08-19T22:35:52.466Z - info: Loading plugin "rest_api"...
2019-08-19T22:35:52.502Z - info: Loading plugin "websocket"...
2019-08-19T22:35:52.529Z - info: ___________ START PLUGINS ___________
2019-08-19T22:35:52.534Z - info: CoreCommandRouter::executeOnPlugin: mpd , getConfigParam
2019-08-19T22:35:52.536Z - info: CoreCommandRouter::volumioAddToBrowseSources[object Object]
2019-08-19T22:35:52.536Z - info: [1566254152536] CoreMusicLibrary::Adding element Media Servers
2019-08-19T22:35:52.538Z - info: CoreCommandRouter::executeOnPlugin: my_music , getDisabledSources
2019-08-19T22:35:52.591Z - info: Could not detect Primo: Error: Command failed: aplay -l | grep es90x8q2m-dac-dai-0
2019-08-19T22:35:52.624Z - info: Could not detect Primo: Error: Command failed: aplay -l | grep es90x8q2m-dac-dai-0
2019-08-19T22:35:52.626Z - info: CoreCommandRouter::volumioAddToBrowseSources[object Object]
2019-08-19T22:35:52.627Z - info: [1566254152626] CoreMusicLibrary::Adding element Last_100
2019-08-19T22:35:52.628Z - info: CoreCommandRouter::executeOnPlugin: my_music , getDisabledSources
2019-08-19T22:35:52.631Z - info: CoreCommandRouter::volumioAddToBrowseSources[object Object]
2019-08-19T22:35:52.631Z - info: [1566254152631] CoreMusicLibrary::Adding element Webradio
2019-08-19T22:35:52.632Z - info: CoreCommandRouter::executeOnPlugin: my_music , getDisabledSources
2019-08-19T22:35:52.636Z - info: CoreCommandRouter::executeOnPlugin: system , getSystemVersion
2019-08-19T22:35:52.646Z - info: -------------------------------------------
2019-08-19T22:35:52.646Z - info: -----    MyVolumio plugins startup     ----
2019-08-19T22:35:52.647Z - info: -------------------------------------------
2019-08-19T22:35:52.648Z - info: Loading plugins from folder /myvolumio/plugins
2019-08-19T22:35:52.670Z - info: Loading plugins from folder /data/myvolumio/plugins
2019-08-19T22:35:52.672Z - info: Loading plugin "cd_controller"...
2019-08-19T22:35:52.710Z - info: Loading plugin "streaming_services"...
2019-08-19T22:35:53.108Z - info: Loading plugin "my_volumio"...
2019-08-19T22:35:53.918Z - info: Adding CD REST API Endpoints
2019-08-19T22:35:53.920Z - info: Adding detectCD REST Endpoint for plugin: music_service/cd_controller
2019-08-19T22:35:53.920Z - info: Adding cdRemove REST Endpoint for plugin: music_service/cd_controller
2019-08-19T22:35:53.921Z - info: Adding cdPostScan REST Endpoint for plugin: music_service/cd_controller
2019-08-19T22:35:53.921Z - info: Adding cdPostRip REST Endpoint for plugin: music_service/cd_controller
2019-08-19T22:35:53.922Z - info: Detecting CD presence
2019-08-19T22:35:53.924Z - info: Streaming services startup
2019-08-19T22:35:53.929Z - info: Starting Streaming Daemon
2019-08-19T22:35:53.942Z - info: CoreCommandRouter::executeOnPlugin: system , getConfigParam
2019-08-19T22:35:53.943Z - info: CoreCommandRouter::executeOnPlugin: system , getConfigParam
2019-08-19T22:35:53.945Z - info: Starting MyVolumio Remote Streaming Endpoints
2019-08-19T22:35:53.988Z - info: Loading i18n strings for locale en
2019-08-19T22:35:53.996Z - info: CoreCommandRouter::executeOnPlugin: my_music , getDisabledSources
2019-08-19T22:35:54.027Z - info: CoreCommandRouter::executeOnPlugin: mpd , getConfigParam
2019-08-19T22:35:54.029Z - info: CoreCommandRouter::initPlayerControls
2019-08-19T22:35:54.039Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam
2019-08-19T22:35:54.039Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getAlsaCards
2019-08-19T22:35:54.065Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam
2019-08-19T22:35:54.066Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam
2019-08-19T22:35:54.066Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam
2019-08-19T22:35:54.067Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam
2019-08-19T22:35:54.067Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , getConfigParam
2019-08-19T22:35:54.077Z - info: CoreCommandRouter::executeOnPlugin: mpd , getConfigParam
2019-08-19T22:35:54.082Z - info: BOOT COMPLETED
2019-08-19T22:35:54.083Z - info: CoreCommandRouter::executeOnPlugin: system , getConfigParam
2019-08-19T22:35:59.842Z - info: CoreCommandRouter::Close All Modals sent
2019-08-19T22:35:59.843Z - info: CoreCommandRouter::Close All Modals sent
2019-08-19T22:35:59.922Z - info: MyVolumio not started
2019-08-19T22:35:59.923Z - info: Initializing device activation check
2019-08-19T22:35:59.926Z - info: CoreStateMachine::resetVolumioState
2019-08-19T22:35:59.926Z - info: CoreStateMachine::getcurrentVolume
2019-08-19T22:35:59.927Z - info: CoreCommandRouter::volumioRetrievevolume
2019-08-19T22:36:00.382Z - info: Volumio called home
2019-08-19T22:36:00.387Z - info: Setting Device type: Raspberry PI
2019-08-19T22:36:00.407Z - info: MPD running with PID651 ,establishing connection
2019-08-19T22:36:00.544Z - info: VolumeController:: Volume=68 Mute =false
2019-08-19T22:36:00.546Z - info: CoreStateMachine::pushState
2019-08-19T22:36:00.548Z - info: CoreStateMachine::getState
2019-08-19T22:36:00.549Z - info: CorePlayQueue::getTrack 0
2019-08-19T22:36:00.550Z - info: CoreCommandRouter::volumioPushState
2019-08-19T22:36:00.550Z - info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , saveDeviceInfo
2019-08-19T22:36:00.587Z - info:
---------------------------- Client requests Volume 70
2019-08-19T22:36:00.590Z - info: VolumeController::SetAlsaVolume70
2019-08-19T22:36:00.602Z - info: CoreStateMachine::pushState
2019-08-19T22:36:00.603Z - info: CoreStateMachine::getState
2019-08-19T22:36:00.603Z - info: CorePlayQueue::getTrack 0
2019-08-19T22:36:00.604Z - info: CoreCommandRouter::volumioPushState
2019-08-19T22:36:00.604Z - info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , saveDeviceInfo
2019-08-19T22:36:00.727Z - info: CoreCommandRouter::executeOnPlugin: system , getConfigParam
2019-08-19T22:36:00.741Z - info: Reloading queue from file
2019-08-19T22:36:00.761Z - info:
2019-08-19T22:36:00.768Z - info:  message= [50@0] {} No such directory, stack=Error:  [50@0] {} No such directory
    at MpdClient.receive (/volumio/app/plugins/music_service/mpd/lib/mpd.js:63:14)
    at Socket.<anonymous> (/volumio/app/plugins/music_service/mpd/lib/mpd.js:43:10)
    at emitOne (events.js:116:13)
    at Socket.emit (events.js:211:7)
    at addChunk (_stream_readable.js:263:12)
    at readableAddChunk (_stream_readable.js:246:13)
    at Socket.Readable.push (_stream_readable.js:208:10)
    at Pipe.onread (net.js:607:20)
2019-08-19T22:36:00.841Z - info: Setting volume on startup at 70
2019-08-19T22:36:00.846Z - info: CoreStateMachine::setRepeat false single undefined
2019-08-19T22:36:00.846Z - info: CoreStateMachine::pushState
2019-08-19T22:36:00.847Z - info: CoreStateMachine::getState
2019-08-19T22:36:00.847Z - info: CorePlayQueue::getTrack 0
2019-08-19T22:36:00.848Z - info: CoreCommandRouter::volumioPushState
2019-08-19T22:36:00.848Z - info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , saveDeviceInfo
2019-08-19T22:36:00.852Z - info: CoreStateMachine::setRandom false
2019-08-19T22:36:00.852Z - info: CoreStateMachine::pushState
2019-08-19T22:36:00.852Z - info: CoreStateMachine::getState
2019-08-19T22:36:00.853Z - info: CorePlayQueue::getTrack 0
2019-08-19T22:36:00.853Z - info: CoreCommandRouter::volumioPushState
2019-08-19T22:36:00.854Z - info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , saveDeviceInfo
2019-08-19T22:36:00.897Z - info: CoreCommandRouter::executeOnPlugin: alsa_controller , checkAudioDeviceAvailable
2019-08-19T22:36:00.920Z - info: CoreCommandRouter::executeOnPlugin: system , versionChangeDetect
2019-08-19T22:36:01.034Z - info: mDNS: Found device droopy
2019-08-19T22:36:01.154Z - info: mDNS: Found device sleepy
2019-08-19T22:36:01.191Z - info: Shairport-Sync Started
2019-08-19T22:36:01.196Z - info: Upmpdcli Daemon Started
2019-08-19T22:36:01.197Z - info: Shairport-Sync Started
2019-08-19T22:36:01.260Z - info: CoreCommandRouter::volumioGetState
2019-08-19T22:36:01.261Z - info: CoreStateMachine::getState
2019-08-19T22:36:01.262Z - info: CorePlayQueue::getTrack 0
2019-08-19T22:36:06.716Z - info: Fetching Streaming Services browse cache
2019-08-19T22:36:06.740Z - info: CoreCommandRouter::volumioRemoveToBrowseSourcesTIDAL
2019-08-19T22:36:06.742Z - info: CoreCommandRouter::executeOnPlugin: my_music , getDisabledSources
2019-08-19T22:36:06.823Z - info: CoreCommandRouter::volumioRemoveToBrowseSourcesQOBUZ
2019-08-19T22:36:06.823Z - info: CoreCommandRouter::executeOnPlugin: my_music , getDisabledSources
2019-08-19T22:36:22.664Z - info: CoreCommandRouter::executeOnPlugin: system , getSystemVersion
2019-08-19T22:36:22.665Z - info: CoreCommandRouter::executeOnPlugin: system , getConfigParam

Another data-point. I had never used the “multiroom devices” feature before.
On my 2nd pi, I noticed that, in the “multiroom devices” window, I could still see the last song that my 1st pi was playing while/during the upgrade. Maybe that has something to do with it ? I had my pi playing while upgrading, and even while rebooting ? Anyway, I see that song on my 2nd pi. I click on it. I get the song in the “playback” tab. I click play. My 1st pi starts playing the song !! On the web-page of my 2nd pi, I can now browse through my songs, and play songs on my 1st pi ! If I try to access my 1st pi directly, it doesn’t work.

Conclusion: on my 1st pi (the broken one), networking works fine, playback works fine, it’s just the web-interface that is broken. Weird. Any ideas ?

I will keep my broken pi in this state for 1-2 days. So I can gather any info you guys wanna see. Just let me know.