Updating To Volumio 3 Has Caused no end of trouble

Even after flashing my SD card with Volumio 3 the raspberry Pi will not start up. No idea what to do now. Everything worked perfectly with Volumio 2 but after upgrading to Volumio 3 the Raspberry Pi appears to be dead. I have now flashed my SD card 3 times on a separate computer with Volumio 3 using Balena Etcher but still does not work. Any ideas please???

how you have verified your rasberry is not booting?

1 Like

The Rasp Pi does not show up in any IP searches on my network when powered up.

1 Like

if its not connected via ethernet cable, you need connect to the “volumio-xxxxx” hotspot it makes and setup wireless network again.


Yes, Connected to rasp Pi with ethernet cable to my laptop. But no IP address given with this method.

What is “volumio-xxxx” hotspot. What are you talking about? Wireless??


Its wireless network that your rasbperry will create, if network cables is not plugged in.


So I downloaded Volumio App to my android phone. Ran it and the Rasp Pi cannot be found when searching for Volumio.

Also a wireless search of available networks from my phone does not show Volumio-xxxx.

1 Like

I have now flashed my SD card 3 times with Volumio 3. Its as if the flashing or the Volumio program itself is corrupt.


If you reflashed you SD, please connect a monitor (TV) to it and look if it will reach to the login prompt.
Had similar issues with an old rpi-3B. It was connected to the copper network, but didn’t get an IP assigned. Luckily the hotspot did show up and was able to se the IP manually.
The rPi will most likely not show on an IP scanner as the subnet is not accessible due to the Network mask ( of the scanner that you’re using.

1 Like

i dont have a micro hdmi to hdmi cable. Volumio should start up right? What do you mean by prompt?Volumio 2 never had a prompt.

Volumio boots in console mode, so after the boot it will show the console.
Normally you’ll get a WiFi connection visible called volumio-xxxxx. If you connect to it, it will port you to volumio.local.


What is the console mode? I dont understand. As I said previously. Volumio-xxxx does not show up on my wifi connections on my phone. Should be a clue that Volumio is not starting.

1 Like

See it as the cmd shell in windows, but then the Linux version of it. Same as you open putty to SSH to the pi.

It takes some time before everyhing is set on first boot. Try to look for it using a computer with a wireless connection.

Are you using an rPi3 or rPi4?

You need to unzip the image after downloading it.

Yes, of course. I unzipped the image from Volumio. Balena Etcher wouldn’t work in the unzipped state.

I never had this trouble installing Volumio 2. Update was done on the fly from Volumio 1 update in its own software.

I’m using a rasp Pi 4. I’ll have to get a Micro HDMI port to HDMI adaptor. I want to avoid getting a converter though. So how do I set up remotely from a laptop (and ethernet cable I presume) given I cannot even get an IP address for the Rasp Pi?

Any help would be appreciated.


If you check the SD card with volumio on a pc, does it have 3 partitions, including one called boot?

If so, the os is there at least. If not, maybe try using the raspberrypi tool to select your unzipped image to reflash your card.

After boot, do you see the green led working?

Try power off and on a couple of times and keep checking on your phone for a new ssid with volumio in the name. It can take a couple of minutes to get there.

Other than that I’m out of ideas.

1 Like

Connect the Pi to your router using a Ethernet cable, reboot the router, and then log into the admin page of the router and see if the router assigned an IP address to the PI

1 Like

Volumio SD card details. No I cannot see 3 partitions. See the screenshot of highest level on SD card.

Try a different SD card. I was was having tons of issues with Volumio but they all went away went I bought a different SD card.

The SD card worked perfectly for Volumio 2.

Is the source code shown on the screenshot Brian? How can I tell if there are 3 partitions on the SD card?

1 Like