Updating from v3.251 to v3.512

I’m running Volumio v3.251 on a raspberry pi zero w. I control it entirely through the web interface. Normally with my tablet or cell phone. I works perfectly in that it does everything I want it to.
When I check for updates I’m told that v3.521 is the lastest version so I hit the update button. The system then spends a while self checking downloading an installing the update, then restarts. When I check which version I’m running, low and behold it’s v3.251. I can’t see where I’m going wrong but I obviously am.
Someone suggested stopping any plugins I run, restarting the system, then trying to update. It didn’t work.
Does anyone have any suggestions?
----------------------------- Delete here & above before posting below -----------------

1 Like

maybe you just have to refresh your browser [F5] ?

Do you mean 3.512? That’s the latest version.

Yes I do, apologies.

I mainly use the android app,but I’ve tried with my laptop (Linux) as well. I would have thought restarting the raspberry pi would refresh the browser.

Updated the topic with the correct version.