Update Allo Usbridge to 2.878 for tidal connect

Volumio Information

Volumio Version: 2.873
Hardware: allo usbridge
DAC: Gustard X16

Just says I have the latest version, even with test mode

Disable test mode and you should see it.
Unless this is a a special version made from allo that prevents updating… Let us know

No luck, I have updated OTA before to 2.873.

1 Like

Are you sure you disabled test mode?
Other thing you can try is factory reset then update

Did a factory reset as advised, but still no update. Is there an image available so I can put it on the sd card?

Yes, from the download page.

Just for information: this SD Card and software, did come from Allo or did you flash it before?

On the download page there are links for Raspberry pi, pc (x86/x64) and asus tinkerboard.
None for allo usbridge. can you give me the url for the download please.

I did download and flash before, sorry forgot to answer the question!

I found an image for 2.873 in the community posts and used that in the hope it would update, but still no luck. Any suggestions welcome!