Unable to set up wifi v2.141

Hi all,
I’m a new user.
I installed Volumio v2.141 onto a newly formatted sd card in a Rasp Pi 2.
I can connect to the Pi while it is attached by Ethernet, but am unable to set up the wifi.
I know that there is supposed to be an option to use a hotspot, but that is not working for me - presumably because my usb wifi dongles are old - but if that doesn’t work I should be able to set up wifi while linked to the Pi by ethernet.
I have set up Network > Wireless Network:
Wireless Networking: On
Automatic IP: On

Hotspot: Off

I can see no way to select which wifi network I can link to.

Any advice appreciated.

If you can’t see any wifi network, then your wifi dongle is not supported. Volumio does not work with every possible dongle, but with 90% of them.

Can you be more specific about the dongle used?
What do lsusb and lsmod commands give?

Thanks for the replies.
I’ve now upgraded to the latest version 2.163.
Whether it is because of the upgrade, or something I’m doing differently, i’m not sure, but I can now see wifi networks.
This is the process I’m following

  1. Plug in ethernet cable - WiFi dongle not plugged in.
  2. Power on the Pi
  3. Go to Network Settings page.
  • Note that Wireless Network is switched off.
  1. Plug in wifi dongle
  2. On Network settings page, switch on Wireless network and click Save
  3. Refresh page - can no longer be reached.

Start again.
Steps 1- 3

  • Wireless Network is still switched off
  1. Plug in wifi dongle
  2. Switch on Wireless Network and Hotspot and click Save
  3. Wifi networks visible ** WOO HOO!! **
  4. Select my wifi network, type in password and validate (unhide password)
  5. Select CONNECT
  • notification appears saying network will restart
  1. On my router’s page, no new Volumio client is showing - only the previous Volumio with ethernet connection
  2. Unplug ethernet on Pi - now no connection (hardly surprising, but just had to check)
  3. Restart Pi with wifi dongle plugged in and no ethernet plugged in.
  4. Volumio wifi hotspot appeared for just a moment. Tried to connect to it. Then it disappeared.

In an earlier iteration I managed to connect to the hotspot, but as that is only used to select a wifi network, I don’t think it gets me any further forward.

As you can see, I’m bouncing around a bit here. The dongle I’m using is a very generic wireless n adaptor. But it has worked with other Pi configurations in the past.
If you believe a different/better wifi dongle is the answer, I’m happy to get one, but would prefer not to buy a more expensive dongle without some reasonable belief that it is the solution.

@macmpi: I’m sorry, but I don’t know how to drive command-line functions. Happy to learn, but I’m unable to answer your question right now.

Any further advice would be greatly appreciated.

Nice and simply, preferably with a newly flashed image, attach wifi dongle without ethernet and boot your RPi. Leave it afew minutes and then can you see a wifi network called Volumio? If so, can you join that network with password ‘volumio2’?

If that fails then switch off RPi, attach ethernet and boot your RPi. Access the Volumio UI through your browser, and turn on wireless networking. Refresh your browser screen, and look if you can see any wireless networks. Sometimes I find that I have to repeat the switching on of the wireless to get it to actually occur.

HI chsims1,
i appreciate your efforts to help.

Although I can only sporadically see the Volumio hotspot, I have managed to see the available wifi networks by connecting to ethernet without a wifi dongle attached, then attaching the dongle. This then allows me to see wifi networks. I have entered the password for my wifi, and I can see that it is stored - I don’t need to enter it each time.

The problem seems to be that the setting to switch on wifi on the RPi is not being stored: Every time I go to Network Settings, I have to switch on the wifi.

Presumably, when I unplug the wifi then restart the Pi, wifi is switched off, so it is unable to connect, even though I have entered the wifi password.

What do I have to do to make it save the wifi-switched-on setting?

Thanks again for your help

I don’t know what I did differently, but I just managed to get it to connect to the wi-fi!
To those who offered assistance, thanks for your patience.

So, to repeat for anyone else, the steps I used (with a Pi 2)

  1. Plug in ethernet, but not usb dongle
  2. Power up the pi
  3. Plug in usb wifi dongle
  4. Switch on wifi in network settings and select your network.
  5. Click Save.
  6. When you reload the page, you should see two connection ip addresses at the top, one for ethernet and one for wifi
  7. Unplug ethernet, and connect to the wifi ip address.

While your Pi has working network connection (presumably ethernet), connect to it from another machine with ssh client (Putty app if you are on Windows) with volumio:volumio user:pass

But I also assume your dongle may have some brand & model names printed on it: this would also help identifying it…

This is not something you can force: it does translate that Volumio indeed fails in starting-up wlan, so it remains OFF. We need to find the reason…

Hi MacPi,

Thanks for the explanation. lsusb and lsmod output below.
The exact brand of USB dongle - no specific brand as far as I know. Just a super-cheap one off eBay.
Frustratingly, the problem with wifi turning off seems to still be there. I successfully set up my Pi with Volumio by connecting by ethernet then plugging in a wifi dongle as described in an earlier post. I even managed to restart it and still connect. But today when I took it to its intended home (workshop sound-system) I was unable to connect. Still unable to connect when I brought it back inside until I used ethernet, at which point it once again connected with wifi too.

volumio@volumioworkshop:~$ lsusb
Bus 001 Device 004: ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
volumio@volumioworkshop:~$ lsmod
Module Size Used by
rpcsec_gss_krb5 21302 0
xt_REDIRECT 1340 1
nf_nat_redirect 1454 1 xt_REDIRECT
xt_tcpudp 2269 1
iptable_nat 1725 1
nf_conntrack_ipv4 12912 1
nf_defrag_ipv4 1428 1 nf_conntrack_ipv4
nf_nat_ipv4 4992 1 iptable_nat
cpufreq_stats 3463 0
nf_nat 12375 2 nf_nat_redirect,nf_nat_ipv4
nf_conntrack 77388 3 nf_nat,nf_nat_ipv4,nf_conntrack_ipv4
ip_tables 11637 1 iptable_nat
x_tables 12507 3 ip_tables,xt_tcpudp,xt_REDIRECT
nfsd 246430 2
cfg80211 427855 0
rfkill 16037 2 cfg80211
8192cu 519156 0
snd_bcm2835 20511 1
snd_pcm 75698 1 snd_bcm2835
snd_seq 53119 0
snd_seq_device 3621 1 snd_seq
snd_timer 19160 2 snd_pcm,snd_seq
snd 51844 7 snd_bcm2835,snd_timer,snd_pcm,snd_seq,snd_seq_device
bcm2835_gpiomem 3040 0
bcm2835_wdt 3225 0
i2c_bcm2708 4770 0
uio_pdrv_genirq 3164 0
uio 8000 1 uio_pdrv_genirq
i2c_dev 5859 0
fuse 83461 1
ipv6 347530 74
squashfs 29079 1
overlay 30212 1

It looks like a TL-WN822N v3 clone most probably; does it have 2 antennas?
Some of these are knowingly bogus for setting Hotspot operations (not Volumio specific), but should operate fine as wifi client.

Thanks for this bit!
Did you turn OFF Hotspot function (and saved) in Volumio Network settings preference panel?
With that, you confirm you can only have wifi working IF ethernet is ON at same time?
Feel free to follow this other thread.