Unable to see current song and queue in web UI


I’m a longtime user, but this is the first time I’ve had to post a question.

I just upgraded from Volumio 1.5, which was working fine and I would not have upgraded, but I wanted to use the Spotify connect plugin to unify my music playback devices.

I am now on System Version: 2.443 Released: Thu Jul 26 10:29:04 CEST 2018
Running on Raspberry Pi Model B Revision 1.0 (256MB)
With audio out via HDMI.

General usage is fine, Spotify Connect works well, and I can control MPD on Volumio from both my PC, using QMPDClient 1.1.2, and my Android phone using MPDroid 1.08 beta 4.

However, whilst the current song and queue are showing on my PC and Android clients (and also via MPC if I SSH in), they are not appearing in the Web UI.

The Web UI works to access the system menus and control the volume, but it is just not showing the current song and queue.

It was working after the initial install, however it got stuck displaying a track even though the playlist had moved on and only showed that one song in the queue. I cleared the queue from the queue tab, but ever since both the queue tab and the playback tab have been empty (i.e. the playback tab shows the controls, but not the current track playing). I have a feeling the track became “stuck” after I first used Spotify Connect, but I have no real evidence for that.

TBH this is not a major problem as all my clients are showing the correct info and I rarely use the Web UI, but it’s annoying and I’d like to fix it if I can.

Any suggestions would be appreciated.


Hi Dave, first I am surprised to see that Volumio2 works on a PI model B with 256MB of RAM. I would have never thought it would have worked…
(suggested is to have 1GB of RAM)

The issue you have is most likely tied to Spotify connect plugin. I suggest to talk with the developer about that.

Cheers for the quick response. :slight_smile:

Yeah, Volumio 1.5 (and RaspiFi before that) worked fine for years on that Pi so I just upgraded to Volumio 2 and, other than this minor problem it seems to be working OK as well :slight_smile:

I’ll try to contact the author (balbuze I believe), but I’m not sure the best way to do that.