Unable to install Volumio disk image on Pi Zero

After downloading the latest disk image and flashing it to my Micro SD card, I am trying to boot it on the Pi Zero. I’ve got a monitor connected and it seems to progress ok but then goes into a ‘job task’ indefinitely with no means of escaping except unplugging the Pi. I’ve googled around and it seems a number of people have the same problem, mainly due to the Zero not having an ethernet (only USB wifi dongles). I don’t have another Pi to try and despite trying everything I can’t seem to install it. Can anyone advise if there’s an updating working disk img that would get me started on the Zero?

Really hoping to get this working as I feel the tiny Zero is the ideal candidate for VOLUMIO.

Thanks in anticipation

Works fine on a RPi 0 here. You do need to leave it running for quite a while after the installation to let it sort stuff out.

may I ask, how long you have to wait? I am only running pie zeros, so shifting from 1.55 to the new version would be a great advantage

10 mins or so usually does it for me.

Yes, most probably a network config issue for those devices coming with no built-in networking ports (refer here).
Do you have any usb ethernet and/or wifi dongle attached to it?

You can try to hook-up a keyboard and hit ctrl-c when blocked, it may pass.
Then, a workaround is to modify /etc/network/interfaces and comment-out auto statements for the interface you do not have…
You may then have a side-effect at shut-down if any network volume (NAS) is mounted: it may delay shut-down quite a bit…less of an issue at this point.
Still related to networking start-up (and therefore shut-down) sequence, which may be fixed later.

PS: until this is fixed in Volumio code, modifying network settings in Volumio UI may reset /etc/network/interfaces to it’s original setting. So you may need to re-comment-out auto statement…

I usually have the edimax n 150 WiFi dongle attached only, I could add a usb-Ethernet device, though I guess mine is not supported out of the box…
If it is just a time question until I get wifi running, then it should be ok for me, as I can ssh your workaround manually.
I’ll receive a new pi0 tomorrow and give it a go this weekend.

Got it running, after out-commenting the auto ethernet statemend (as suggest, using a USB Ethernet device)
The next boot, with EDIMAX Wifi Dongle attached, the hotspot started and I was ablte to connect to my home wifi.

the phat DAC is working (pretending to have a HIFIBERRY DAC connected) out of the box. My only problem is the mounting of the NAS. I can add it, but I cannot guarantee it is working, as it is not displayed anywhere in the UI…

I failed to boot latest version of VOLUMIO(volumio-2.001-2016-10-15-pi.img) with PI ZERO too.

It outputs the following message:
[ *** ] Start job running for LSB: Raise network interface. ( **min **s / no limit )

I use PI ZERO with OTG USB HUB, zd1211b USB WIFI adapter, USB keyboard & mouse. and It works well with Rasbian.
Please help me.

Well the trick is to use an usb2ethernet adapter first to passby the Raise network interface. I could send you a version, where that process is out-commented, but I have to know, if your wifi adapter supports the hotspot possibility.

Thanks. I’ll buy USB Ethernet adapter and try it.

My setup:

RasPi Zero v. 1.3
EDiMAX WiFi dongle (connected with a micro USB to USB type A adapter)
8G microSD card with Volumio 2.001 (2016-10-15)

My problem:

The PiZero stalls on boot, even if I wait 30 minutes. WiFi hotspot is not available.

My solution:

Transfer the microSD card to my Rasperry Pi B 1.
Connect the RasPiB1 to the local network via ethernet cable.
Boot the RasPiB1. Wait. After boot, Volumio should be working properly.

In a terminal program from a computer connected to the local network, ssh into the RasPiB1:

ssh volumio@volumio.local

When prompted for the password, enter “volumio”.

Modify the /etc/network/interfaces file. To be safe, make a copy of the unmodified file:

cd /etc/network sudo cp interfaces interfaces.old
(Enter “volumio” whenever you are prompted for a password.)

Edit the interfaces file with the nano editor:

sudo nano interfaces

The original file looks like this, you want to delete the line that is “auto eth0” (in red):

auto wlan0
auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual

Then press x to save and quit the nano program.

I actually deleted the “auto eth0” line and the “auto wlan0” line, but you probably only need to delete the “auto eth0” line. I’m not sure why either of those lines are in this file. I did a little investigating from a Google search on “/etc/network/interfaces”. It seems like you should either include a line that has “auto eth0” or “allow-hotplug eth0”, not both.

Next, exit the ssh:


Turn off the RasPiB1 by navigating to volumio.local and selecting “shutdown” from the settings menu. Unplug the RasPiB1.

Transfer the microSD card to the RasPiZero. Plug it in and the wifi hotspot should be available after a couple of minutes.

Join the Volumio hotspot and go to volumio.local

From there, you can configure the network settings so the PiZero can join your local network like normal.

Hopefully, the next update of Volumio will have these changes in the /etc/network/interfaces file. If there is some reason why that can’t be done, would it be possible to offer a wireless Raspberry Pi Zero Volumio disk image for download that has these changes?


No need for alternate raspi to get things going.
Hook a USB keyboard (and HDMI screen to see what’s going-on): you may then hit Ctrl-C when Pi0 is stuck, and let it finalize boot.
Then you login on console (volumio/volumio) and edit /etc/network/interfaces, commenting-out the auto statement related to network interface you do not use (or both).

As said earlier, an open issue is logged here, so hopefully this will get fixed at some point.

Ctrl-C doesn’t work, as the boot gets stuck in a wait for the ethernet to initialise. (No time limit request).

Any other ideas, or do we have to go through plan A from the OP?


You may plug SD onto a PC, mount volumio_data ext4 partition, and then edit that partition’s volumio_data/dyn/etc/network/interfaces file

Unfortunately that will only work if volumio has booted up successfully for the first time, otherwise half the file system is missing.

I’ve also just tried the latest image in the hope that the problem had been fixed by now (v2.029), but unfortunately not.

I can confirm, seems that volumio_data is initially empty, so no way to edit config prior to successful boot.
Has anyone managed to resolve this without another pi device or USB Ethernet adapter? I don’t have any of these at hand.

Ok, so until this is fixed as reported here, here is a method to modify the original image on a linux machine (with squashfs-tools installed).
Mount the original SD on your Linux PC (your PC may do it alone)
extract the squashfs image onto some local directory
edit the relevant etc/network/interfaces as described previously
rebuild the squashfs image with the applied change
replace the squashfs file of the SD by the updated one.
unmount & cleanup

or on shell from the .img file (omit the mount related stuff if you work with mounted SD):

mkdir mytemp cd mytemp sudo mkdir /mnt/toto sudo mount -o offset=64000512 -t ext4 path_to/volumio-2.030-2016-11-19-pi.img /mnt/toto unsquashfs /mnt/toto/volumio_current.sqsh sudo nano squashfs-root/etc/network/interfaces (and comment with # the two auto statements, then ctrl-o, ctrl-x) sudo mksquashfs squashfs-root/ newimage.sqsh sudo cp newimage.sqsh /mnt/toto/volumio_current.sqsh sudo umount /mnt/toto sudo rm -rf /mnt/toto cd .. rm -rf mytemp
EDIT: Not anymore necessary and removed linked modified image as issue is fixed as of 2.036

Thanks for the efforts.
I have tested this image with USB WiFi dongle plugged in, here’s how it went:

  • Pi zero boots up to the login prompt, but with some “FAILED” and “ERROR” messages:
Failed to start LSB: DHCP server
ERROR: netdev:wlan0 already exists
  • As I couldn’t find Pi on the network (seems like it didn’t get IP address), I have replaced WiFi dongle with the keyboard and tried playing with the /etc/network/interfaces file, but sudo doesn’t seem to work, so no editing of interfaces was possible:
sudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit set

Btw, results of the:

ls -l /usr/bin/sudo


-rwxr-xr-x 1 volumio volumio

I have only one USB port available, so I need to unplug WiFi whenever I wish to type anything :slight_smile:.

Appreciate any further ideas…

At first boot, Volumio starts in hotspot mode: please read this.
If you are lucky and your wifi dongle is supported, then you may log into this hotspot with a wifi PC, Tablet or mobile phone, and then connect to volumio.local with a web browser.
From there, you may turn off the hotspot from Volumio UI, and join an existing home Access-point.

It remains quite challenging to start a rpi0 without ethernet dongle for now, particularly if wifi dongle is not supported out of the box and hotspot does not start…Also using a powered USB hub may help…(but some wifi dongle do not like them).

I managed to overlook hotspot SSID “Volumio” in the long list of neighboring WiFi networks (or didn’t wait long enough to see it up). Anyhow, now I got Volumio hotspot, I manage to connect to it, but don’t get the right IP address, therefore cannot access Pi zero -Volumio web interface.
Tried from several devices (PC, Android, Win phone), I get IP from APIPA range, which probably makes sense if I remember failed DHCP server message on boot.