Unable to install to eMMC

Volumio Version: 2.779
Hardware: Asus Tinker Board S

I have tried installing Volumio to the eMMC, being careful to use an 8GB SD card to ensure that it fits. I get the error message Install to Disk failed: undefined.

How can I fix this?

With the jumper settings from factory just plug the usb lead from the tinkerboard to your computer and install volumio to the tinkerboard as you would to a micro sd, unplug from computer and plug the tinkerboard usb to the power source and follow the same steps as for a micro sd :+1:

I can try that but I’m going to need to find a powered USB hub to power the Tinker Board, as it requires over 2A when booting up and I doubt my computer can supply that.

I’m still left wondering why the Volumio facility isn’t working, though.

i did it w/o a usb hub…

Hi dangermouse, I did as you suggest, flashing with etcher from a Mac. The procedure went fine, but Volumio does not boot. The yellow led of the TBS blinks and that’s it: no hotspot to connect to.
if I use the SD card, everything is fine.
I am using Volumio version released on June 8th

If its booting from the sd card then you need to look at the jumper settings so it looks at the eMMC for booting

I tried both jumpers combinations, but nothing happened.

I have upgraded to balenaetcher 1.5, factory-configured jumpers and reflashed: now Volumio successfully boots from eMMC.

Thanks, I have a Windows PC so I’ll try it with Win32DiskImager.

I use balena etcher on windows…

I didn’t know that existed. Thanks!

I can’t do it. The Asus is exceptionally current hungry on boot-up and shuts down every time. Even a powered USB hub can’t start it.

I’ll go back to trying it through Volumio after checking the jumpers.

Tried the jumpers in Parking and Maskrom positions. No joy.

Please help, Volumio!

There is another way to flash to eMMC using UMS mode.

  • Prepare an SD card with Volumio
  • Put the Tinker S in maskrom mode
  • Remove any devices, incl. ethernet
  • Take a USB cable and power the Tinker S from your PC (windows or linux)
    Tinker S now starts in UMS mode and will be connected to your PC as a USB storage device
  • Flash to that device as if it were an SD card.

Thank you, but as i said: I cannot power the Tinker S from either my PC or a powered hub.

do you happen to have a usb serial cable? Just try, for ums mode 500ma from the pc is enough.

Ok, thanks, I will try it.

No, it doesn’t work. As I said, my PC cannot power it and it shuts down soon after.

I’ve given up.

This must be a board issue then. During testing I always flash with ums mode. Which will fail everytime I don’t pull all other devices off.
Just wonder whether the serial console would give any hint.
Sorry not to be of further help.