Unable to boot Volumio on Cubox-i2

Hello there!
Happy with Volumio on Udoo, I’ve just received my new Cubox-i2 and tried to install Volumio on it.
I’ve downloaded the image from the site and using the torrent, I’ve extracted it with 4 different programs (on windows and even on a Mac), I have written the image with win32diskimagewriter about 12 times but nothing: I insert the mini-SD in the Cubox-i but nothing happens when I plug the power cable.
I’ve been able to boot geexbox on it but I want Volumio, of course…
Anybody could help me???
Thanks in advance

I’ve also got a Cubox-I2. It was also unable to boot volumio. I went and got another SD card, as well as another img file. It now boots, but only about 50% of the times i try.

The official Volumio image file doesn’t work at all.

Try this one instead: solved-wifi-cubox-t1117.html

Additional problems: that image file needs workarounds (described in the same thread) for USB dac to work. It also doesn’t work with SPDIF, at all. Additionally, i get pops and cracks with the sound once or twice each minute. Not acceptable at all.

The SPDIF doesn’t work with Geekbox either and i get the same pops and cracks with USB DAC there. This makes me think the Cubox-I needs a newer kernel, or is as shitty engineered as the Raspberry Pi. Or, you need an HDMI receiver. Shitty hardware and experimental software is a disaster for simple linux users such as myself. I’m not good enough with Linux to compile my own kernels.

After purchase of both Raspberry Pi and Cubox-I and none of them works as intended, i went back to my big Intel powered HTPC for now.


I received my cubox-i some days ago and experienced the same problem. The img file provided did noct work. I tried the solution in this post ( solved-wifi-cubox-t1117.html ) and finally got a booting system . Thank you for that.

I can see that a lot of work has been done to make this volumio version happen, this is a cool program.

But here is my problem:
I use the optical out on the cubox-i + external DAC.
Unfortunately the music stops playing after some seconds, pauses for aboout 1 second and the plays again for another 6-10 seconds an so on.
The DAC indicates that there is no signal from the spdif out during this time.
Tried to play around with the settings and buffer sizes in the setup without finding a solution.

I hope I can find a solution for that. Is these anyone with cubox-i using optical out without having these troubles?
Thank you in advance


I have written in two other threads here at Volumio without getting any attention. Mine booted once with the 3.10 kernal
and never after that. This report above that changing Flash card might help makes me start to think it’s a timing problem,
but what do I know as a newbee on this with Linux…

(( Phi

i had the same problem until i bought a highspeed microsd card and flashed it with volumio.
Now it works.
Might be that your cards are indeed to slow.

I can confirm that changing to a faster Micro SD Flash card did made Volumio run for me and I have restarted several times
and it has never failed once. No trying to make my USB DAC play but without success so far. Yes I have read this thread:

Yes a ready to run out of the box Volumio is high on my wish list ! :astonished:)

(( Per