Udoo quad usb issue

I’m still in trouble with volumio and udoo quad.
I was able (with lot of troubles) to update mpd to the latest version, so I solved the problems with my NAS, but I still can not hear anything. I connected to my dac (m-dac) volumio through hiface2 and when I try to play something remains completely silent.

In playback window the transfer value is 0 in Kb, while if I select the internal dac everything is working properly and the same happens if I connect hiface2 to my mac .
I’ve reimaged the sd several times and also I changed the sd with a new one
Has anyone had the same problem and can help me?

The problem is this?
If you try to change sample rate for example you see your mdac change the sample rate if you pass from16 bit 44.1 to 24 bit 96 knz but no music from it?
Same time I had this probrem, all the problem disappeared when I changed power supply with another one more powerful.
I suspect the udoo default power supply is a bit underpowered.
I don’t know what is the usb chip in mdac, it is xmos or other? And the usb is powered by mdac itself or trought usb connections?

Inviato dal mio SM-N9005 utilizzando Tapatalk

Have you tried connecting direct from the UDOO to the M-DAC without the HiFace? This should be possible and seems to me will remove another signal conversion in the path from source -> amp.

I should say that I don’t have a UDOO or an M-DAC, so this is guesswork on my part…

Good luck…

the problem occurs with both mp3 and flac with high resolution, I see the dac actually changing resolution, but I think that there is proper flow of data to the usb port. This problem occurs even if I connect directly to the dac with usb cable

I don’t understand…
The problem occur when you playng 44.1 khz or only with high res?
I have an udoo and a linear power supply 13v 4A, with the default power supply sometime I had problems … the dac changed the sample rate, all seem ok … but no music from the dac at any tipe of resolution.

Inviato dal mio SM-N9005 utilizzando Tapatalk

yes the problem occur with 16/44.1 files too

if you have a different power supply beetwen 12-15v and over 2a you can try if the problem go away.

Inviato dal mio SM-N9005 utilizzando Tapatalk

Anyway if anyone want to change the udoo quad with an utilite middle version I like to change :slight_smile:

Inviato dal mio SM-N9005 utilizzando Tapatalk

i tried to change the power supply with one with 14V and 3A, but still no output from usb
Mpd log file return to me an error like

alsa_mixer: Failed to set mixer for ‘Output’: failed to set ALSA volume: Invalid argument

I think tomorrow I’ll go to a macstore to buy a mac macmini

In the playback option what voice is selectioned in mixer tipe?

Inviato dal mio SM-N9005 utilizzando Tapatalk



I also have an Mdac and am very intrested to know if Volumio + Udoo will work with USB connection to Mdac.

Have you tried to connect Mdac directly via USB, without the Hiface interface? Did you succesfully get sound and joy? :wink: