Udoo first run experience


So trying volumio on Udoo and had a few issues

1- WiFi Connection
Not sure why but i couldn’t get the WebUI to successfully connect to my wifi network. I ended up having to connect a monitor and keyboard and editing /etc/network/interfaces to look the same as the equivalent on my raspberry pi volumio setup.

2- NAS Drive
I can’t seem to get Volumio on Udoo to connect to my NAS drive, even if i copy all the same parameters from the raspberry pi version.

3- Slow boot time
Seems like compared to the standard ubuntu udoo version, there is a long boot time for a headless volumio boot on Udoo. It’s not much quicker than the raspberry pi.

4- General instability
Seems to hang up / freeze for reasons i’m still trying to find a link for (i.e. particular menu selection etc)

Hopefully the above doesn’t sound like negative feedback, just a update of my first run at volumio on udoo and understand it’s all still in beta, so wanted to share my experience.


Thank you Dave, your feedbacks are precious. I try to give you some hints:

1: When setting up wi-fi, to save, just hit the second save button, then reboot Udoo and it should connect via wi-fi. Unfortunately Udoos’ wi-fi range is poor… But there’s a fix for that… Just solder an antenna on it :smiley: :smiley:

2- Try to connect via ssh and do

sudo apt-get update sudo apt-get install cifs-utils

reboot and let me know

3 - Yes, boot time is slow, I’m trying to understand why this happens…

4- Apc caching has been disabled on Udoo… That should explain that behaviour…

Please let me know how it goes, your feedbacks are the only one I received for Udoo so far. This will help me getting it better, since this board really deserves it…


So i did a clean install again on udoo.

1 - Wifi
So i tried the web ui again, it seemed to hang but looking no the SSH login i checked the settings and it seemed to update, restarted the udoo and it works. it now connects via wifi. albiet takes longer to load up than when wired connection.

2 - NAS
i tried the cifs update and no luck. Then i tried entering my NAS admin username and password into the web ui relevant sections and lo and behold it recognizes the NAS (even after reboot too). Which is strange as volumio on the Pi doesn’t require that information. 2nd to that is that it doesn’t update the libruary with the full NAS drive contents (i.e. only 2 folders) and i’ve left it “updating” for a while with no changes. I’m guessing it’s still not 100% there.

3- Antenna strength
you’re right, the udoo doens’t have that great an wifi antenna. check, will solder coat hanger onto udoo :slight_smile: just kidding but for me it still manages to get through a few rooms and my hifi is located in the same area as the wifi router so signal range isn’t a concern.

I agree, the udoo has allot of potential, i was playing with it’s ubunto version the other day, it’s actually quite impressive for a little device like that.



I managed to mount the drives using UDOO and Synology Nas.

In Raspberry I should use the sec=ntlm option but this did not work using UDOO. Using all other parameters but without the sec-option did make the UDOO mount the NAS :slight_smile:

Before that I did the cifs-utils update as recommended in this post but I’m not sure if avoiding the sec-option would have done the job by itself.

I did end up getting the Udoo to connect to the NAS with keeping all the standard settings as you mentioned but i also put in the word guest in the username section. That gets it connecting just fine.

There are still some issues with Volumio on the Udoo
1 - Wifi cannot keep up with hi-res music i.e. 24bit/96khz. On ethernet it’s fine with no skipping/stutter noises etc. As soon as i use the wifi on the udoo i get skipping/stuttering of music. I also noticed that when on SSH login there seems to be some lag at times from me typing and text appearing in the terminal window, once again this only happens when it’s on wifi as opposed to ethernet.
2- General instability on updating settings etc, just seems to hang at times and rebooting the udoo is the only fix but once it’s restarted the new settings are in place.

I wonder if the wifi driver is operating correctly or if the onboard wifi module is any good. My router and udoo are in the same room so signal strength shouldn’t be an issue.

I have a raspberry pi set up in the same area with wifi using volumio and it plays hi-res music from my nas without any skipping.


I am also running Volumio on Udoo :

  • Same issue with WIFI : unable to use it until now…

  • The Synology NAS has been connected using NFS : difficult due to the lot of parameters provided by the NAS DSM application (the last missing parameter was to update the accepted hosts with “*”)

  • Volumio seems to work correctly but I am unable to manage the audio output.

How do you handle the audio ouput ? HDMI or which other connectivity ?

Thanks for help


For output selection just go to playback and select output option, then save. You can use HDMI, analog jack or USB as outputs.
Yes, wi-fi range on Udoo is quite poor, not suitable for hi-res streaming… If you have a Wi-Fi dongle connected to the Pi which works, suggest pluggin into Udoo and see what happens…
To do that, after configuring wi-fi, connect via SSH to Volumio and edit /etc/network/interfaces/

sudo nano /etc/network/interfaces/

and change wlan0 to wlan1

then do

service networking restart

You should now be connected via the Wi-Fi dongle…

Let me know how it goes… I’m currently trying to deploy a fix for that (requires soldering an external antenna to Udoo)

just tried using the same wifi dongle that i use on the rpi, udoo doesn’t seem to recognize it

lsusb shows the device (it’s a rtl8192cu chipset) but lsmod, ifconfig do not show the device…

suppose udoo in thier build package didn’t think anyone would attach a wifi device and hence didn’t preload drivers like RPi did (?).

I’ll have a gander around and too see if i can get the driver and have a crack at installing it. will post back with success, fingers crossed :slight_smile:

Just received my Udoo Quad.
Powered via Kingrex Slap (Battery PSU) and Flashed with Volumio, it sounds… well… awesome :slight_smile:
much much better than Raspberry Pi!

Volumio is a bit buggy tho…
I had to restart MPD via SHH couple of times.

just waiting for sATA to eSATA cable (for now I’m using USB connection)

I’m not using WiFi or Nas so I can’t comment…

I like where this is going! (a lot) . I’m trying to decide on using the Rip or a Udoo board.

Can someone comment on the quality in sound difference these two boards produce? I’ve been reading people where having issue with Ethernet interference on the Rip.

I’ve had bad interference issues with Wifi on my audio systems so staying away from this. I like the idea of the Udoo board having a SATA interface, together with a SSD drive this might work nice and quiet with no networking latency or NAS interfacing issues.

I’m still trying to get my head around the DSD verses PCM playback possibilities on these two boards.

Also, can someone confirm, is the current Volumio version able to support Uboo I2S out?

I have spent a few nights struggling with UDOO wl networking…
UDOO per se is a very nice beast, its limitations seem essentially due to software problems, AFAIK,
but getting the wireless network to work reasonably is an issue both with Ubuntu and Volumio.
This is especially frustrating, as setting up the wired network is very strightforward, so you get
the impression that the problem is not in what you are doing…

First of all, I have not been able found any way to make everything work using Volumio network panel.
I was able set up the wired network with a static address, I confirmed with the top button, it took a while
and then it worked as expected.
Then I went to the wirelss SSID setup panel (the wireless ip address panel seemed disabled, no address
was shown, neither any active button), inserte the required data, confirmed with the bottom button,
and it remained apparently stuck. But I was connected via wired network: as a matter of fact, instead
it had just reset the wired connection to dhcp, and did not set up the wireless network at all…

After repeating this refrain again and again, finally I decided to go for manual setup. After a lot
of tests, I reached a working configuration, just to see it stop working after any reset or reboot…

After several other troubled hours, I think that I have finally found a definite pattern: setting up a correct
manual configurationis is not enough to make it work.

The situation is weird: everything seems correct, wl is up and (in cas of dhcp) has received an address, and
in some cases the router even lists the UDOO as a wireless client, but still UDOO is not reachable via wireless.

However, if you restart the network deamon, then everything start working correctly (apart a few strange
things I’ll write about later on).

If you now reboot by resetting or powering off (and maybe also via software, I am not sure) the wl does
not work any longer. Again, a restart of the network deamon solves the situation.

In the end, I added the network daemon restart command to the startup script, and now the wl seems to come
up correctly after any reboot.

I append here the files and changes I did hoping to be of some help.

One big caveat: I am still using WEP, even tough this is not safe at all: if you use WPA, things get more
complicated. This in any case affects only the wlan0 section, the rest does not change at all.

  1. login as root / volumio

  2. reconfigure network: edit file /etc/network/interfaces and make it similar to this:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static

auto wlan0
iface wlan0 inet static
wireless-essid TBNet
wireless-key 66666666666666666666666666
  1. to restart automatically the deamon at the end of reboot, you should edit /etc/rc.local shell file.
    However in volumio this file is automatically replaced with a clean version after each reboot: so you
    have to edit this clean copy, which is /var/www/_OS_SETTINGS/etc/rc.local

Change it adding the following line just before the exit 0 line:

/etc/init.d/networking restart

For the key, I used the usual key sequence I always use in any wl router or client (the format is the hex
form, for WEP128 26 hex figures).

The strange things: during testing, please take into account that the system has a very strange behaviour
(I had a similar behaviour also with UBUNTU, so I suppose it is related to UDOO hw).
With the configuration file above (and with any other reasonable configuration…) you should get two
different, separated addresses for eth0 and wlan0: the strange fact is that instead

  • when wired network is up and wire connected, both addresses are reachable by ping, even though the
    wl connection does not work at all.
  • when wl is up and running, and the wire is fisically disconnectd, then again both addresses are reachable.
    So for any test of the wireless connection, you must fisically disconnect the wired network.

Good luck… and let me know if you find any different behaviour.


@Michelangeloz: just FYI, if you’ll ever find the time to look into it

  1. at a certain point in test I found in the interfaces file the key inserted by Volumio panel:
    if was the string I entered, but encoded in hex (in the example above it would have been 3636363636363636…),
    so I assume this might be one of the problems.
  2. after the weird reset of the configuration experienced while trying to setup wl with the Volumio panel, the
    interfaces file was in facts devastated…


Just got my udoo board this afternoon. I spent some time loading the software and connecting it up. So far it has not stayed connected for too long. It plays for 10-15 minutes and then turns off. I can detect the udoo using Fing. I cannot, however, connect to it via the browser or via the Sound@Home app. If I shut it down for a few minutes, restart and wait a few minutes then it starts working again.

I have successfully used my NAS to play music. Everything is being done with a wired connection to my network. Having read the stories about wifi on the udoo I thought it would be easier to start this way. I am playing through the HDMI output into a Yamaha AV receiver.

Any suggestions?



I think I have progressed a little further. I am wondering whether my issue is related to an hdmi sleep post elsewhere. I have restarted my udoo with an analog audio cable output from the udoo. I am getting no sound from this but volumio has kept running for the last 30 minutes or so. Unfortunately I cannot find the uEnv.txt file mentioned in the hdmi sleep post so cannot try that modification.


A quick followup. I had a downstream hardware problem with the analog cable output. This is now working and seems to be running well. I am able to run music off of both my NAS and also web radio.

And a little bit further today. I found the change to mpd.conf that enables the reading of m4a files.

I downloaded a couple of sample tracks from audiogate.bluecoastrecords.com/ to see whether I could get them to play. They are recognized by the player but they do not play.

I believe there are two things with the wireless.

/etc/modprobe.d/alsa-base.conf -> remove the ‘#’ in front of “options snd-usb-audio index=-2”

I believe the above is conflicting with the wifi dongle on bootup.

Just need to run “aplay -l” and see what number your dac is and then modify the /etc/mpd.conf file to have

audio_output {
type “alsa”
name “DAC”
device “hw:X,0”

where the “X” above is the card number of the DAC you want from “aplay -l”

by doing the above I don’t get the long and erratic loading of volumio.

I find the RT5370 wifi module that comes standard with udoo board to not be able to keep up with HD music (24bit), it however manages to keep up with CD quality (16bit). You can see it being buggy in SSH when typing, certainly slow.

I edited the “/etc/network/interfaces” and added after the wireless lan setup part
“wireless-power off”

reboot or restart the network or from root “iwconfig wlan0 power off”

I should note, the wlan section should be before the eth0 section. otherwise it wont boot well.

This turns the power management setting for the wifi module off, it may run hotter (meh) but your SSH logging shouldn’t be so twitchy anymore

This may improve performance but not enough for it to stream 24bit music on my system. I use a different usb wifi module now. Plenty of info on the net to suit your other usb wifi module if you want to add a different one.

  1. Mounting a nas

I found that it was easier to install cifs-utils and then manually edit the /etc/fstab file to create a mount and then symbolic link to the music folder shown in mpd.conf or edit the mpd.conf file to have the music directory as the nas mount location than using the volumio gui to mount the nas.

Works allot easier for me

  1. I found it too buggy with the volumio gui for settings changes on the current version of udoo.

I’ve done most of my mods through command prompt and editing the necessary files.

  1. boot time, i’m not sure how much better it is than the raspberry pi. I was really hoping for a quick boot time. With the pi allot of things work well on the gui side. The ubuntu distro’s boot’s really quickly compared to the debian / volumio. I suspect the current version of udoo could be greatly optimized on that front.

Anyways hopefully there is some info in the above that is of help to people who are having issues with volumio for udoo. i hear there is a new version in the works. I really hope there is a proper software fix for the wifi module. I’ve ended up using the ubuntu distro, installing mpd and using mpdroid but i just saw ympd looks like an interesting web mpd client.


I’m still having trouble with the HDMI audio output and the video going to sleep. I am playing the audio through an AV receiver with an HDMI connection. I have sound for 10 minutes and a login prompt appearing on my television. After 10 minutes the television goes blank and the audio stops. The udoo is still running - I can log into it using PuTTY.

I’ve been searching the web for solutions and have tried various combinations of
or setterm -blank 0

and I suspect that I am just not putting these in the right location. Any suggestions?