Turning off HDMI/composite to save power

Apparently, this command will turn off the HDMI and composite signals and save around 20mA

/opt/vc/bin/tvservice -off


Seeing as Volumio is headless and can be operated via SSH if need be, would this be a worthwhile addition?

The only problem I see is setting up wireless on a Raspberry Pi Model A which may need the video signal to start with.

I guess also, that having less electrical activity MIGHT potentially reduce interference and improve sound quality. Although more likely it will have no discernible effect.

Just thought it might be worth mentioning. :smiley:

Perhaps there could be a toggle in the “Services management” section of the system menu. I like tweakability, although I like the idea of keeping Volumio as simple as possible.

added to the “Suggest a Feature” Thread

any idea how to do this on a Cubox?

No idea! :smiley:

However, if this tweak is of any use, the tvservice command will have to be added to Volumio again, because it’s missing from the Volumio distribution. I’m afraid that don’t have the expertise to do it!

Along with this lines, it could be good to add also the possibility to stop spinning the HD if any. That can be done by keeping “hdparm” tool in the system.

Does hdparm work with USB HHD’s? If it does it would be a great addition IF there isnt a power problem to spin up the disk, this would require some testing. But both these options sound like great additions to the system / settings page

On the topic of saving power…

The Raspberry Pi cmdline.txt file includes this command:


And, according to this website http://elinux.org/RPiconfig#force_turbo_mode it means the following:

Volumio doesn’t really use many resources as it stands. Is there any need have force_turbo=1 when all processes are using very little? I know we’re talking minute amounts of power even with force_turbo=1, but many ARM devices (phones especially) work fine with dynamic frequency scaling.

See: switching-governor-performance-what-t410.html?hilit=cpu#p1936

Michelangelo stated that there were some lag troubles when it wasn’t turned on. He states that 800 is used but mine uses a stock 700.

Personally i believe it should be turned of, but the Governor should be told to set 700 as the minimal clock so over-clocking works dynamically. This can be done using arm_freq_min = 700

Thanks. Yeah, glitch-free music takes priority over power saving. I’ll leave it as it is.

Sorry for the delay. In my case, I have a HD with external PSU and yes, it is possible to use hdparm with that. However, I’m using XFS. I was not able to stop spinning with EXTFS for instance, even with anotime etc params when mounting it. XFS seems to be designed for big files (flacs, wavs, apes, etc in my case) and no problem so far, stopping after X minutes of inactrivity.

Running 1.51, I looked for the command and it was on my system. And it worked as well :slight_smile: with -s you get the status, -o turns it off (or --off) and you can turn it back on (-c) if you want. Just turned it off and let’s see how it goes :slight_smile: