Trying to solve GPIO conflict with remotePi Board

HI all,
I have a raspberry 3+ with iqaudio dac pro and a remotepi board.
I recently realized i had to make some hardware adjustements to have the system properly working due to a GPIO conflict between remote board and the DAC board.
Here you can see the official instructions.

I soldered the two open pads as required and than i decided to completely remove the pin n.12 (GPIO18) which connects the dac and the remote board,
instead of completely removing the copper trace wich starts from there.
I thought the result would have been the same (avoiding to break the board) but when i plug the power Rasp doesnt turns on.
Why is my solution wrong? Looking at the board a cannot see any difference between removing the pin and cutting the trace.
Thanks for any contribution or suggestion

Did you remove pin 12 from the Pi, the IQaudio DAC or the RemotePi board?

Could you post a picture of the result?

I removed pin 12 from the IQaudio Dac.
Here are the pictures: RemotePi Board and DAC board

I assume you did connect power to the RemotePi board (and not the Pi). In that case the Pi won’t start just by plugging in power. You would have to use the power button of the RemotePi board or a remote control that has be learned in to the RemotePi (as described here in the section “Configure the RemotePi Board to power on and off using your remote”).

If you have tried the above without success: Does the Pi start if you only connect the RemotePi board (and not the DAC)?

Yes, both of them.
first Plugged the remotePi board no power to the raspberry board using the button, only remote board lights up;
then plugged the rasb board and everything is ok.

At the moment I have no idea, except possibly a hardware defect. Did you check if there is +5V power on pins 2/4 of the RemotePi board’s connector to the Pi after pressing the power button?

I don’t know hot to check it… i only see the green led blinking

If you have a multimeter you could measure the voltage between pin 2 (+5V) and pin 6 or 9 (GND) of the RemotePi board’s connector.

You mean the LED on the RemotePi board?

Do the LED’s on the Pi light up or show any kind of activity after the RemotePi’s power button has been pressed?

What power supply are you using?

No multimeter at this moment.
The green led on the remotepi board.
The rasp seems to be completely unplugged, as if no power arrived.
At this moment iìm using the original rasp power unit (2.5A)

how do you quote parts of my msg? I can only do a simple reply :smiley:

That should be sufficient so it’s unlikely the PSU is the reason for your problem.

Did powering the Pi on using the RemotePi work before you modified the RemotePi board?

Highlight the text you want to quote and press “q”.

Yes, the board was ok as i tried to use it with rasp only. So something went wrong after soldering

Are you able to spot any mechanical damage on one of the electronic components?

I think i wouldn’t notice it even if there were…

Nothing obviously defect, IMHO.

I think the next thing to check would measuring if there’s power on pin 2/4 of the RemotePi board’s connector after pressing the power button as mentioned above. Maybe you can borrow a multimeter from someone. Be careful not to cause a short! :wink:

I’ll try… but just to be sure: pin which ones are pin 2/4 :smiley:

And what if i find there’s no power on pin 2/4?

On the RemotePi board:

The red coloured pins are pin 2 and 4 (+5V). The light blue coloured ones are pins 6 and 9 (GND).

Then the RemotePi board has probably been damaged somehow.

ok, you were very kind and helpful. Thanks
I’ll let you know what i’ll find.

Meantime a start looking for a new solution to safely start ad stop raspberry. I’ve already started a thread about this. :wink:

Good luck! :slight_smile:

Hi, hoping you’re still listening: I have verified that there’s power on pin 2 and 4. So maybe pin 12 powers something else before the cut?

Only after pressing the power button of the RemotePi or already before doing so?

No, pin 12 is not intended to supply power (GPIO 18 (PCM Clock) at Raspberry Pi GPIO Pinout).